Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

drop in power for a second
Reply
 
LinkBack Thread Tools Display Modes
Old 06 Jun 2005, 05:39 PM   #1 (permalink)
Young Scooby
 
stirus's Avatar
 
Join Date: Feb 2005
Location: sheffield
Posts: 78
drop in power for a second

Guys,

Anyone experienced an immediate drop in power ( almost none ! )when pulling off sometimes ?

Only lasts about 1-2 seconds before it picks up but its worrying me, I've always suspected a slightly rough clutch but Im not sure,


I swear one day Im gonna get hit in the side,

:shock:
Offline   Reply With Quote
Old 07 Jun 2005, 02:25 PM   #2 (permalink)
Regular Scooby
 
Join Date: Jun 2005
Posts: 175
how old is the car?
i m having the same prob with my old car( mitsubishi galent) exectp that when the cars cold the engine stops.
the repair shop said it was the cab that was bad, apparently to much air or something like that
Offline   Reply With Quote
Old 07 Jun 2005, 08:01 PM   #3 (permalink)
Administrator
 
skylight's Avatar
 
Join Date: Apr 2004
Location: Here and S.Wales
Posts: 13,155
Re: drop in power for a second

Quote:
Originally Posted by stirus
Guys,

Anyone experienced an immediate drop in power ( almost none ! )when pulling off sometimes ?

Only lasts about 1-2 seconds before it picks up but its worrying me, I've always suspected a slightly rough clutch but Im not sure,


I swear one day Im gonna get hit in the side,

:shock:
Is the car warm when this is happening? Or only when cold?

Thanks in advance
Offline   Reply With Quote
Old 08 Jun 2005, 04:16 PM   #4 (permalink)
Young Scooby
 
stirus's Avatar
 
Join Date: Feb 2005
Location: sheffield
Posts: 78
Cheers for replying chaps,

Its a 2002 STi,

Its usually when cold to be honest.


:?:
Offline   Reply With Quote
Old 08 Jun 2005, 06:32 PM   #5 (permalink)
Dedicated Scooby
 
Nelson's Avatar
 
Join Date: Apr 2004
Location: South West
Posts: 2,659
I assme you aren't running with Aircon on ??
Offline   Reply With Quote
Old 08 Jun 2005, 06:58 PM   #6 (permalink)
Administrator
 
skylight's Avatar
 
Join Date: Apr 2004
Location: Here and S.Wales
Posts: 13,155
This warm weather doesnt help either - have seen the car dip in response today... just not the same in this weather... Air con does take away resources when running also...
Offline   Reply With Quote
Old 08 Jun 2005, 10:56 PM   #7 (permalink)
Dedicated Scooby
 
Nelson's Avatar
 
Join Date: Apr 2004
Location: South West
Posts: 2,659
spot on Gar - Warm air and Turbos don't mix very well I'm afraid

Just wait until night time and then go for a drive - response will be restored the dip in power could be clutch related mate ?? However Aircon does take a sap of power when the compressor fires up ops:
Offline   Reply With Quote
Old 09 Jun 2005, 12:38 PM   #8 (permalink)
Young Scooby
 
stirus's Avatar
 
Join Date: Feb 2005
Location: sheffield
Posts: 78
I dont ever use aircon to be honest !

I suppose it could be the weather, I try and run it on optimax all the time, sometimes just super-unleaded so maybe its just running rough ?? I dunno.

My clutch has always been suspect to me though, its got just a slight judder sometimes and I just wonder if its something related to that maybe ??

Its the kind of thing I'd never be able to prove to the dealership on a test drive though.


Rus
Offline   Reply With Quote
Old 09 Jun 2005, 12:58 PM   #9 (permalink)
Administrator
 
skylight's Avatar
 
Join Date: Apr 2004
Location: Here and S.Wales
Posts: 13,155
Quote:
Originally Posted by stirus
I dont ever use aircon to be honest !

I suppose it could be the weather, I try and run it on optimax all the time, sometimes just super-unleaded so maybe its just running rough ?? I dunno.

My clutch has always been suspect to me though, its got just a slight judder sometimes and I just wonder if its something related to that maybe ??

Its the kind of thing I'd never be able to prove to the dealership on a test drive though.


Rus
The most annoying problem of all - :evil: Keep us informed, the more clues the better....
Offline   Reply With Quote
Old 09 Jun 2005, 06:40 PM   #10 (permalink)
Fresh Scooby
 
Join Date: Feb 2005
Posts: 30
Quote:
Originally Posted by stirus
My clutch has always been suspect to me though, its got just a slight judder sometimes and I just wonder if its something related to that maybe ??

Its the kind of thing I'd never be able to prove to the dealership on a test drive though.


Rus
Think the clutch might be a red herring mate, there are loads of threads on here about the juddering clutches a lot of Scoobs seems to have.

Does your clutch judder when pulling away from cold? Happens on mine (UK MY00), about 30% of the time, for the first 5 mins of a journey only, then gets better. No idea why it happens but been like it for 25,ooo miles (18 months) now. Clutch is still ok though, (no slipping).

No idea what your other prob could be though,

Good luck,
Cheers,

Mickey.
Offline   Reply With Quote
Old 09 Jun 2005, 08:06 PM   #11 (permalink)
Administrator
 
skylight's Avatar
 
Join Date: Apr 2004
Location: Here and S.Wales
Posts: 13,155
Quote:
Originally Posted by mickey
Does your clutch judder when pulling away from cold? Happens on mine (UK MY00), about 30% of the time, for the first 5 mins of a journey only, then gets better.

Mickey.
Hows you doing Mickey? This is a known problem with the classic scoobs and a real pain in the butt... My 99 turbo had a terrible time with the judder effect... Most classic scoobs experience this in their ownership life.

This (at present) doesnt seem true for the new age scoobs as very little has be identified with regards judder.(Subaru fixed the problem?)... Going back to the previous posts - air con hampers the new age massivly more than it does the classic. Have experienced both now and new age puts a dent in big time compared to the classic (can really feel the kick in) - im guessing a greater powered compressor kicking in -??
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
power sterring pump conversion gammi0025 Technical General 1 25 Oct 2007 04:00 PM
Power connector in trunk - purpose,fuse postlewt Electrical (Including ICE) 5 22 Oct 2007 05:28 PM
Info: Drop Links Tidgy Exterior 0 14 Jul 2006 10:42 AM
FREE POWER UPGRADES FOR IMPREZA WRX AND STi skylight Subaru Impreza Discussions 15 08 May 2005 11:04 AM
Kuwano Direct power system willfal Technical General 3 31 Dec 2004 04:44 PM


All times are GMT. The time now is 09:10 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.