Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

engine
Reply
 
LinkBack Thread Tools Display Modes
Old 08 Apr 2005, 11:27 PM   #1 (permalink)
jrk
Fresh Scooby
 
Join Date: Mar 2005
Posts: 9
engine

hi all
engine stops pulling around 3500-4000 rpm classic 2000 any ideas would be great
car seems to hesitate.could this be down to the dump value thanks for any help :4:
Offline   Reply With Quote
Old 09 Apr 2005, 02:38 PM   #2 (permalink)
Dedicated Scooby
 
Nelson's Avatar
 
Join Date: Apr 2004
Location: South West
Posts: 2,659
Hi mate

Sounds like its gone into Limp Home mode Have you got the check engine light come on ??

Can I suggest you check the ECU for fault codes......
Offline   Reply With Quote
Old 10 Apr 2005, 07:30 PM   #3 (permalink)
jrk
Fresh Scooby
 
Join Date: Mar 2005
Posts: 9
nelson

thanks nelson no engine light on.will check for ecu fault codes tomorrow.any link on how to do this would be great
Offline   Reply With Quote
Old 10 Apr 2005, 09:19 PM   #4 (permalink)
Dedicated Scooby
 
Nelson's Avatar
 
Join Date: Apr 2004
Location: South West
Posts: 2,659
HI mate

Check this post out this should be of use

http://www.subaru-impreza.org/subaru...pic.php?t=3144

Get back to us when you've done the ECU check cos there are some other things it could well be :wink:
Offline   Reply With Quote
Old 11 Apr 2005, 09:00 PM   #5 (permalink)
Dedicated Scooby
 
Nelson's Avatar
 
Join Date: Apr 2004
Location: South West
Posts: 2,659
Any luck ??

Did you sort it ?
Offline   Reply With Quote
Old 16 Apr 2005, 05:27 PM   #6 (permalink)
jrk
Fresh Scooby
 
Join Date: Mar 2005
Posts: 9
nelson

sorry it took so long to get back to you.done ecu reset and got a constant flashing light.have found that air is leaking from dump vavle could this be the problem
Offline   Reply With Quote
Old 16 Apr 2005, 09:19 PM   #7 (permalink)
Dedicated Scooby
 
Nelson's Avatar
 
Join Date: Apr 2004
Location: South West
Posts: 2,659
May well be mate - I mean a leaking dump valve is certainly not gonna help at all
Offline   Reply With Quote
Old 20 Apr 2005, 03:21 PM   #8 (permalink)
jrk
Fresh Scooby
 
Join Date: Mar 2005
Posts: 9
nelson

just replaced dump valve with factory one.still no good.see a thread about cleaning out boost solenoid done this seems abit better.had enough so took it to dealer said maf senser no good got another one all is ok [/img]
Offline   Reply With Quote
Old 20 Apr 2005, 04:07 PM   #9 (permalink)
Dedicated Scooby
 
Nelson's Avatar
 
Join Date: Apr 2004
Location: South West
Posts: 2,659
They really are the achilles heel of the Imprezas - just goes to show that the ECU didn't pick it up with a fault code light but the limp mode was enough to suggest a problem.

Just glad your managed to sort it ou - happy motoring mate 8)
Offline   Reply With Quote
Old 21 Apr 2005, 08:01 PM   #10 (permalink)
jrk
Fresh Scooby
 
Join Date: Mar 2005
Posts: 9
nelson

thanks for the help nelson.happy again
Offline   Reply With Quote
Old 22 Apr 2005, 07:26 AM   #11 (permalink)
Dedicated Scooby
 
Nelson's Avatar
 
Join Date: Apr 2004
Location: South West
Posts: 2,659
Good job
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
16 important OIL questions and answers oilman Technical General 0 23 Jan 2008 03:31 PM
Answers From The Oil Expert Part # 2 oilman Technical General 0 18 Oct 2007 12:57 PM
FORD'S BRIDGEND ENGINE BUILDERS PARCEL UP THEIR GOOD IDEAS skylight General Chat - Anything about Anything 1 19 Aug 2005 09:55 PM
OUTSTANDING NEW ‘BOXER’ ENGINE FOR ’06 LEGACY RANGE skylight General Chat - Anything about Anything 3 03 Aug 2005 10:15 AM
Which engine fits my '99 sedan turbo mirk Subaru Impreza Discussions 0 31 Jul 2004 09:46 AM


All times are GMT. The time now is 04:35 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.