Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

Problems with automatic gearbox
Reply
 
LinkBack Thread Tools Display Modes
Old 12 Jan 2010, 04:05 AM   #1 (permalink)
Fresh Scooby
 
Join Date: Jan 2010
Location: Ekaterinburg
Posts: 3
Problems with automatic gearbox

Hello there!
Briefly about my car:
model - 2001 impreza
1.5 litre engine
manufactured in Japan

Problems begun for about a month ago: indicator of "power" rate started to wink permanentry, and now rear gear switches with loud "thump" (maybe in diff).

I asked people in RuNet, but nobody can give definite answer for my problem
Somebody say - that's the problem with solenoid, others say - center differential.

Thanks for any help.
Offline   Reply With Quote
Old 12 Jan 2010, 09:31 PM   #2 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: Problems with automatic gearbox

First you check the oil in the box and diff as think their 2 dipsticks as said one for box and one for diff, is the right oil in it normally Dexron 2 or 3 for Automatics but find out to be 100% sure for the gearbox for your car, also did it have any problems just before that problem happen that if your put your foot to the floor on the accelerator pedal and when its in D did it find it hard to say (Kickdown) as in the gearbox to downshift a gear to get you into the right power band so you can accelerate fast, if that was the case it low on oil AND if not that the selector mechanism needs adjusting hope it helps
__________________
SEE NO EVO HEAR NO EVO!

Last edited by stiimpreza1984; 12 Jan 2010 at 09:53 PM.
Offline   Reply With Quote
Old 21 Jan 2010, 04:08 AM   #3 (permalink)
Fresh Scooby
 
Join Date: Jan 2010
Location: Ekaterinburg
Posts: 3
Re: Problems with automatic gearbox

I've checked oil level - normally.
I have never had problems with kickdown before and nowadays.

Yesterdey I solved this problem - diagnostics in service center showed cable breakdown in electrical circuit, and after replacement of solenoid "POWER" stopped winking.

Thanks anyway
Offline   Reply With Quote
Old 21 Jan 2010, 10:08 AM   #4 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,567
Re: Problems with automatic gearbox

Quote:
Originally Posted by Ice_Driver View Post
I've checked oil level - normally.
I have never had problems with kickdown before and nowadays.

Yesterdey I solved this problem - diagnostics in service center showed cable breakdown in electrical circuit, and after replacement of solenoid "POWER" stopped winking.

Thanks anyway
Can you supply the info that helped you?
It may be of use to others in the future.
thanks
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 04 Feb 2010, 03:32 AM   #5 (permalink)
Fresh Scooby
 
Join Date: Jan 2010
Location: Ekaterinburg
Posts: 3
Re: Problems with automatic gearbox

Cable breakdown was in rear gear solenoid, and that was the reason of thump, when switching gear
That's all information I know
Offline   Reply With Quote
Old 01 Nov 2010, 07:04 PM   #6 (permalink)
Fresh Scooby
 
Join Date: Feb 2010
Location: wales
Posts: 7
Re: Problems with automatic gearbox

i have a problem with mine,when you go thru the gears it gets to 3rd and it feels like a clutch slipping.ive put new dex 3 oil in but no difference
Offline   Reply With Quote
Old 15 Jan 2011, 10:19 PM   #7 (permalink)
Fresh Scooby
 
Join Date: Jan 2011
Posts: 1
Re: Problems with automatic gearbox

I have the same problem to, it's a 95 wrx wagon import, you put it in drive and you can hear it go through the gears when taking it slow, but when i push it, it will do first and second fine but when it gets in third it boosts and revs up like it's not holding the gear. gearbox oil levels are perfect, not to sure about the diff oil will check in the morning, but does any one have any ideas?

cheers
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Catalunya 5MT gearbox problems when on track jonno_tt Technical General 3 26 Apr 2009 04:02 PM
Gearbox problems freemoyoyo Engine Bay 7 21 Nov 2008 05:35 PM
Gearbox whining problems BaileyWRX Technical General 3 31 Dec 2007 12:00 PM
[CHEVROLET] THE NEW CHEVROLET MATIZ 0.8SE AUTOMATIC skylight World Wide Automotive - News / Discussions 0 18 Nov 2005 08:33 PM
OUTSTANDING NEW ‘BOXER’ ENGINE FOR ’06 LEGACY RANGE skylight General Chat - Anything about Anything 3 03 Aug 2005 10:15 AM


All times are GMT. The time now is 12:44 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.