Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

Boost on a version 1 STI
Reply
 
LinkBack Thread Tools Display Modes
Old 27 Sep 2009, 05:39 PM   #1 (permalink)
Fresh Scooby
 
Tom991981's Avatar
 
Join Date: Mar 2008
Location: Kent
Posts: 41
Boost on a version 1 STI

Hi All,

Hope you can help!

I got a ScoobyECU type chipped ECU mapped to boost up to 1.15bar.
Took it down to Surrey rolling road at the weekend. First up I have no doubt in the chip's map as I know who mapped it.


Original SA ECU made 0.95bar with a slightly erratic fueling graph (Jap octane limits I presume). 260bhp.


Chipped ECU ALSO made 0.95bar, 260bhp BUT a much safer fueling map (for uk fuel) BUT should have been hitting 1.15 bar. Had an almost identical power curve and boost curve to the SA.


SO is anyone able to suggest a reason why boost is being restricted to 0.95 bar? I thought this was directly controlled by ECU? Both were nailed on 0.95 bar.
Anything I can try without reverting to a manual boost control device?


Notes:
Recently cleaned out the boost control solenoid and MAF
Charlie at Surrey R/Road noted turbo was a bit laggy -nothing to be concerned about its a 15yr old car
It's a v1 STI with no mods other than a HKS panel filter

Much appreciated!

Tom
Offline   Reply With Quote
Old 28 Sep 2009, 12:06 PM   #2 (permalink)
Super Moderator
Paid & Proud
 
Tidgy's Avatar
 
Join Date: Apr 2006
Location: Nottingham
Posts: 18,743
Re: Boost on a version 1 STI

was it mapped for the specific car? as in on your car?
__________________
PM, Squirrels best friend, cream egg king and resident .org spam tart/Perv
Offline   Reply With Quote
Old 28 Sep 2009, 12:52 PM   #3 (permalink)
Fresh Scooby
 
Tom991981's Avatar
 
Join Date: Mar 2008
Location: Kent
Posts: 41
Re: Boost on a version 1 STI

It was mapped for my specific model but not on it. It is similar to the Polar Performance chip I believe, i.e. some of the maps were co-developed by the same group of chaps some time ago (its not an ebay "special")

I would like to work on the premise that the map/chip is fine, its been run on a rolling road (Charlie Wright at surrey rolling road who also knows the developer of the map) so I know it to be a safe map (definitely safer than the original STI chip was running in my stock SA ECU and almost identical power delivery) and some other factor is restricting boost to 0.95 bar.

Things i am guessing at and other more knowledgable people can put me right...
1) Tired Boost Control Solenoid (I cleaned it out recently and it clicks like clappers in diagnostic mode)
2) Leaky / perished old boost pipes (not changed in 15 years after all)
3) Restrictor pill (present) not allowing boost pass 0.95 bar (This seems like most likely to me?)

Cheers!
Offline   Reply With Quote
Old 28 Sep 2009, 12:53 PM   #4 (permalink)
Super Moderator
Paid & Proud
 
Tidgy's Avatar
 
Join Date: Apr 2006
Location: Nottingham
Posts: 18,743
Re: Boost on a version 1 STI

ah right, tbh i'd ditch it and get it mapped properly.

different maps react in different ways on different cars
__________________
PM, Squirrels best friend, cream egg king and resident .org spam tart/Perv
Offline   Reply With Quote
Old 28 Sep 2009, 01:06 PM   #5 (permalink)
Fresh Scooby
 
Tom991981's Avatar
 
Join Date: Mar 2008
Location: Kent
Posts: 41
Re: Boost on a version 1 STI

Respect your thoughts Tidgy and I know that's the stock response to any questions regarding chips, but after all that is how the STI cars were tunded at this age!

But if we can put that to the side for one moment my question still stands....

Do any of the reasons I specified make sense? Or are there any others? I thought boost was specifically managed by the ECU, what other factors determine the peak boost?
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
hitting boost cut, need help to lower boost mark191178 Subaru Impreza Discussions 12 01 Jul 2010 12:00 AM
3 port boost solinoid on a 93 wrx import T21CDR Engine Bay 1 24 Jan 2009 02:42 PM
help engine jerk and code 45 came up, boost no constant limfk7 Engine Bay 3 05 Sep 2008 01:46 PM
boost problem - need help! Big Dawg Engine Bay 2 13 Jun 2006 07:32 PM


All times are GMT. The time now is 04:37 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.