Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

help please
Reply
 
LinkBack Thread Tools Display Modes
Old 23 Aug 2009, 03:08 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Aug 2009
Posts: 31
help please

hi every1 i have a subaru wrx 2.5t 2006 , today when i was out in it i went to pull away from a junction and the car lost all power and the engine managment came on and wouldnt rev above 3000rpm then it started to rev upto 2000rpm its self, i stoped and the car off and started it and it reved ok but the engine managment light was still on it stayed on for a few hours then i went to the petrol garage put fuel in it then when i started it back up the light was off and it was ok since then ?????? any ideas what could be wrong with it thanks every1
Offline   Reply With Quote
Old 23 Aug 2009, 03:51 PM   #2 (permalink)
Super Moderator
Paid & Proud
 
2002pete's Avatar
 
Join Date: Sep 2004
Location: UK
Posts: 14,377
Hi, it sounds like your car went into "safe mode" restricting your revs. It could be faulty sensor. Basicaly the engine managment will light whenever a problem is detected. If the CEL comes on again I suggest you get your car checked for a fault/error code via the OBDII diagnostics port using a computer.
__________________
Pete.

Offline   Reply With Quote
Old 23 Aug 2009, 03:54 PM   #3 (permalink)
Fresh Scooby
 
Join Date: Aug 2009
Posts: 31
Re: help please

will the fault code still be stored in the ecu even if the lights off now
Offline   Reply With Quote
Old 23 Aug 2009, 04:12 PM   #4 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: help please

Quote:
Originally Posted by sandywrx View Post
will the fault code still be stored in the ecu even if the lights off now
Yes it will
__________________
SEE NO EVO HEAR NO EVO!
Offline   Reply With Quote
Old 23 Aug 2009, 04:19 PM   #5 (permalink)
Fresh Scooby
 
Join Date: Aug 2009
Posts: 31
Re: help please

thanks i will phone a garage tomorow to book it in , does any1 know if 1 of the snap on scaners will do my car
Offline   Reply With Quote
Old 24 Aug 2009, 07:49 AM   #6 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
Re: help please

the snap on scanner may come up with the codes,all depends if it's got the software application
__________________
Mapped by Enginetuner(Plymouth)..
Offline   Reply With Quote
Old 25 Aug 2009, 02:47 PM   #7 (permalink)
Fresh Scooby
 
Join Date: Aug 2009
Posts: 31
Re: help please

i got it on a computer today the fault code was p0607 control module performance
Offline   Reply With Quote
Old 25 Aug 2009, 09:45 PM   #8 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: help please

As Ed said above
__________________
SEE NO EVO HEAR NO EVO!
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 11:01 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.