Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

Up in steam :(
Reply
 
LinkBack Thread Tools Display Modes
Old 24 Sep 2004, 10:15 PM   #1 (permalink)
Regular Scooby
 
KaraK's Avatar
 
Join Date: May 2004
Location: Cumbria, UK
Posts: 189
Send a message via MSN to KaraK
Up in steam :(

I'm not having a good car week. Stopped to pick up some petrol after work only to be greeted by a large amount of steam coming from my front grille. Flicked the ignition back on and temp guage was really high.

Filled the coolant all the way up (it took about 3l) and then ran the engine for some time (air bubbles were coming up the coolant filler pipe for a while then slowed and stopped). No apprant sign of leakage. Gave the car a quick 5mile run and stopped again. Water level looked about the same, no sign of leakage, temp guage normal, drove about 25 miles (m-way 70-80 cruiusing) and stopped again. Water level - not sure if it had dropped or if memory was playing tricks. It was however still quite clearly visible in the filler tube. When I pulled away there was some water under the car, not a vast amount at all really. Again temp guage was completely normal. Drove another 60miles and stopped again. Water level appeared to be the same as previous stop (bad light so hard to tell exactly) - although if it had changed it cant have been significant. Ran engine for a coupla minutes while stationary and left car for about 5-10 mins. Came back and pulled away and no water where the car . Drove remaining 70 miles of journey, again temp guage normal. No suitable lights where I am no so havent checked water level. Will look in morning.

So whats the verdict guys... am I fecked?
__________________
Not even in the face of armageddon - never compromise
Offline   Reply With Quote
Old 25 Sep 2004, 07:26 AM   #2 (permalink)
Administrator
 
skylight's Avatar
 
Join Date: Apr 2004
Location: Here and S.Wales
Posts: 13,155
How long prior to this top up was the last top up KaraK?
Offline   Reply With Quote
Old 25 Sep 2004, 03:14 PM   #3 (permalink)
Dedicated Scooby
 
Nelson's Avatar
 
Join Date: Apr 2004
Location: South West
Posts: 2,659
As per Gars comment maybe you could tell us when you last topped up the water ??

If I had to take a stab at your problem I'd go for possible coolant sensor playing up or maybe a faulty thermostat ??

Deffo keep an eye on it though mate as the only other possibility if head gasket :shock: but on the basis the car seems to be holding the water then you may be lucky
Offline   Reply With Quote
Old 03 Oct 2004, 08:17 AM   #4 (permalink)
Regular Scooby
 
KaraK's Avatar
 
Join Date: May 2004
Location: Cumbria, UK
Posts: 189
Send a message via MSN to KaraK
sorry for the late reply guys... have been poorly all week (am still dog rough now). Basically I succeeded in spotting a drip from one corner of the radiator so we dropped some rad-weld into the system and then ran it for a coupla days. After this I had the boys at TEG Sport pressure test it and replace the coolant. Apparantly it pressure tested fine so thank god for that! I'm deffo going to keep a cloaser eye on the water level from now on!
__________________
Not even in the face of armageddon - never compromise
Offline   Reply With Quote
Old 03 Oct 2004, 10:49 AM   #5 (permalink)
Dedicated Scooby
 
Nelson's Avatar
 
Join Date: Apr 2004
Location: South West
Posts: 2,659
good to hear things are fine mate
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2006 Paris-Bercy Supercross gathers steam. News_Bot Moto-X News 0 13 Nov 2006 03:28 PM
2006 Paris-Bercy Supercross gathers steam. News_Bot Moto-X News 0 04 Oct 2006 01:04 PM
Engine Steam Cleaning Yam got a Scooby Technical General 3 26 Aug 2005 06:36 PM


All times are GMT. The time now is 04:55 AM.

Archive: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.