Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

sti boost problem
Reply
 
LinkBack Thread Tools Display Modes
Old 13 Jun 2009, 06:33 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Jun 2009
Posts: 19
sti boost problem

Hi all I need help I have a 03 sti with PPP running around 330bhp lately my boost level has dropped a fair bit. It would normally hit around 1.5/1.7 bar but now only hits around 0.5/0.6 bar then creeps up to 1 bar with the building revs. I don't think it is a boost leak as the problem goes sometimes then comes bak. I have cleaned my MAF sensor but does not seem to hav sorted the problem.
Any help would be much appreciated. James
Offline   Reply With Quote
Old 13 Jun 2009, 07:31 PM   #2 (permalink)
Regular Scooby
 
Join Date: Jan 2009
Location: essex
Posts: 133
Re: sti boost problem

boost solenoid???
Offline   Reply With Quote
Old 13 Jun 2009, 11:39 PM   #3 (permalink)
Fresh Scooby
 
Join Date: Jun 2009
Posts: 19
Re: sti boost problem

I'm not an expert sorry where is it? And how much would 1 cost?
Offline   Reply With Quote
Old 14 Jun 2009, 12:41 AM   #4 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: sti boost problem

http://www.subaru-impreza.org/forum/...agrams-222.jpg
The boost solenoid is the blue solenoid under the presure sensor its located top of drivers side just behind the airbox clean the lines with carb cleaner that should help also clean restrictor pill no harm when you cleaning solenoid anyway thats located just off actuator heres a link to it
__________________
SEE NO EVO HEAR NO EVO!
Offline   Reply With Quote
Old 14 Jun 2009, 12:43 AM   #5 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: sti boost problem

http://www.subaru-impreza.org/forum/...agrams-222.jpg
The boost solenoid is the blue solenoid to the side of the pressure sensor its located top of drivers side just behind the airbox clean the lines with carb cleaner that should help also clean restrictor pill no harm when you cleaning solenoid anyway thats located just off actuator heres a link to it
Hope it helps How Subaru's Factory Boost Control System Works v1[1] 01
__________________
SEE NO EVO HEAR NO EVO!

Last edited by stiimpreza1984; 14 Jun 2009 at 12:45 AM.
Offline   Reply With Quote
Old 14 Jun 2009, 08:59 AM   #6 (permalink)
jd
Obsessed Scooby
Paid & Proud
 
jd's Avatar
 
Join Date: Mar 2005
Location: here
Posts: 6,414
Send a message via MSN to jd
Re: sti boost problem

if you need to replace, you can get a turbosmart 3 port for about 60
__________________
blah blah blah
Offline   Reply With Quote
Old 14 Jun 2009, 11:48 AM   #7 (permalink)
Fresh Scooby
 
Join Date: Jun 2009
Posts: 19
Re: sti boost problem

ive cleaned the boost solenoid and the pipes but theres stil no change. any other ideas?
Offline   Reply With Quote
Old 14 Jun 2009, 12:11 PM   #8 (permalink)
Super Moderator
Paid & Proud
 
2002pete's Avatar
 
Join Date: Sep 2004
Location: UK
Posts: 14,377
Re: sti boost problem

Quote:
Originally Posted by bigjb View Post
i any other ideas?
Hi,


If the boost pipes to the solenoid are not the correct way round, this has been known to cause low boost. "Make a note of how they came off"
__________________
Pete.

Offline   Reply With Quote
Old 14 Jun 2009, 12:21 PM   #9 (permalink)
Fresh Scooby
 
Join Date: Jun 2009
Posts: 19
Re: sti boost problem

yeah i put them on the right way mate i maked 1 before taking it off
Offline   Reply With Quote
Old 14 Jun 2009, 03:37 PM   #10 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: sti boost problem

Quote:
Originally Posted by bigjb View Post
yeah i put them on the right way mate i maked 1 before taking it off
Are you positive its not a boost leak...............
__________________
SEE NO EVO HEAR NO EVO!
Offline   Reply With Quote
Old 14 Jun 2009, 03:48 PM   #11 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: sti boost problem

Actuators Have a look at this it might help sounds like your problem
__________________
SEE NO EVO HEAR NO EVO!
Offline   Reply With Quote
Old 15 Jun 2009, 07:20 AM   #12 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
Re: sti boost problem

have you got an aftermarket dummer fitted??
__________________
Mapped by Enginetuner(Plymouth)..
Offline   Reply With Quote
Old 15 Jun 2009, 09:08 AM   #13 (permalink)
Fresh Scooby
 
Join Date: Jun 2009
Posts: 19
Re: sti boost problem

sorry mate what is a dummer?
Offline   Reply With Quote
Old 15 Jun 2009, 09:15 AM   #14 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
Re: sti boost problem

dump valve
__________________
Mapped by Enginetuner(Plymouth)..
Offline   Reply With Quote
Old 15 Jun 2009, 09:17 AM   #15 (permalink)
Fresh Scooby
 
Join Date: Jun 2009
Posts: 19
Re: sti boost problem

yea its got a turbosmart on it mate
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
boost problem - stutter/judder under boost occuring Dazzaboy7 Subaru Impreza Discussions 8 06 Oct 2011 12:04 PM
boost problem gav2777 Technical General 5 27 Feb 2009 11:39 PM
boost cut problem (help) meldino Engine Bay 2 06 Aug 2008 06:59 PM
strange boost problem! doc__dave Engine Bay 11 30 Aug 2007 07:09 PM
boost problem - need help! Big Dawg Engine Bay 2 13 Jun 2006 07:32 PM


All times are GMT. The time now is 02:44 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.