Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

brake problem ;(..
Reply
 
LinkBack Thread Tools Display Modes
Old 09 Jun 2009, 09:08 AM   #1 (permalink)
Fresh Scooby
 
Join Date: Apr 2009
Posts: 3
brake problem ;(..

--------------------------------------------------------------------------------

hi all,can anyone help!!! i have a 1997 2.0L sport i goes well but for some reason i think that the brakes are binding,when i brake and then go i can feel the car slow down and stop then i can't move the car.if i turn the car off and leave it for a while its ok again.hope somone out there can piont me in the rite direction,thanx in advance.gazza
Offline   Reply With Quote
Old 09 Jun 2009, 09:27 AM   #2 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
Re: brake problem ;(..

sounds like the calipers are sticking on,could be a costly job,if the seals have gone.whip the wheels off and check for scoring on the discs,if your unsure,take it to a specialist
__________________
Mapped by Enginetuner(Plymouth)..
Offline   Reply With Quote
Old 09 Jun 2009, 05:32 PM   #3 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: brake problem ;(..

As Ed said^^^^^^^^^^^^
__________________
SEE NO EVO HEAR NO EVO!
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird Tail light / Brake light problem!! saxywigs Electrical (Including ICE) 7 12 May 2009 07:23 PM
94 WRX rear brake pad problem bigcat450 Technical General 1 15 May 2008 09:46 PM
ECU Data Fault Codes 2002pete Electrical (Including ICE) 2 25 Apr 2007 07:59 AM
STi braking problem ! Anybody else experienced this ? torrekens Subaru Impreza Discussions 10 24 Feb 2005 11:56 AM
Brake problem when wet. torrekens Technical General 0 09 Feb 2005 11:39 AM


All times are GMT. The time now is 11:54 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.