Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

Worst problem Ever.Need help please!!!
Reply
 
LinkBack Thread Tools Display Modes
Old 26 Apr 2009, 07:18 PM   #1 (permalink)
Fresh Scooby
 
TUNER's Avatar
 
Join Date: Dec 2008
Location: Blackburn
Posts: 41
WORST PROBLEM EVER NEED HELP PLS!!!

Hello Guys, im new to this forum an i would like to say hello.Im known as muzzy and im from manchester.

I need your much needed advise please. I bought a version 6 sti and unfortunately hit the drivers side which has now been repaired. The problem that im having is that the brake pedal goes to the floor when the car is switched off but when pumped it gos firm.

I have bled the brakes numerous times in the right sequence but now when car is driven forward the brake pedal goes to the floor then when the car stops and you pump the pedal it goes firm again. There are no signs of leaks and the brake fluid level has remained the same when topped up. The discs and pads are ok aswell.

Please could you assist in this matter. Thanks

Last edited by TUNER; 26 Apr 2009 at 07:58 PM.
Offline   Reply With Quote
Old 26 Apr 2009, 10:18 PM   #2 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
Re: Worst problem Ever.Need help please!!!

sounds to me like a caliper problem bud,maybe one of the pots it sticking!!
__________________
Mapped by Enginetuner(Plymouth)..
Offline   Reply With Quote
Old 26 Apr 2009, 10:30 PM   #3 (permalink)
Dedicated Scooby
 
nobby248's Avatar
 
Join Date: Aug 2004
Location: Cardiff Wales UK.
Posts: 2,744
Send a message via AIM to nobby248
Re: WORST PROBLEM EVER NEED HELP PLS!!!

Quote:
Originally Posted by TUNER View Post
Hello Guys, im new to this forum an i would like to say hello.Im known as muzzy and im from manchester.

I need your much needed advise please. I bought a version 6 sti and unfortunately hit the drivers side which has now been repaired. The problem that im having is that the brake pedal goes to the floor when the car is switched off but when pumped it gos firm.

I have bled the brakes numerous times in the right sequence but now when car is driven forward the brake pedal goes to the floor then when the car stops and you pump the pedal it goes firm again. There are no signs of leaks and the brake fluid level has remained the same when topped up. The discs and pads are ok aswell.

Please could you assist in this matter. Thanks
Hi,
hydraulic action... compress fluid highly enough and it acts as solid... so either there is not enough pressure or the fluid is not being compressed

So if you say no fluid is being lost... it follows that the fluid is not being compressed enough... so master cylinder first suspect.... then air in system... ?

Modern cars mostly have an air operated 'servo' the servo works by adding pressure to compress the brake fluid without the driver having to push really hard on the brake pedal.... as it works by air being sucked out by the engine when it is running.... when you switch of your engine the servo assistance stops working and the pedal will go hard and be difficult to depress

I suspect you may have a faulty brake master cylinder?

Hope this helps.... you need to take it to a mechanic to get the above confirmed.... the only other thing that jumps to mind is contaminated brake fluid? but you say you have bled the whole system so unlikely

Good luck

Nobby
__________________
Poor but happy!
Offline   Reply With Quote
Old 26 Apr 2009, 11:52 PM   #4 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: WORST PROBLEM EVER NEED HELP PLS!!!

Quote:
Originally Posted by TUNER View Post
Hello Guys, im new to this forum an i would like to say hello.Im known as muzzy and im from manchester.

I need your much needed advise please. I bought a version 6 sti and unfortunately hit the drivers side which has now been repaired. The problem that im having is that the brake pedal goes to the floor when the car is switched off but when pumped it gos firm.

I have bled the brakes numerous times in the right sequence but now when car is driven forward the brake pedal goes to the floor then when the car stops and you pump the pedal it goes firm again. There are no signs of leaks and the brake fluid level has remained the same when topped up. The discs and pads are ok aswell.

Please could you assist in this matter. Thanks
Did this just happen after the car got hit drivers side? if so was the caliper replaced with a new one drivers side? if the caliper was not replaced Id say its a caliper issue if the caliper was replaced with a new one Id go with Dean on the Master cyclinder it might be acting up or it still could be servo unit got to get it checked out fella
__________________
SEE NO EVO HEAR NO EVO!
Offline   Reply With Quote
Old 27 Apr 2009, 06:11 AM   #5 (permalink)
Fresh Scooby
 
TUNER's Avatar
 
Join Date: Dec 2008
Location: Blackburn
Posts: 41
Re: Worst problem Ever.Need help please!!!

Thanks for your replys guys, ha that rhyms..

I didnt change the caliper and this has only started to happen after the accident. Ill change the brake cylinder first as this is the cheaper option and then if there is no resolution ill then be in touch but i will keep you posted.

Just miss driving my scooby
Offline   Reply With Quote
Old 27 Apr 2009, 07:57 AM   #6 (permalink)
Regular Scooby
 
subaru5468's Avatar
 
Join Date: Feb 2009
Location: Worcestershire UK
Posts: 92
Re: Worst problem Ever.Need help please!!!

I had the same problem the cause was a front wheel bearing jack the car and check play from side to side and top and bottom of the wheel
Offline   Reply With Quote
Old 27 Apr 2009, 10:01 AM   #7 (permalink)
Fresh Scooby
 
TUNER's Avatar
 
Join Date: Dec 2008
Location: Blackburn
Posts: 41
Re: Worst problem Ever.Need help please!!!

I didnt think a wheel bearing would cause the brake pedal to feel the way it is? will check the wheel bearing for play
Offline   Reply With Quote
Old 27 Apr 2009, 10:35 AM   #8 (permalink)
Regular Scooby
 
subaru5468's Avatar
 
Join Date: Feb 2009
Location: Worcestershire UK
Posts: 92
Re: Worst problem Ever.Need help please!!!

If there is play in the wheel as u are driving along its pushing the pistons back in the caliper then when u pump it goes hard again if it was air in the brakes then the pedel would go to the floor even if u pump it
Offline   Reply With Quote
Old 27 Apr 2009, 05:53 PM   #9 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: Worst problem Ever.Need help please!!!

Quote:
Originally Posted by TUNER View Post
Thanks for your replys guys, ha that rhyms..

I didnt change the caliper and this has only started to happen after the accident. Ill change the brake cylinder first as this is the cheaper option and then if there is no resolution ill then be in touch but i will keep you posted.

Just miss driving my scooby
Going by your post here Id say its the brake caliper with out a douth tell me I'am wrong when you find out ands it not the caliper
__________________
SEE NO EVO HEAR NO EVO!
Offline   Reply With Quote
Old 27 Apr 2009, 07:24 PM   #10 (permalink)
Dedicated Scooby
 
nobby248's Avatar
 
Join Date: Aug 2004
Location: Cardiff Wales UK.
Posts: 2,744
Send a message via AIM to nobby248
Re: Worst problem Ever.Need help please!!!

Quote:
Originally Posted by stiimpreza1984 View Post
Going by your post here Id say its the brake caliper with out a douth tell me I'am wrong when you find out ands it not the caliper
me to....

good luck

Be interested in the cause, please let us know thanks

Nobby
__________________
Poor but happy!
Offline   Reply With Quote
Old 28 Apr 2009, 06:26 AM   #11 (permalink)
Fresh Scooby
 
TUNER's Avatar
 
Join Date: Dec 2008
Location: Blackburn
Posts: 41
Re: Worst problem Ever.Need help please!!!

Hi , just wanted to ask are the brake master cylinders the same for all the scoobys or are the sti ones different? A mate of a mate has one off a wrx 93 plate?
Offline   Reply With Quote
Old 28 Apr 2009, 05:32 PM   #12 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: Worst problem Ever.Need help please!!!

Quote:
Originally Posted by TUNER View Post
Hi , just wanted to ask are the brake master cylinders the same for all the scoobys or are the sti ones different? A mate of a mate has one off a wrx 93 plate?
I would imagine it different but some one will tell you for certain
__________________
SEE NO EVO HEAR NO EVO!
Offline   Reply With Quote
Old 23 May 2009, 07:19 PM   #13 (permalink)
Fresh Scooby
 
TUNER's Avatar
 
Join Date: Dec 2008
Location: Blackburn
Posts: 41
Re: Worst problem Ever.Need help please!!!

Hi guys, im back!!!!!

Made some progress with my scooby. Ive changed the master cylinder and bled the brakes still the same problem, then changed the caliper and bled the brakes again, same issue.

The brake pedal only goes to floor when the car is driven forward or backwards, the wheel bearing has no play in it either.

Just a point the brake disc it rubbing on just a 1/4 of the disc and when the wheel is spun you can see when the back shield goes wide then narrows and touches the disc then widens out again. Also the break pad on one side can be moved when the car is stood still not like the other side were the pistons on caliper are pushing the pads against the disc. Im thinking the disc is warped or the hub is bent?

Any ideas or suggestions would be grately appreciated.
Offline   Reply With Quote
Old 24 May 2009, 05:33 PM   #14 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: Worst problem Ever.Need help please!!!

A video or pic be great fella but the disc seems to be warped by what you saying take the disc off the car and place it on a flat table looking alround the disc looking for it warped you should have the same measurment alround the disc when measuring from the surface of the table to the edge of the disc if you know what I mean...............
__________________
SEE NO EVO HEAR NO EVO!
Offline   Reply With Quote
Old 25 May 2009, 10:22 AM   #15 (permalink)
Fresh Scooby
 
TUNER's Avatar
 
Join Date: Dec 2008
Location: Blackburn
Posts: 41
Re: Worst problem Ever.Need help please!!!

yep i know exactly what you mean im going to try it tomorrow see what comes of it. Ill try and get a vid on tomorrow aswell. If the hub was bent would that make the brakes act as they are doing. To me it makes sense to change it just to make sure.
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Power loss Problem, Please help - maybe clutch djquest Technical General 23 20 Oct 2007 05:02 PM
ECU Data Fault Codes 2002pete Electrical (Including ICE) 2 25 Apr 2007 07:59 AM
Another problem...GRRRRRRR sjay72 Subaru Impreza Discussions 1 07 Feb 2007 11:29 PM
MY99 Turbo ignition problem M-Tech Engine Bay 7 27 Aug 2006 06:56 AM


All times are GMT. The time now is 11:47 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.