Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

Surging...Still!
Reply
 
LinkBack Thread Tools Display Modes
Old 07 Mar 2009, 03:09 PM   #1 (permalink)
Cool Scooby
 
strat's Avatar
 
Join Date: Jan 2009
Location: Colchester
Posts: 325
Surging...Still!

Morning all!

Right I'll try to keep it as simple and short as possible....

As some of you might recall I had a surging problem. The guy who looks after the car tried a few thing to no avail so said he'd take it back for a few days and replace parts for ones that he knew worked to see how it went, all for free so can't complain.

Went to see him yesterday but still he couldn't find anything, all the diagnostics came back normal.

I'll try to explain when the surging happens. It only happens when the turbo kicks in between 2.5k and 5k (probably not the exact figures). Can't feel it at all in first or second, a little in third, bad in fourth and terrible in 5th. Car is fine below 2.5k and over 5.5k. If you were a passenger in the car you would say that I was lifting off the throttle (when flat to the floor).

I am really at a loss for what to do, spoke to a guy at work who has had a few scoobs and all he could suggest was...

Injectors shutting off (said about the boosted air pressure?)
Dump Valve (its a baileys one)
Actuator (he did go into detail but he lost me a bit )
Coilpacks
Crack in the turbo manifold

Its a definite boost problem, it doesn't affect anything else expect accelerating and it makes the car so disappointing to drive.

Some history, the cam belt was destroyed (somehow stayed in one piece) but messed up all the timing and was about a day away from it blowing up. It badly overheated and cracked the radiator. The car was not in a good way. All got sorted and car was much better Thinking that coilpacks don't like getting hot? there could be a crack and that when the boost is building its leaking from the crack? The turbo all seems fine, its not making any noise or chucking smoke out so I don't think its that.

Really really want to get it sorted, its ruining such an amazing car

Any Ideas?!

Strat

Last edited by strat; 07 Mar 2009 at 03:13 PM.
Offline   Reply With Quote
Old 07 Mar 2009, 05:35 PM   #2 (permalink)
Veteran Scooby
 
uk dave's Avatar
 
Join Date: Feb 2005
Location: Impreza Preservation Society HQ
Posts: 4,399
Send a message via MSN to uk dave
Re: Surging...Still!

Have you cleaned the boost solenoid?
__________________
Best sealant used to date- Fourstar ultimate paint protection *Now discontinued* Rebranded as sonus SFX4 paint sealant-Try some ya wont be dissapointed.
Offline   Reply With Quote
Old 07 Mar 2009, 05:46 PM   #3 (permalink)
Cool Scooby
 
strat's Avatar
 
Join Date: Jan 2009
Location: Colchester
Posts: 325
Re: Surging...Still!

I haven't, no, but i'd imagine the guy at the garage would have done that? (it had its yearly service a few weeks ago) If it hasn't been cleaned...how would I go about it? (think I've seen a post on here...will go look)
Offline   Reply With Quote
Old 07 Mar 2009, 06:13 PM   #4 (permalink)
Cool Scooby
 
strat's Avatar
 
Join Date: Jan 2009
Location: Colchester
Posts: 325
Re: Surging...Still!

found the post, little bit too dark now to clean it, will do it first thing in the morning. Did find something strange....the bracket that the boost solenoid is on has a black box type thing (about 3"x3"x3") that is just held on by a tie rap! leaving able to bounce all over the show!
Offline   Reply With Quote
Old 09 Mar 2009, 06:32 PM   #5 (permalink)
Cool Scooby
 
strat's Avatar
 
Join Date: Jan 2009
Location: Colchester
Posts: 325
Re: Surging...Still!

decided to go down the route of what it isn't rather than what it is.

Its not the turbo...no smoke no bearing noise
not the injectors....not misfiring

which lead me to the dump valve....baileys piston one....no idea how long its been on there or if its working 100% correct (didn't see it from new) so i'll going to see if they do a re seal pack. I'll update at the weekend
Offline   Reply With Quote
Old 09 Mar 2009, 10:20 PM   #6 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
Re: Surging...Still!

sounds like overboost to me,would suggest as Dave has,the boost solenoid is playing silly buggers
__________________
Mapped by Enginetuner(Plymouth)..
Offline   Reply With Quote
Old 10 Mar 2009, 12:45 PM   #7 (permalink)
Super Moderator
Paid & Proud
 
Tidgy's Avatar
 
Join Date: Apr 2006
Location: Nottingham
Posts: 18,743
Re: Surging...Still!

if needs be get it on a rolling road, will be able to see what the boost is doing
__________________
PM, Squirrels best friend, cream egg king and resident .org spam tart/Perv
Offline   Reply With Quote
Old 10 Mar 2009, 04:52 PM   #8 (permalink)
Cool Scooby
 
strat's Avatar
 
Join Date: Jan 2009
Location: Colchester
Posts: 325
Re: Surging...Still!

yea it did cross my mind about the rolling road. I was told by the guy at mocom racing that it was boosting 1.2

I'll get the boost solenoid cleaned, and see if there is anyone local with a working dump valve just to swap to see if it is that.
Offline   Reply With Quote
Old 13 Mar 2009, 06:42 AM   #9 (permalink)
Regular Scooby
 
Angelo_Pav's Avatar
 
Join Date: Oct 2007
Location: Barnet, Hertfordshire
Posts: 118
Re: Surging...Still!

Clean the boost control solenoid my friend. Mine had "exactly" the same problem and cleaning it cured the problem.

Good luck
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Power surging at high speed blythy Engine Bay 14 30 Jan 2016 11:06 PM
Engine Surging at high rev - Diagnosis help House Engine Bay 2 17 Oct 2008 07:12 PM
Dreaded surging problem help carswaps Technical General 1 24 Nov 2007 02:59 PM
2000 uk spec wrx surging under 3000 rpm carswaps Subaru Impreza Discussions 8 22 Nov 2007 01:04 PM


All times are GMT. The time now is 05:13 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.