Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

Idle problem
Reply
 
LinkBack Thread Tools Display Modes
Old 28 Feb 2009, 06:24 AM   #1 (permalink)
Fresh Scooby
 
Join Date: Jun 2008
Location: LANCASHIRE
Posts: 20
Idle problem

Hi Guyz

My type r version 4 is idling funny at the moment, at start up it will idle like it should and then once warmed up it idles up and down and sumtimes looks like it will stall. Any help will be much appreciated. oh btw i bought a new maf a month ago and it still does it.
Offline   Reply With Quote
Old 28 Feb 2009, 09:47 AM   #2 (permalink)
Veteran Scooby
 
rikimaru's Avatar
 
Join Date: Aug 2006
Location: Sussex
Posts: 3,335
Re: Idle problem

If you've changed MAF then could be Idle Control Valve.

Also, do you by any chance have an aftermarket BOV? Read thread on here before where an HKS BOV was the source the idling issue.
Offline   Reply With Quote
Old 28 Feb 2009, 10:21 AM   #3 (permalink)
Super Moderator
Paid & Proud
 
2002pete's Avatar
 
Join Date: Sep 2004
Location: UK
Posts: 14,377
Hi.



Link:Cleaning And Reattaching The IACV (Idle Air Control Valve) - NASIOC


Also have a look at the air-filter it could be clogged.
__________________
Pete.

Offline   Reply With Quote
Old 28 Feb 2009, 10:42 AM   #4 (permalink)
Fresh Scooby
 
Join Date: Jun 2008
Location: LANCASHIRE
Posts: 20
Re: Idle problem

yes rikamaru i have a baileys bov and pete is the iacv located under the intercooler? thanks for your replys.
Offline   Reply With Quote
Old 28 Feb 2009, 11:05 AM   #5 (permalink)
Super Moderator
Paid & Proud
 
2002pete's Avatar
 
Join Date: Sep 2004
Location: UK
Posts: 14,377
Re: Idle problem

Quote:
Originally Posted by type r_v-limited View Post
pete is the iacv located under the intercooler? thanks for your replys.
Yes, in front of the intercooler.
__________________
Pete.

Offline   Reply With Quote
Old 01 Mar 2009, 01:49 AM   #6 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: Idle problem

If you fitted the Maf sensor then id clean the iacv then failing that did this problem just happen after baileys bov?
Offline   Reply With Quote
Old 02 Mar 2009, 08:21 AM   #7 (permalink)
Fresh Scooby
 
Join Date: Jun 2008
Location: LANCASHIRE
Posts: 20
Re: Idle problem

Hi Guyz, i had the intercooler off yesterday and couldnt find the idle control valve, basically its probaly coz i dont know how it looks like. lol. does anyone have a picture of it so i can locate it?
Offline   Reply With Quote
Old 02 Mar 2009, 08:25 AM   #8 (permalink)
Super Moderator
Paid & Proud
 
2002pete's Avatar
 
Join Date: Sep 2004
Location: UK
Posts: 14,377
Re: Idle problem

Quote:
Originally Posted by type r_v-limited View Post
Hi Guyz, i had the intercooler off yesterday and couldnt find the idle control valve, basically its probaly coz i dont know how it looks like. lol. does anyone have a picture of it so i can locate it?

http://www.subaru-impreza.org/forum/...-diagrams.html
__________________
Pete.

Offline   Reply With Quote
Old 02 Mar 2009, 08:30 AM   #9 (permalink)
Fresh Scooby
 
Join Date: Jun 2008
Location: LANCASHIRE
Posts: 20
Re: Idle problem

Thanks for your kwick reply, so do u have to take the intercooler off or can you just leave it on? is it the one which has ABC printed on top?
Offline   Reply With Quote
Old 02 Mar 2009, 08:39 AM   #10 (permalink)
Super Moderator
Paid & Proud
 
2002pete's Avatar
 
Join Date: Sep 2004
Location: UK
Posts: 14,377
Re: Idle problem

Quote:
Originally Posted by type r_v-limited View Post
Thanks for your kwick reply, so do u have to take the intercooler off or can you just leave it on? is it the one which has ABC printed on top?
__________________
Pete.

Offline   Reply With Quote
Old 03 May 2010, 07:24 AM   #11 (permalink)
Fresh Scooby
 
Join Date: May 2010
Posts: 9
Re: Idle problem

Hi All
Could the Idle air control valve give you a boost leak? Mine has an air hose that goes back to the intake near the MAF (not MAP), I have really low boost atm but the suspect thing is that I can blow through this air hose from near the MAF all the way into the intake manifold. I would have said this would give me a boost leak however if I disconnect the air hose whilst running the car dies and if I disconnect it with the car turned off and block both hoses it won't start.
Cheers.
Offline   Reply With Quote
Old 03 May 2010, 11:43 AM   #12 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: Idle problem

Quote:
Originally Posted by Obscure View Post
Hi All
Could the Idle air control valve give you a boost leak? Mine has an air hose that goes back to the intake near the MAF (not MAP), I have really low boost atm but the suspect thing is that I can blow through this air hose from near the MAF all the way into the intake manifold. I would have said this would give me a boost leak however if I disconnect the air hose whilst running the car dies and if I disconnect it with the car turned off and block both hoses it won't start.
Cheers.
A pic of that hose would be great if you could take one it would explain it a bit better
__________________
SEE NO EVO HEAR NO EVO!
Offline   Reply With Quote
Old 04 May 2010, 02:11 PM   #13 (permalink)
Fresh Scooby
 
Join Date: May 2010
Posts: 9
Re: Idle problem

Hi,
Sorry about the late reply, I got stuck between work and the family. Photo attached. thanks for you help
Jade
Attached Images
File Type: jpg IAC Hose.jpg (68.6 KB, 22 views)
Offline   Reply With Quote
Old 05 May 2010, 12:30 AM   #14 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: Idle problem

That pipe you marked their are no holes or slits in the rubber hoses is their?
__________________
SEE NO EVO HEAR NO EVO!

Last edited by stiimpreza1984; 05 May 2010 at 12:35 AM.
Offline   Reply With Quote
Old 05 May 2010, 12:34 AM   #15 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: Idle problem

Quote:
Originally Posted by type r_v-limited View Post
yes rikamaru i have a baileys bov and pete is the iacv located under the intercooler? thanks for your replys.
Could you stick on the standard original dump valve as heard some people had issues with the baileys and it might be your problem
__________________
SEE NO EVO HEAR NO EVO!
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
High Idle Problem on Bugeye myles Technical General 3 06 Jan 2008 09:50 AM
ECU Data Fault Codes 2002pete Electrical (Including ICE) 2 25 Apr 2007 07:59 AM
MY99 Turbo ignition problem M-Tech Engine Bay 7 27 Aug 2006 06:56 AM
99 impreza turbo idle problem ??? Paolo Ch Engine Bay 7 28 Nov 2005 04:47 PM
Idle problem? Phill-type-R Subaru Impreza Discussions 12 16 May 2005 05:13 PM


All times are GMT. The time now is 11:47 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.