Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

Urgent please help.
Reply
 
LinkBack Thread Tools Display Modes
Old 26 Jan 2009, 12:06 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Nov 2008
Location: suffolk
Posts: 12
Urgent please help.

Car was running fine yesterday went for a drive round town in heavy rain start stop speed up/down etc. Came home and the car was juddery and holding back. Turbo is working/boosting as it should but the engine just dont want to go as it should. No signs of failed gaskets. Was thinking maybe water has got in somewhere? Any suggestions please.
Offline   Reply With Quote
Old 26 Jan 2009, 01:36 PM   #2 (permalink)
Veteran Scooby
 
uk dave's Avatar
 
Join Date: Feb 2005
Location: Impreza Preservation Society HQ
Posts: 4,399
Send a message via MSN to uk dave
Re: Urgent please help.

Possible coilpack problems depends if ya cars got em or not(maf maybe not water related may have just packed up they have to go sometime)no check engine light at all?
__________________
Best sealant used to date- Fourstar ultimate paint protection *Now discontinued* Rebranded as sonus SFX4 paint sealant-Try some ya wont be dissapointed.
Offline   Reply With Quote
Old 26 Jan 2009, 01:54 PM   #3 (permalink)
Fresh Scooby
 
Join Date: Nov 2008
Location: suffolk
Posts: 12
Re: Urgent please help.

No engine check light. Coil packs and maf sensor were replaced in 06. Ticks over fine and drives fine its just when you put your foot down.
Offline   Reply With Quote
Old 26 Jan 2009, 02:02 PM   #4 (permalink)
Veteran Scooby
 
uk dave's Avatar
 
Join Date: Feb 2005
Location: Impreza Preservation Society HQ
Posts: 4,399
Send a message via MSN to uk dave
Re: Urgent please help.

How many miles since then??and when were the plugs last changed,what type of air filter ya using std/induction kit?


Theres not actually that many places water would fcuk it when ya put ya foot down-could possibly be an earthing issue though would expect tickover to not be that clever aswell.


Like a slight missfire on acceleration on mine were too large a plug gap but to happen suddenly would be really strange.

(2006 is still a while ago for the parts mentioned)
__________________
Best sealant used to date- Fourstar ultimate paint protection *Now discontinued* Rebranded as sonus SFX4 paint sealant-Try some ya wont be dissapointed.
Offline   Reply With Quote
Old 26 Jan 2009, 02:25 PM   #5 (permalink)
Fresh Scooby
 
Join Date: Nov 2008
Location: suffolk
Posts: 12
Re: Urgent please help.

Powertec Induction kit fitted, coil packs 10/06 and maf sensor 01/07. Basically you put your foot down turbo spins up as it should but the car wont go its holding back and it kind of i suppose like a misfire thens its ok then it starts again. This all happens quickly and repeats as the revs build up. Is there anything i can do to check
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
URGENT mr freeze General Chat - Anything about Anything 18 23 Aug 2005 03:13 PM
New member needs urgent advice ... Pleeeease :-) mikehuff Subaru Impreza Discussions 6 10 Jul 2005 01:48 PM
URGENT ! ! ! ! ! ! !! ! ! mr freeze General Chat - Anything about Anything 5 09 May 2005 06:01 PM


All times are GMT. The time now is 10:29 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.