Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

Battery Charge Problems
Reply
 
LinkBack Thread Tools Display Modes
Old 12 Oct 2008, 11:06 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Sep 2008
Posts: 18
Exclamation Battery Charge Problems

Hi there, in the past year i've gone through 4 alternators and still seem to be havin a problem keeping my battery charged, i drive everyday so standing still for ages isn't an issue. I dont want to believe the other ones i've had were all shot so was wondering what else may be causing this problem, how do you know how much water should be in each cell?, thanks
Offline   Reply With Quote
Old 13 Oct 2008, 10:31 PM   #2 (permalink)
Super Moderator
Paid & Proud
 
Tidgy's Avatar
 
Join Date: Apr 2006
Location: Nottingham
Posts: 18,743
Re: Battery Charge Problems

sounds like an electrical fault wiping it out while the cars not running.

where abouts in the uk are you?
__________________
PM, Squirrels best friend, cream egg king and resident .org spam tart/Perv
Offline   Reply With Quote
Old 13 Oct 2008, 10:53 PM   #3 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: Battery Charge Problems

Sounds like an electrical fault alright would they be any way that you dont notice like a boot light or a glovebox light staying on constant cause that would drain power and be the problem stick at it you'll find it eventually hate problems like that you would go mad hope you find it Would you not go for a maintenance free battery they seem to be that bit better........................

Last edited by stiimpreza1984; 13 Oct 2008 at 10:55 PM.
Offline   Reply With Quote
Old 13 Oct 2008, 11:17 PM   #4 (permalink)
Super Moderator
Paid & Proud
 
Tidgy's Avatar
 
Join Date: Apr 2006
Location: Nottingham
Posts: 18,743
Re: Battery Charge Problems

Quote:
Originally Posted by stiimpreza1984 View Post
Sounds like an electrical fault alright would they be any way that you dont notice like a boot light or a glovebox light staying on constant cause that would drain power and be the problem stick at it you'll find it eventually hate problems like that you would go mad hope you find it Would you not go for a maintenance free battery they seem to be that bit better........................

boot light shouldn't be an issue as long as the battery is taking charge ok and alternaters charging it well, took month and half for it to drain the power out of the wreck of my old car lol
__________________
PM, Squirrels best friend, cream egg king and resident .org spam tart/Perv
Offline   Reply With Quote
Old 14 Oct 2008, 05:22 PM   #5 (permalink)
Fresh Scooby
 
Join Date: Sep 2008
Posts: 18
Re: Battery Charge Problems

i live in Northampton, alternator is kickin out bout 12.8v no load, i'm not even sure if this is normal, i just assume it is as its a 12v battery, think i will go maintenance free next time the sound of sloshin water each time i remove just isnt rite, lol!. i have loads of supid problems with my car but this is the most annoyin at the min.
Offline   Reply With Quote
Old 14 Oct 2008, 05:27 PM   #6 (permalink)
Fresh Scooby
 
Join Date: Sep 2008
Posts: 18
Re: Battery Charge Problems

i live northamptonshire, yeah it really is a pain in the arse to have to keep rechargin the battery every few days, lol!, i'm assumin the alternator is working as its kickin out bout 12.8v no load, well i assume thats right as i have a 12v battery, could be wrong though usually am!
Offline   Reply With Quote
Old 14 Oct 2008, 08:17 PM   #7 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: Battery Charge Problems

Quote:
Originally Posted by Tidgy View Post
boot light shouldn't be an issue as long as the battery is taking charge ok and alternaters charging it well, took month and half for it to drain the power out of the wreck of my old car lol

Ha ha cancel that out so
Offline   Reply With Quote
Old 14 Oct 2008, 08:21 PM   #8 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: Battery Charge Problems

Quote:
Originally Posted by saxywigs View Post
i live northamptonshire, yeah it really is a pain in the arse to have to keep rechargin the battery every few days, lol!, i'm assumin the alternator is working as its kickin out bout 12.8v no load, well i assume thats right as i have a 12v battery, could be wrong though usually am!

Normally with engine running no load and no a/c turned on, a low output would be 13.0v or less and 13.5 normal and 14.0v strong output................. but the 12.8 would say nearly ok..................
Offline   Reply With Quote
Old 15 Oct 2008, 09:19 AM   #9 (permalink)
Fresh Scooby
 
Join Date: Sep 2008
Posts: 18
Re: Battery Charge Problems

so i actually might have just had some really bad luck with second hand alternators!, think i may look at just buyin new, any idea where i can get a good value one?
Offline   Reply With Quote
Old 15 Oct 2008, 10:55 PM   #10 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: Battery Charge Problems

Quote:
Originally Posted by saxywigs View Post
so i actually might have just had some really bad luck with second hand alternators!, think i may look at just buyin new, any idea where i can get a good value one?
Id say try a good car parts stockist or you could buy subaru genuine part but might cost ya.....................
Offline   Reply With Quote
Old 23 Oct 2008, 05:01 PM   #11 (permalink)
Fresh Scooby
 
Join Date: Sep 2008
Posts: 18
Re: Battery Charge Problems

All sorted now, turned out to be a broken wire from the battery to the engine im now chargin at 14.8v!, thanks for all your help guys
Offline   Reply With Quote
Old 23 Oct 2008, 10:37 PM   #12 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: Battery Charge Problems

Quote:
Originally Posted by saxywigs View Post
All sorted now, turned out to be a broken wire from the battery to the engine im now chargin at 14.8v!, thanks for all your help guys
thats a good strong voltage glad you sorted it
Offline   Reply With Quote
Reply

Bookmarks

Tags
battery


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hirvonen questions if problems are tactics. News_Bot Rally News 0 29 Aug 2008 10:10 PM
lightweight battery Stig Subaru Impreza Discussions 3 25 May 2008 05:36 PM
alarm immobiliser problems after battery disconnected help! gordo996 Electrical (Including ICE) 9 17 Mar 2007 05:14 PM
Battery Flat Again bob Subaru Impreza Discussions 2 19 Mar 2005 08:36 PM
General Problems after new server skylight General Chat - Anything about Anything 2 17 Aug 2004 07:16 AM


All times are GMT. The time now is 11:57 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.