Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

Lambada Sensor
Reply
 
LinkBack Thread Tools Display Modes
Old 14 Aug 2008, 01:29 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Apr 2008
Posts: 11
Lambada Sensor

Hi all. I have a problem with my 98 uk turbo. The revs fluctuate when the engine is at running temperature and gets so bad it eventually cuts out. It does not do this when started from cold. It also revs freely/fine when hot or cold. I have disconnected the MAF when running and the engine cuts out, so i assume this is fine ? The ECU is showing no fault codes, just flashing the steady all clear. Could it possibly be the lambada sensor,although this should show up a fault code shouldn't it.

Any help would be greatly appreciated.
Offline   Reply With Quote
Old 16 Aug 2008, 10:53 AM   #2 (permalink)
Cool Scooby
 
Anders52's Avatar
 
Join Date: Oct 2007
Location: Edinburgh
Posts: 228
Send a message via MSN to Anders52
Re: Lambada Sensor

try cleaning the idle air control valve as they can become full of gunk which gives those symptoms on most cars.
__________________
Liver is evil!!!!
Offline   Reply With Quote
Old 16 Aug 2008, 12:46 PM   #3 (permalink)
Fresh Scooby
 
Join Date: Apr 2008
Posts: 11
Re: Lambada Sensor

Anders, Have cleaned the idle control valve which was not really dirty, and it made no difference.
I have also checked the plugs and they look spot on.
Where do i go from here ?
Offline   Reply With Quote
Old 16 Aug 2008, 01:08 PM   #4 (permalink)
Cool Scooby
 
Anders52's Avatar
 
Join Date: Oct 2007
Location: Edinburgh
Posts: 228
Send a message via MSN to Anders52
Re: Lambada Sensor

only other thing i can think of is a vacuum leak on the intake somewhere. Without getting a live reading on the sensors its hard to say if they are knackered or not. Might be worth getting it checked out by someone in the know.

Im sure someone else will have had this prob and no doubt give you some pointers.
__________________
Liver is evil!!!!
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Info: 02+ WRX Sensor Diagrams/Location 2002pete Engine Bay 6 24 Jan 2017 02:33 PM
ECU Reset... How many different methods are there??? Richy B Electrical (Including ICE) 95 26 Jan 2011 01:05 PM
Intake Air Temperature & Pressure Sensor Terrydlm Technical General 3 05 Nov 2007 01:23 PM
ECU Data Fault Codes 2002pete Electrical (Including ICE) 2 25 Apr 2007 07:59 AM
HELP engine check light andyd Technical General 26 09 Dec 2006 01:09 PM


All times are GMT. The time now is 04:45 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.