Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

Max revs of 4500 rpm, ideas?
Reply
 
LinkBack Thread Tools Display Modes
Old 02 Mar 2008, 06:21 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Mar 2008
Posts: 9
Max revs of 4500 rpm, ideas?

Hey folks,

First advice post here so hope someone can help me out!

I just bought a nice 93 import scoob, but after about 10 miles driving home, the Check Engine Light came on, i txt the seller and he said was cool and i should just do a wee ECU reset when i got home, i did this which sorted the issue for about 3 miles, then it started again.

When i put a bit of power on the car pulls like a train up to 4500 rpm (in all gears and when in neutral also)

I have read some other posts on this, and from what i gather it could be several different issues?

As i have no idea about the engines to be honest, anyone give me a wee started for 10?

CHeers folks

Gary
Offline   Reply With Quote
Old 03 Mar 2008, 12:55 PM   #2 (permalink)
Super Moderator
Paid & Proud
 
Tidgy's Avatar
 
Join Date: Apr 2006
Location: Nottingham
Posts: 18,743
the 4.5k is the default 'safe' mode, its switche's to that when the ecu detects an issue thats serious enough to possibly do perminent damage to the engine.

it could just be a duff sensor or it could be more serious, best bet get it to a specialist and see what they say
__________________
PM, Squirrels best friend, cream egg king and resident .org spam tart/Perv
Offline   Reply With Quote
Old 03 Mar 2008, 05:31 PM   #3 (permalink)
Fresh Scooby
 
Join Date: Mar 2008
Posts: 9
just manually checked codes, 24 and 33, which is system idle malfunction/stuck ISC valve/short in isc valve and vehicle speed sensor, this sounding particularly bad yet? or am i not in for a hefty wallet dent?

Last edited by 2087; 03 Mar 2008 at 06:09 PM.
Offline   Reply With Quote
Old 03 Mar 2008, 08:09 PM   #4 (permalink)
Forum Sponsor
Paid & Proud
 
Join Date: Feb 2005
Location: north east
Posts: 655
does the speedo work??
__________________
ASPerformance
UK distributors PIAA, EXE-TC, PERFORMANCE FRICTION
online shop!!
Offline   Reply With Quote
Old 03 Mar 2008, 08:10 PM   #5 (permalink)
Fresh Scooby
 
Join Date: Mar 2008
Posts: 9
yeah buddy everything in full working order, except that the car wont go over 4.5k rpm in any gear and neutral, and as a direct result wont go faster than maybe 100mph
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
REVS STICK WHEN CHANGING GEARS...bugeye ozbod1 Technical General 5 23 Mar 2008 05:05 PM
Illingworth puts forward ideas for 2007 News_Bot Speedway News 0 25 Oct 2006 12:23 PM
Low revs/ cut out when coming to a stand still! Gunky Technical General 10 16 Sep 2006 05:57 AM
Revs dropping on idle!! themacka Technical General 11 10 Jan 2006 10:46 PM
FORD'S BRIDGEND ENGINE BUILDERS PARCEL UP THEIR GOOD IDEAS skylight General Chat - Anything about Anything 1 19 Aug 2005 09:55 PM


All times are GMT. The time now is 01:04 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.