Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

Running Issues
Reply
 
LinkBack Thread Tools Display Modes
Old 27 Sep 2007, 02:22 PM   #1 (permalink)
Fresh Scooby
 
TheWelsho's Avatar
 
Join Date: Aug 2007
Location: Glasgow, Scotland
Posts: 26
Running Issues

Hi Folks, please help:

Here's the deal

Replaced turbo with VF34 and sports cat downpipe installed. Car mapped and running tremendously well. Took the car on track 3 days after the map and it was fantastic. Drive home, fantastic. Up the next morning, fuel light on took it to the petrol station and 100 yards from the forecourt, the car gives starts to run lumpy as I appraoch the give way, I think oh no, Im out of gas. I make it to the pump, fill up, drive off, same problem.

Its been running like a bag of spanners ever since, mostly in low revs. Changed the plugs no joy, ran a different MAF was a bit better but still not right. I have spoken to everyone and anyone and can't get a solution. It has been suggested that it might be injectors or coil packs (earlier suggestions were thought to be a damaged ring-land due to the ECU knocking at same low revs, however, it seems that its a misfire that is triggering the KS thus making matters worse).

SO! Can anyone what it might be? I am going to put the car off the road for a couple of days for extensive checks, but would rather avoid that if possible because: a) I NEED the car b) I DON'T need the expense!

Other info that might be of help:
  • WRX MY06 2.5
  • Diagnostics checks show no sensor faults
  • Misfire at low revs (mostly)
  • No smoke or vapour from exhaust
  • Water levels fine
  • Put fuel cleaner in, no joy
Thanks
John
__________________
Money = BHP
Offline   Reply With Quote
Old 27 Sep 2007, 04:04 PM   #2 (permalink)
Super Moderator
Paid & Proud
 
Tidgy's Avatar
 
Join Date: Apr 2006
Location: Nottingham
Posts: 18,743
might be worth getting it back to the mapper getting them to hitch up the laptop and go for a wuick drive, should be able to see what the exact issue is, if its not fireing right or fuel issue etc.
__________________
PM, Squirrels best friend, cream egg king and resident .org spam tart/Perv
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Running Problems susan43 Technical General 3 01 Nov 2008 03:26 PM
Suzuki: Engine issues sorted. News_Bot Rally News 0 23 Mar 2008 12:10 PM
TIME RUNNING OUT: Win Group B rally book. News_Bot Rally News 0 06 Mar 2008 01:22 PM
not running right but still making me smile !!! uk dave Subaru Impreza Discussions 14 28 Jun 2006 08:08 PM
WRX running costs?? dom88 Subaru Impreza Discussions 5 07 Apr 2005 07:30 PM


All times are GMT. The time now is 12:39 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.