Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

Clutch woes pls help! also error code help
Reply
 
LinkBack Thread Tools Display Modes
Old 07 Aug 2007, 04:55 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Apr 2007
Posts: 10
Clutch woes pls help! also error code help

HI GUys,
Got a 2003 UK STi impreza runnin 342bhp at fly at last dyno, standard clutch went after a bit of a heavy start during a track session and started juddering then slipping as soon as boost came on. Went to my local scooby specialist and had a new flywheel and uprated organic exedy clutch kit fitted, as you can imagine the bill wasn't small. After picking it up the clutch was very heavy and still juddered, I was told it had to bed in, this didn't work put 600miles on it and it only juddered worse, it was either in or out along with constant clutch stink when pulling away or parking. There was also a constant high pitched grinding noise on acceleration and deceleration which went when you pressed the clutch. I took it back and they inspected it saying the clutch cover plate had cracked putting it down to a faulty clutch. It was replaced for free along with another flywheel as the other one had major deposits left on it. Exactly the same has happened again, clutch stink, judder and the whining grinding noise is coming back slowly, this is within 100miles. Also after both times he worked on it my cel light has come on, i've got an engine data monitor and the code is P0139 O2 sensor slow response, this will come on for a couple of days then go away again. Any help guys much appreciated.
Cheers from ross
Offline   Reply With Quote
Old 07 Aug 2007, 05:54 PM   #2 (permalink)
Regular Scooby
 
Join Date: May 2005
Location: S.Wales
Posts: 183
Send a message via MSN to warrenjenkins Send a message via Yahoo to warrenjenkins
took about 1000k on mine to bed in and every now and then it smells i didnt get any grinding noise had the flywheel replaced as well
Offline   Reply With Quote
Old 07 Aug 2007, 06:00 PM   #3 (permalink)
Fresh Scooby
 
Join Date: Apr 2007
Posts: 10
cheers warren, might just be a characteristic of the organic ones then, do you get any noise at all from yours?
Offline   Reply With Quote
Old 07 Aug 2007, 06:18 PM   #4 (permalink)
Forum Sponsor
Paid & Proud
 
Join Date: Feb 2005
Location: north east
Posts: 655
as above, they can be juddery until properly bedded but shouldn't be any noise.....................
__________________
ASPerformance
UK distributors PIAA, EXE-TC, PERFORMANCE FRICTION
online shop!!
Offline   Reply With Quote
Old 07 Aug 2007, 06:36 PM   #5 (permalink)
Veteran Scooby
 
uk dave's Avatar
 
Join Date: Feb 2005
Location: Impreza Preservation Society HQ
Posts: 4,399
Send a message via MSN to uk dave
Got exedy organic and lightened flywheel on my classic not heavy no judder or noise, though is sharp but ya get used to it-love it though only runnin around 240bhp.
Offline   Reply With Quote
Old 07 Aug 2007, 06:50 PM   #6 (permalink)
Regular Scooby
 
Join Date: May 2005
Location: S.Wales
Posts: 183
Send a message via MSN to warrenjenkins Send a message via Yahoo to warrenjenkins
no noise just the usual classic symptoms little bit of judder if cold and bit of a smell if you gun it running 308bhp with 369nm torque @ 1.1bar
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
clutch time -Ant- Technical General 0 17 Apr 2008 06:19 PM
Power loss Problem, Please help - maybe clutch djquest Technical General 23 20 Oct 2007 05:02 PM
clutch nugster Technical General 3 14 May 2006 12:23 PM
New Clutch! andrewwhitcombe Technical General 6 20 Apr 2005 01:10 PM
1999 2.0 Turbo Shuddering when pulling off imported_Gareth Subaru Impreza Discussions 17 20 Apr 2004 06:52 AM


All times are GMT. The time now is 01:55 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.