Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

check engine light/ misses above 4000rpm
Reply
 
LinkBack Thread Tools Display Modes
Old 05 Jun 2007, 11:53 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Jun 2007
Location: Mansfield, Ohio, USA don't ya know
Posts: 3
check engine light/ misses above 4000rpm

Hello all,
I'm new to the site and need a bit of help. Just today on the way to work my engine died for about 2 seconds and came back on. About 30 seconds after that the check engine light came on. The car is running fine now except the check engine light is still on and if the engine revs above 4000rpm it acts like a rev limiter come on.(misses badly) As soon as the RPMs drop below 4000 it runs fine again. The red line for the engine is 6000rpm.
any ideas or thoughts???

Car info:
93 impreza 1.8L sedan
5 speed stick
150,000 miles
I live in the US if it makes a difference.

Thanks for the help.
Darrell
Offline   Reply With Quote
Old 06 Jun 2007, 07:07 AM   #2 (permalink)
Forum Sponsor
Paid & Proud
 
Join Date: Feb 2005
Location: north east
Posts: 655
the car is now rnning in "safe" mode and restricting your revs to 4000 as part of that protection......................

you need to check the fault codes and suss exactly why this has occurred?? speedo still working??
__________________
ASPerformance
UK distributors PIAA, EXE-TC, PERFORMANCE FRICTION
online shop!!
Offline   Reply With Quote
Old 06 Jun 2007, 10:48 PM   #3 (permalink)
Fresh Scooby
 
Join Date: Jun 2007
Location: Mansfield, Ohio, USA don't ya know
Posts: 3
speedo is working. I have not had time to get it checked so far maybe tonight. new to the area were i currently live, need to find a good wrench to handle the things I can't.
Offline   Reply With Quote
Old 07 Jun 2007, 01:49 AM   #4 (permalink)
Fresh Scooby
 
Join Date: Jun 2007
Location: Mansfield, Ohio, USA don't ya know
Posts: 3
Quote:
Originally Posted by stockcar View Post
the car is now rnning in "safe" mode and restricting your revs to 4000 as part of that protection......................

you need to check the fault codes and suss exactly why this has occurred?? speedo still working??
I use to drive a medium duty tow/recovery truck. It was easy to pull codes off it and the ecu did a great job of protecting the engine by cutting the amount of fuel and such if there was a problem of some sort. I figured it was a safe mode situation just wondered if anyone had ideas on what it would be.
That's basicly a million dollar question because there could be about a million reasons for the light to come on.

I reset the ecu and will drive it easy for a day or two and see if the CEL comes back on.
Thanks for the input
Offline   Reply With Quote
Old 18 Feb 2008, 07:34 PM   #5 (permalink)
Fresh Scooby
 
Join Date: Oct 2007
Posts: 6
try the plugs even if they look ok replace them with some good quality ones coz ur problem sounds familiar, sounds like a longshot but i had the same prob and it turned out to be one plug that looked fine by me
Offline   Reply With Quote
Old 18 Feb 2008, 09:35 PM   #6 (permalink)
Cool Scooby
 
Anders52's Avatar
 
Join Date: Oct 2007
Location: Edinburgh
Posts: 228
Send a message via MSN to Anders52
as above the car is running in "safe mode" or limp home mode. Usually caused by a sensor failure etc.
What you need to do is read the fault codes by connecting the black connectors under your steering column assuming your car has OBDI connectors (not sure if this is possible due to age and location). If you can this will in turn flash the cel light so you can decipher the codes it produces.

This will then tell you what the problem is but expect more than one code as for example if the water temp sensor is faulty it could throw one of the other sensors out due to the engine running out of parameters.
__________________
Liver is evil!!!!
Offline   Reply With Quote
Old 06 Mar 2008, 03:22 PM   #7 (permalink)
Fresh Scooby
 
iwassurfing's Avatar
 
Join Date: Feb 2008
Location: bath
Posts: 18
i had same thing was my boost controller running ok now except for other codes i got!
__________________
its so fast.... bath and bristol scoobys! local club local cars local meets check us out
Offline   Reply With Quote
Old 04 Aug 2008, 03:08 PM   #8 (permalink)
Fresh Scooby
 
Join Date: Aug 2008
Posts: 2
Re: check engine light/ misses above 4000rpm

Hi Guys, thanks very much for the info. But no engine light is coming on and my car doesnt misfire it just cuts out. My car is a UK model does it make a difference?

Last edited by Colinnina; 04 Aug 2008 at 03:10 PM. Reason: Missed some crucial information
Offline   Reply With Quote
Old 04 Aug 2008, 03:12 PM   #9 (permalink)
Fresh Scooby
 
iwassurfing's Avatar
 
Join Date: Feb 2008
Location: bath
Posts: 18
Re: check engine light/ misses above 4000rpm

just for an update for my sti, after alot of playing around Dave at Tileys decided to check in the fuel tank and at some point water was in there and caused the pump to rust, and the particles where obviously getting to the fuel filter and stopping the fuel flow once it had been used from the filter to the engine hence my loss of power

i had a new tank fitted and pumps from a P1 and she has been sweet as ever since, all fault codes gone,

thanks
__________________
its so fast.... bath and bristol scoobys! local club local cars local meets check us out
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Check Engine Light SilverStreak Technical General 4 12 Nov 2007 06:54 PM
check engine light on in morning??? RossD Technical General 14 14 Sep 2007 12:41 PM
Stuttering Check engine light Soundtweaker Technical General 15 02 Mar 2007 04:39 PM
Engine Check Light On mmayim Engine Bay 3 25 Jul 2005 09:15 PM
Intermittant Engine check light!? AberScooby Technical General 7 01 Jul 2005 09:34 PM


All times are GMT. The time now is 05:56 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.