Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

Boost Problem
Reply
 
LinkBack Thread Tools Display Modes
Old 07 May 2007, 05:49 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Sep 2006
Posts: 8
Boost Problem

Looking For Some Help/advice.i Have A 99 Uk Turbo.have Noticed That Intermittantly When Going To Overtake That I Am Only Getting 5psi Of Boost Instead Of The Normal 15psi.if I Keep The Foot Down It Eventually Kicks Back To Life.its A Bit Worrying When Trying To Overtake Safley Then Getting Very Little Boost.can Anyone Help/give Advice.
Offline   Reply With Quote
Old 07 May 2007, 06:38 PM   #2 (permalink)
Obsessed Scooby
Paid & Proud
 
PeterUK300's Avatar
 
Join Date: Apr 2004
Location: East Herts
Posts: 12,081
Try cleaning out your boost pipes to the solinoid. They can get contaminated with oil which will cause boost problems
__________________
All the best
Pete

http://www.scoobyweb.co.uk
Offline   Reply With Quote
Old 07 May 2007, 10:34 PM   #3 (permalink)
Super Moderator
Paid & Proud
 
Tidgy's Avatar
 
Join Date: Apr 2006
Location: Nottingham
Posts: 18,743
does it stop when you change gear or come off the throttle for a second?

get revs higher before you go, i get it on mine, basicly subaru built in a test section in the ecu, if you hold it at certain revs then boot it, it hits 0.5 then stops, hold sat at that till you come off the throttle or it will slowly slowy increase.

not saying for def its that but i get it thrrough a certain section of road (50 yards of 30pmh after a round about, then into a national, if i don't either up change or come of throttle before wellying it it holds the boost).

try comming off the throttle and see if that works.

had quiet a few people baffled with mine cos of it, had to get the lowdown from pat herborn about it in the end lol
__________________
PM, Squirrels best friend, cream egg king and resident .org spam tart/Perv
Offline   Reply With Quote
Old 08 May 2007, 03:06 PM   #4 (permalink)
Dedicated Scooby
 
Nelson's Avatar
 
Join Date: Apr 2004
Location: South West
Posts: 2,659
As per Pete's comments - my money would be on the boost solenoid. Clean it out with carb/brake cleaner and performance should be restored
Offline   Reply With Quote
Old 21 Oct 2007, 01:22 PM   #5 (permalink)
Fresh Scooby
 
scoobydrew72's Avatar
 
Join Date: Jul 2007
Posts: 9
hi ive started having same problem with my 97 scoob. it only boosts upto 0.5 bar and wont go any higher ive tried booting it from a junction or reving it through the gears and it wont boost past 0.5 its bin 2 local garage they have swapped solenoid and actuator and the boost pipe but still doing it its going back in next friday to have the ecu changed so i will let you know if that sorts the problem
Offline   Reply With Quote
Old 25 Oct 2007, 12:00 PM   #6 (permalink)
Super Moderator
Paid & Proud
 
Tidgy's Avatar
 
Join Date: Apr 2006
Location: Nottingham
Posts: 18,743
Quote:
Originally Posted by scoobydrew72 View Post
hi ive started having same problem with my 97 scoob. it only boosts upto 0.5 bar and wont go any higher ive tried booting it from a junction or reving it through the gears and it wont boost past 0.5 its bin 2 local garage they have swapped solenoid and actuator and the boost pipe but still doing it its going back in next friday to have the ecu changed so i will let you know if that sorts the problem

read below, take foot off throttle then back on again and see what happens, if it sorts it its just the test function
__________________
PM, Squirrels best friend, cream egg king and resident .org spam tart/Perv
Offline   Reply With Quote
Old 25 Oct 2007, 12:00 PM   #7 (permalink)
Super Moderator
Paid & Proud
 
Tidgy's Avatar
 
Join Date: Apr 2006
Location: Nottingham
Posts: 18,743
Quote:
Originally Posted by scoobydrew72 View Post
hi ive started having same problem with my 97 scoob. it only boosts upto 0.5 bar and wont go any higher ive tried booting it from a junction or reving it through the gears and it wont boost past 0.5 its bin 2 local garage they have swapped solenoid and actuator and the boost pipe but still doing it its going back in next friday to have the ecu changed so i will let you know if that sorts the problem

read below, take foot off throttle then back on again and see what happens, if it sorts it its just the test function
__________________
PM, Squirrels best friend, cream egg king and resident .org spam tart/Perv
Offline   Reply With Quote
Old 25 Oct 2007, 12:00 PM   #8 (permalink)
Super Moderator
Paid & Proud
 
Tidgy's Avatar
 
Join Date: Apr 2006
Location: Nottingham
Posts: 18,743
Quote:
Originally Posted by scoobydrew72 View Post
hi ive started having same problem with my 97 scoob. it only boosts upto 0.5 bar and wont go any higher ive tried booting it from a junction or reving it through the gears and it wont boost past 0.5 its bin 2 local garage they have swapped solenoid and actuator and the boost pipe but still doing it its going back in next friday to have the ecu changed so i will let you know if that sorts the problem

read below, take foot off throttle then back on again and see what happens, if it sorts it its just the test function
__________________
PM, Squirrels best friend, cream egg king and resident .org spam tart/Perv
Offline   Reply With Quote
Old 28 Oct 2007, 08:52 PM   #9 (permalink)
Fresh Scooby
 
scoobydrew72's Avatar
 
Join Date: Jul 2007
Posts: 9
hi found out there is a problem in the ecu not switching when it should, i could have got a re-con 1 for £150 but opted for a greddy pro spec 2 boost controller which will sort the problem out plus will be able 2 run 1.1 bar of boost and be better 4 when i upgrade 2 a bigger turbo
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
strange boost problem! doc__dave Engine Bay 11 30 Aug 2007 07:09 PM
Boost solenoid problem uk dave Engine Bay 7 29 May 2007 05:24 PM
Another boost problem poundhound Technical General 4 23 Mar 2007 07:15 PM
boost problem - need help! Big Dawg Engine Bay 2 13 Jun 2006 07:32 PM
boost problem scotteboy Technical General 8 14 Mar 2006 10:41 PM


All times are GMT. The time now is 08:17 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.