Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

knock sensor
Reply
 
LinkBack Thread Tools Display Modes
Old 05 Feb 2007, 08:15 PM   #1 (permalink)
CS1
Fresh Scooby
 
Join Date: Feb 2007
Posts: 4
knock sensor

ive read the fault code from my cel and its telling me theres a problem with the knock sensor. when im driving the cel comes on and goes off but its on most of the time. theres does'nt seem to be a problem with the engine .any ideas welcome?
Offline   Reply With Quote
Old 05 Feb 2007, 08:36 PM   #2 (permalink)
Obsessed Scooby
Paid & Proud
 
PeterUK300's Avatar
 
Join Date: Apr 2004
Location: East Herts
Posts: 12,081
Check the sensor, wiring etc, back of engine passenger side under intercooler on engine block (I believe).
__________________
All the best
Pete

http://www.scoobyweb.co.uk
Offline   Reply With Quote
Old 05 Feb 2007, 09:56 PM   #3 (permalink)
CS1
Fresh Scooby
 
Join Date: Feb 2007
Posts: 4
I've already taken it off and clean it all up but that made no difference. someone told me it could be down to feul? do you know any other reasons why it might be happening?
Offline   Reply With Quote
Old 06 Feb 2007, 08:20 AM   #4 (permalink)
Forum Sponsor
Paid & Proud
 
Join Date: Feb 2005
Location: north east
Posts: 655
they can be a fault, worth getting another knock sensor and re-setting the ECU to sort....................as for fuel you should be running super as a min. in a turbo car...........
__________________
ASPerformance
UK distributors PIAA, EXE-TC, PERFORMANCE FRICTION
online shop!!
Offline   Reply With Quote
Old 18 Feb 2007, 12:17 AM   #5 (permalink)
CS1
Fresh Scooby
 
Join Date: Feb 2007
Posts: 4
cheers people i got another senor and now its sorted i did'nt even have to reset the ecu, i just fitted the sensor and away she went.
Offline   Reply With Quote
Old 18 Feb 2007, 08:55 AM   #6 (permalink)
Super Moderator
Paid & Proud
 
2002pete's Avatar
 
Join Date: Sep 2004
Location: UK
Posts: 14,377
Quote:
Originally Posted by CS1 View Post
cheers people i got another senor and now its sorted i did'nt even have to reset the ecu, i just fitted the sensor and away she went.
Nice one
__________________
Pete.

Offline   Reply With Quote
Old 18 Feb 2007, 10:11 AM   #7 (permalink)
Obsessed Scooby
Paid & Proud
 
PeterUK300's Avatar
 
Join Date: Apr 2004
Location: East Herts
Posts: 12,081
Glad it is sorted
__________________
All the best
Pete

http://www.scoobyweb.co.uk
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Knock Sensor location 96 Sub Imp Out wagon cukachew Technical General 0 24 Jul 2007 12:46 AM
Knock Sensor/ Det Alarm Help trunkmonkey666 Electrical (Including ICE) 2 17 Oct 2006 08:31 PM
knock sensor scoob Technical General 10 06 Sep 2005 07:32 PM
GOT MY NEW KNOCK SENSOR, CANT FIND WHERE I FIT IT! dieard Technical General 4 10 Aug 2005 09:16 PM


All times are GMT. The time now is 04:13 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.