Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

sqeeking front end ?
Reply
 
LinkBack Thread Tools Display Modes
Old 24 Dec 2006, 10:08 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Dec 2006
Posts: 2
sqeeking front end ?

hi there everyone, and a happy xmas to one and all of you. I need some help please if poss or if anyone knows what problem i might have. I have just bought myself a 93 wrx import and for the last two weeks its been a pure joy to drive and own,but now i have this terrible noise from the front passenger side wheel. It started about five days ago with a mild squeek when i turned the steering wheel but now it is unbearale and embaresing. it dosnt go when i brake or push the clutch down and it seems worse under load.I was told it could be a wheel bearing or even the strut,i dont know. Has any one got any clues for me please,i have a technics turbo gti golf also but sadly i love the wrx so much the gti dosnt get driven anymore, What a fantastic car the wrx is, anyway thanks to you allm mike
Offline   Reply With Quote
Old 24 Dec 2006, 11:35 PM   #2 (permalink)
Senior Scooby
 
speed demoness's Avatar
 
Join Date: Sep 2006
Location: Durham
Posts: 1,410
Send a message via MSN to speed demoness
deffo get the bearings checked hun... also chek the brakes/disc etc
above all... welome aboard .org... lots of knowledgeable guys on here !
Offline   Reply With Quote
Old 25 Dec 2006, 08:33 AM   #3 (permalink)
Obsessed Scooby
Paid & Proud
 
PeterUK300's Avatar
 
Join Date: Apr 2004
Location: East Herts
Posts: 12,081
First check it's not debris jammed in the disc/caliper, if not then it does sound like a wheel bearing.....
__________________
All the best
Pete

http://www.scoobyweb.co.uk
Offline   Reply With Quote
Old 27 Dec 2006, 09:48 PM   #4 (permalink)
Fresh Scooby
 
Join Date: Dec 2006
Posts: 2
thank you very much one and all.
Offline   Reply With Quote
Old 28 Dec 2006, 07:51 AM   #5 (permalink)
Fresh Scooby
 
klunker's Avatar
 
Join Date: Sep 2006
Location: Nr Manchester
Posts: 28
Not too sure about 94 Model but My00 classic Brake pads had the spring wear indicator on them and this squeaked like hell when driving. Its just a metal spring clip that shows when the pads need changing. And it shows this by a very loud squeaking.
It was only on one side as well.
New pads and discs cured mine as the discs were done anyway.
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
front mount lag Tidgy Subaru Impreza Discussions 11 16 Jul 2007 06:40 PM
Info: subaru tec site. 2002pete Modifications - Tips and Tricks 1 01 Apr 2007 03:41 PM
[LEXUS] INTRODUCING THE NEW LEXUS IS skylight World Wide Automotive - News / Discussions 0 18 Nov 2005 08:34 PM
NEW-LOOK AND CLASS-LEADING PERFORMANCE FOR ’06 FORESTER skylight General Chat - Anything about Anything 2 03 Aug 2005 05:05 PM
OUTSTANDING NEW ‘BOXER’ ENGINE FOR ’06 LEGACY RANGE skylight General Chat - Anything about Anything 3 03 Aug 2005 10:15 AM


All times are GMT. The time now is 03:25 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.