Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

HELP engine check light
Reply
 
LinkBack Thread Tools Display Modes
Old 08 Dec 2006, 11:08 AM   #1 (permalink)
Regular Scooby
 
andyd's Avatar
 
Join Date: Nov 2006
Posts: 92
HELP engine check light

someone plzzzzz help,went out to the wrx this mornin,and "check engine" in red letters came up???,car sometimes starts,but now wont???? it's a 95 wrx wagon?
__________________
i fill up with petrol,yet 200 miles later it's empty??lol
Offline   Reply With Quote
Old 08 Dec 2006, 11:21 AM   #2 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
aha,could be the maf playing games,there is a fault code diagnostic read out some where on here,the cel will flash according to the problem,takes a bit of reading......
Offline   Reply With Quote
Old 08 Dec 2006, 11:23 AM   #3 (permalink)
Regular Scooby
 
andyd's Avatar
 
Join Date: Nov 2006
Posts: 92
cel????
__________________
i fill up with petrol,yet 200 miles later it's empty??lol
Offline   Reply With Quote
Old 08 Dec 2006, 11:24 AM   #4 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
check engine light........for a quick test,disconnect the negative terminal on the battery and reconnect,see what happens the,it should go out and stay out,if not you'll have the cel flashing in accordance to the problem......
Offline   Reply With Quote
Old 08 Dec 2006, 11:30 AM   #5 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
link to the codes....

http://www.subaru-impreza.org/bbs/sh...ht=fault+codes
Offline   Reply With Quote
Old 08 Dec 2006, 11:31 AM   #6 (permalink)
Regular Scooby
 
andyd's Avatar
 
Join Date: Nov 2006
Posts: 92
sorry to sound ignorant but wots a cell?
__________________
i fill up with petrol,yet 200 miles later it's empty??lol
Offline   Reply With Quote
Old 08 Dec 2006, 11:32 AM   #7 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
replied in previous post bud....
Offline   Reply With Quote
Old 08 Dec 2006, 11:52 AM   #8 (permalink)
Super Moderator
Paid & Proud
 
2002pete's Avatar
 
Join Date: Sep 2004
Location: UK
Posts: 14,377
Quote:
Originally Posted by andyd View Post
sorry to sound ignorant but wots a cell?
As Ed said it's Check Engine Light........
__________________
Pete.

Offline   Reply With Quote
Old 08 Dec 2006, 11:59 AM   #9 (permalink)
Regular Scooby
 
andyd's Avatar
 
Join Date: Nov 2006
Posts: 92
oops sorry lol ,just disconnected and put back on,cel still on,managed to start it,somethin def aint right,when starting feels like there is no choke,so it really struggles?? throttle is vague,ie a delayed response,and the other weird thing is,the rad fans are on????
__________________
i fill up with petrol,yet 200 miles later it's empty??lol
Offline   Reply With Quote
Old 08 Dec 2006, 12:00 PM   #10 (permalink)
Regular Scooby
 
andyd's Avatar
 
Join Date: Nov 2006
Posts: 92
oh and cel light is permanant,even from from putting ignition on,before starting,not flashing???
__________________
i fill up with petrol,yet 200 miles later it's empty??lol
Offline   Reply With Quote
Old 08 Dec 2006, 12:04 PM   #11 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
ecu is havin a paddy,read the flashing sequence and check againt the list link i put up........
Offline   Reply With Quote
Old 08 Dec 2006, 12:05 PM   #12 (permalink)
Regular Scooby
 
andyd's Avatar
 
Join Date: Nov 2006
Posts: 92
seriously mate it's not flashing atall,just permanantly on
__________________
i fill up with petrol,yet 200 miles later it's empty??lol
Offline   Reply With Quote
Old 08 Dec 2006, 12:06 PM   #13 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
bugger.....hang on......
Offline   Reply With Quote
Old 08 Dec 2006, 12:11 PM   #14 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
In Diagnostic Mode – No Fault is indicated by the Check Engine Light continuously & evenly flashing on/off (this is also used to indicate the successful completion of an ECU Reset).
Offline   Reply With Quote
Old 08 Dec 2006, 12:12 PM   #15 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
failing that i'll put another fault list up........
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light/ misses above 4000rpm darrellmac311 Technical General 8 04 Aug 2008 03:12 PM
Check Engine Light SilverStreak Technical General 4 12 Nov 2007 06:54 PM
Stuttering Check engine light Soundtweaker Technical General 15 02 Mar 2007 04:39 PM
Engine Check Light On mmayim Engine Bay 3 25 Jul 2005 09:15 PM
Intermittant Engine check light!? AberScooby Technical General 7 01 Jul 2005 09:34 PM


All times are GMT. The time now is 09:59 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.