Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

isn't spooling until 3500rpm
Reply
 
LinkBack Thread Tools Display Modes
Old 30 Jul 2006, 02:07 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Nov 2005
Location: suffolk
Posts: 35
isn't spooling until 3500rpm

as above my 96 wrx seems really sluggish until 3500RPM an when it does it doesn't seem to be much of a kick,i recently fitted a scoobecu but cant remember if it as like it before do i need to alter something to suit the chip ,the chip is set to 16.5 psi but it doesn't seem to go past 1 bar
anyone got any ideas
Offline   Reply With Quote
Old 31 Jul 2006, 10:58 PM   #2 (permalink)
Dedicated Scooby
 
tiny's Avatar
 
Join Date: May 2006
Location: fraggle rock
Posts: 2,505
Send a message via MSN to tiny
i think that is about right mate. can`t remember for certain though.

Have you had it mapped at all or was it just a case of plug and play
Offline   Reply With Quote
Old 03 Aug 2006, 03:44 PM   #3 (permalink)
Young Scooby
 
Join Date: Jan 2005
Location: England, nr Europe
Posts: 58
3500rpm is a little high for a TD05. I get 1bar at 2950rpm and 1.4bar at 3150rpm according to my Apexi commander unit.

16.5 psi is approx 1.1bar. To get an accurate reading, you want to accelerate hard in 4th gear to get your readings....you should probably hit 1.1bar with a little load on the engine.
Offline   Reply With Quote
Old 03 Aug 2006, 03:46 PM   #4 (permalink)
jd
Obsessed Scooby
Paid & Proud
 
jd's Avatar
 
Join Date: Mar 2005
Location: here
Posts: 6,414
Send a message via MSN to jd
1 bar is 14.5 bar
__________________
blah blah blah
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stumbing / missing tickover to 3500rpm wicksy5508 Engine Bay 8 17 Mar 2008 05:08 PM


All times are GMT. The time now is 11:04 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.