Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

cluch slip in 3 to 5
Reply
 
LinkBack Thread Tools Display Modes
Old 23 Jun 2006, 11:03 PM   #1 (permalink)
Regular Scooby
 
GHBNIC's Avatar
 
Join Date: Oct 2005
Location: lincs
Posts: 193
Send a message via AIM to GHBNIC Send a message via MSN to GHBNIC
cluch slip in 3 to 5

Hi there i have a 1998 impreza 2000 turbo uk i have had it about 6 months now and it is fantasic. Now the problem is that i have had a manual boost controller fitted and it has been set up to 18psi with no fuel cut... You can boot it though 1st & 2nd but when you get into 3rd 4th and 5th at about 4500 with your foot down it feels like the cluch is slipping the revs go up but nothing else happens.if you back off then boot it again its fine till you change gear again. There is no smell from the cluch burning, i have had it in a local docs and he says the cluch is fairly new and all looks ok.. I was then told about fuel cut but when this happens as you all know its like being put throgh the window screen and wots happenin to me is like cluch slip (so can it be this)... In hearin this i phoned the place where i had the boost controller fitted and set up and spoke about fuel cut and they said that they have removed a brass thing or something from the pipe to stop this happening so it can't be fuel cut... i have the dyno report and they are saying its fine on the rollers.They are clueless can anyone help or have you had any problems like this.

mods on car:
Sti8 scoop
forge dump valve
afterburner decat (centre)
Ts motor sport back box
powertec induction kit
powertec boost control
intercooler spray
268bhp @ 4800rpm @ 18.5psi

So i am stuck it only seems to do it while moving this is strange and got a lot of ppl confused..

sorry for long post thought i betta tell ya it all..lol

ghbnic
Offline   Reply With Quote
Old 23 Jun 2006, 11:06 PM   #2 (permalink)
Dedicated Scooby
 
tiny's Avatar
 
Join Date: May 2006
Location: fraggle rock
Posts: 2,505
Send a message via MSN to tiny
sounds to me like the early stages of you`re clutch going as thats what mine did

try pulling off in 2nd/3rd gears, the car should stall, if not the clutch is on its way out mate
Offline   Reply With Quote
Old 23 Jun 2006, 11:21 PM   #3 (permalink)
Regular Scooby
 
GHBNIC's Avatar
 
Join Date: Oct 2005
Location: lincs
Posts: 193
Send a message via AIM to GHBNIC Send a message via MSN to GHBNIC
Quote:
Originally Posted by tiny
sounds to me like the early stages of you`re clutch going as thats what mine did

try pulling off in 2nd/3rd gears, the car should stall, if not the clutch is on its way out mate

Thanx for quick reply. Right just been out in it and it shacks a bit then stalls in 2nd and 3rd... Something else i have notice since the boost controller has bin on when in traffic stood still and hot it dont like to idle well its al shacky the rev counter dont move up and down it sicks at around 800 mark.. Could this have something to do wiv it..
Sorry i am thick when it comes to cars...
Offline   Reply With Quote
Old 24 Jun 2006, 07:19 AM   #4 (permalink)
Dedicated Scooby
 
tiny's Avatar
 
Join Date: May 2006
Location: fraggle rock
Posts: 2,505
Send a message via MSN to tiny
maybe lambda sensor or maf mate, has it been since the induction kit went on and not the boost controller? If so that could be where your problem is also has it been mapped? if not try putting the old filter back on and do an ecu reset and see if that cures the problem

it may also still be clutch slip though, just its not too bad at the moment

Last edited by tiny; 24 Jun 2006 at 07:28 AM.
Offline   Reply With Quote
Old 25 Jun 2006, 08:39 PM   #5 (permalink)
Dedicated Scooby
 
BIG GRINDER!'s Avatar
 
Join Date: Dec 2004
Location: Lancashire
Posts: 2,458
Send a message via MSN to BIG GRINDER!
Time for a new clutch. I got mine done for 360 inc vat. That's standard BHP ish
If your more that 300 you will need better parts

Kev
__________________
The difference between genius and stupidity is that genius has its limits. Albert Einstein
Offline   Reply With Quote
Old 01 Jul 2006, 06:53 AM   #6 (permalink)
Regular Scooby
 
GHBNIC's Avatar
 
Join Date: Oct 2005
Location: lincs
Posts: 193
Send a message via AIM to GHBNIC Send a message via MSN to GHBNIC
Quote:
Originally Posted by tiny
maybe lambda sensor or maf mate, has it been since the induction kit went on and not the boost controller? If so that could be where your problem is also has it been mapped? if not try putting the old filter back on and do an ecu reset and see if that cures the problem

it may also still be clutch slip though, just its not too bad at the moment


Hi again, no it was all fine until i had the boost controller fitted, the induction kit and decat made little diferance apart from the sound of the car.As i am aware the ecu is standard which the garage thinks is strange boosting at 18psi and got no mixture problems!!!!!!!
Now i have disconected the dump valve on the intercoller, i pulled off the vac pipe on the block and bunged it up with a screew so the dump valve is always closed, it now sounds as if i have a waste gate which is betta than the hiss i got before (can i leave it like this?) But in doin this i am still boosting at around 18psi but there is no cluch slip anymore its all ok at the moment, but can i leave it this way or will it cause damage? I phoned my docs about this and they are unsue well they won't answer me yes or no...................
Nic...........
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mackenzie sees podium slip through his fingers. News_Bot Moto-X News 0 10 Aug 2007 05:21 PM
wot cluch for my99uk GHBNIC Technical General 3 03 Sep 2006 08:06 PM
McLaren slip further behind Renault and Ferrari. News_Bot Formula News 0 16 May 2006 03:44 PM
Clutch slip BIG GRINDER! Technical General 17 04 May 2006 07:40 PM


All times are GMT. The time now is 10:35 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.