Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

Boost probs (seems like the time of year for it!!)
Reply
 
LinkBack Thread Tools Display Modes
Old 15 Apr 2006, 07:43 PM   #1 (permalink)
Senior Scooby
Paid & Proud
 
tom73's Avatar
 
Join Date: Jan 2006
Location: County Durham
Posts: 1,208
Boost probs (seems like the time of year for it!!)

Hi guys,

hope you're all well.

i think i may have a small problem with my MY97 turbo overboostin. its just started revving as quick as a 22B and then lurching (feels like a rev limiter or fuel cut) when it gets to about 3,500 rpm then it gets to about 4,500 and does it again. it only happens under load as when accelerating on part throttle all seems ok.

anybody got any ideas??

tom
__________________
SCOOBS AIN'T JUST CARS, THEY'RE A WAY OF LIFE. KEEP THE FAITH TROOPS
Offline   Reply With Quote
Old 16 Apr 2006, 01:55 PM   #2 (permalink)
Super Moderator
Paid & Proud
 
Tidgy's Avatar
 
Join Date: Apr 2006
Location: Nottingham
Posts: 18,743
yeah sounds very much like over boost, when it cuts do the revs drop about 500rpm before it takes off again?
Offline   Reply With Quote
Old 16 Apr 2006, 02:02 PM   #3 (permalink)
Senior Scooby
Paid & Proud
 
tom73's Avatar
 
Join Date: Jan 2006
Location: County Durham
Posts: 1,208
yeah they did. then it would climb up through the revs and do it again. the boost was coming in really early too. when it happened it just started acting up without warning.

i think i found the problem. what looks like a valve on the inner wing had blown the pipe from the wastegate off. That seems to have sorted it and i've done an ecu reset to clear any faults it had stored.

fingers crossed, it'll be fine.
__________________
SCOOBS AIN'T JUST CARS, THEY'RE A WAY OF LIFE. KEEP THE FAITH TROOPS
Offline   Reply With Quote
Old 16 Apr 2006, 02:10 PM   #4 (permalink)
Super Moderator
Paid & Proud
 
Tidgy's Avatar
 
Join Date: Apr 2006
Location: Nottingham
Posts: 18,743
yeah sounds like it will, ecu reset would have sorted it prob anyway if it wasn't for the pipe lol
Offline   Reply With Quote
Old 16 Apr 2006, 02:13 PM   #5 (permalink)
Senior Scooby
Paid & Proud
 
tom73's Avatar
 
Join Date: Jan 2006
Location: County Durham
Posts: 1,208
its a shame i had to put that pipe back on. it was like a missile without it on. bit of a bumpy ride though
__________________
SCOOBS AIN'T JUST CARS, THEY'RE A WAY OF LIFE. KEEP THE FAITH TROOPS
Offline   Reply With Quote
Old 16 Apr 2006, 02:15 PM   #6 (permalink)
Super Moderator
Paid & Proud
 
Tidgy's Avatar
 
Join Date: Apr 2006
Location: Nottingham
Posts: 18,743
glad you caught it before rod or piston decided to go sight seeing through the wing of the car lol
Offline   Reply With Quote
Old 16 Apr 2006, 02:45 PM   #7 (permalink)
Senior Scooby
Paid & Proud
 
tom73's Avatar
 
Join Date: Jan 2006
Location: County Durham
Posts: 1,208
would have been an expensive way of getting a service done thats for sure lol. as soon as it happened i just brought it straight home on part throttle and as little boost as possible
__________________
SCOOBS AIN'T JUST CARS, THEY'RE A WAY OF LIFE. KEEP THE FAITH TROOPS
Offline   Reply With Quote
Old 16 Apr 2006, 03:03 PM   #8 (permalink)
Super Moderator
Paid & Proud
 
Tidgy's Avatar
 
Join Date: Apr 2006
Location: Nottingham
Posts: 18,743
good move has to be said mate
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to cleanfactory boost solenoid (controler!) pum Engine Bay 10 16 Apr 2010 11:22 PM
Time Attack STi dynamix Users Photo Gallery 40 29 Sep 2008 02:21 AM
Rally GB entries up on this time last year. News_Bot Rally News 0 14 Oct 2007 09:45 AM
boost problem - need help! Big Dawg Engine Bay 2 13 Jun 2006 07:32 PM


All times are GMT. The time now is 11:42 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.