Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

newby saying hi
Reply
 
LinkBack Thread Tools Display Modes
Old 10 Jan 2006, 09:20 AM   #1 (permalink)
Fresh Scooby
 
Join Date: Jan 2006
Posts: 5
newby saying hi

Hi Guys,

I just joined the site yesterday as I have bought a 1994 L reg Impreza wrx as a 30th b'day present to myself. Well chuffed with the car apart from the radiator fan staying on all the time and the engine check light staying on (although I think thats just because of the fan) Before I start ordering parts etc I was wondering if anyone else has had a similar problem and if changing the coolant temp sensor or fan switch would solve it. Would appreciate any comments. Thanks

Sunny
Offline   Reply With Quote
Old 10 Jan 2006, 06:38 PM   #2 (permalink)
Obsessed Scooby
Paid & Proud
 
PeterUK300's Avatar
 
Join Date: Apr 2004
Location: East Herts
Posts: 12,081
Welcome to the site

See here for checking ECU for error codes
http://www.saxonfields.freeserve.co....iag%20Page.htm

Should tell you what is wrong
__________________
All the best
Pete

http://www.scoobyweb.co.uk
Offline   Reply With Quote
Old 10 Jan 2006, 07:23 PM   #3 (permalink)
Obsessed Scooby
 
Tricia's Avatar
 
Join Date: Sep 2004
Location: North Hampshire, UK
Posts: 8,711
Hiya Sunny, welcome to the .org....
__________________
Never Drive Faster Than Your Guardian Angel Can Fly....!!!!
We Girlies Rule...!!!
Offline   Reply With Quote
Old 10 Jan 2006, 07:29 PM   #4 (permalink)
Super Moderator
Paid & Proud
 
2002pete's Avatar
 
Join Date: Sep 2004
Location: UK
Posts: 14,377
Hi Sunny Welcome to .org mate
__________________
Pete.

Offline   Reply With Quote
Old 10 Jan 2006, 07:29 PM   #5 (permalink)
Cool Scooby
 
N_Collins's Avatar
 
Join Date: Apr 2004
Location: Cornwall
Posts: 254
Hi mate and welcome.

It sounds like the coolant temp sensor is playing up. Do a code read and see what comes up and then reset the ecu and check again.
Offline   Reply With Quote
Old 10 Jan 2006, 10:42 PM   #6 (permalink)
Dedicated Scooby
 
Nelson's Avatar
 
Join Date: Apr 2004
Location: South West
Posts: 2,659
Might also be worth checking that the ECU plugs aren't still plugged in cos this can cycle the ECU read/reset process and this would mean fans would be on all the time
Offline   Reply With Quote
Old 11 Jan 2006, 02:26 PM   #7 (permalink)
Fresh Scooby
 
Join Date: Jan 2006
Posts: 5
Thank you very much for the welcome and the suggestions. Did an ecu diagnostic test came up 21 which is coolant temp sensor. One ordered from subaru should be here tommorow. Many thanks to all those that helped.
Offline   Reply With Quote
Old 11 Jan 2006, 02:27 PM   #8 (permalink)
Veteran Scooby
 
Curtiz's Avatar
 
Join Date: Dec 2005
Location: Belfast
Posts: 2,988
gd luck with it mate!

and welcome along to the site
Offline   Reply With Quote
Old 11 Jan 2006, 02:30 PM   #9 (permalink)
Obsessed Scooby
 
Join Date: Oct 2005
Location: Norwich
Posts: 5,170
Ay good luck with it mate.

Welcome by the way

Offline   Reply With Quote
Old 14 Jan 2006, 08:53 AM   #10 (permalink)
Fresh Scooby
 
Join Date: Jan 2006
Posts: 5
Just an update. Got the coolant temp sensor and fitted it then reset the ecu and now the car is perfect. Thank you for all the advice guys.

Sunny
Offline   Reply With Quote
Old 14 Jan 2006, 01:13 PM   #11 (permalink)
Scooby Fanatic
 
johnboy's Avatar
 
Join Date: Mar 2005
Location: Richmond Surrey/Isleworth Middx
Posts: 800
Welcome m8 - glad its sorted!
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
newby smog Newbies - Say Hello Here 7 04 Sep 2005 05:17 PM
scooby newby b8steve Newbies - Say Hello Here 12 27 Jul 2005 09:31 AM
I'm a newby.....to driving my scoob coolangatta Subaru Impreza Discussions 6 20 Mar 2005 08:09 PM
NEWBY WITH A SCOOBY FROM SUFFOLK mel98 Newbies - Say Hello Here 17 21 Dec 2004 12:21 AM
Another newby ScoobywagonGL Newbies - Say Hello Here 21 04 Jul 2004 06:34 PM


All times are GMT. The time now is 09:41 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.