Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

Help turbo on its last legs
Reply
 
LinkBack Thread Tools Display Modes
Old 30 Nov 2005, 07:22 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Jun 2005
Location: Bracknell
Posts: 45
Help turbo on its last legs

Hi Guys,
My Turbo started making some pretty rough sounds yesterday!
Can't really explain the noise except it sounds like turbo whistle but much deeper and louder.
How can i make sure it is the turbo before it goes on me and what sort of outlay am i looking at for a recon?

Bugger!

Cheers Pete
Offline   Reply With Quote
Old 01 Dec 2005, 04:32 PM   #2 (permalink)
Fresh Scooby
 
Join Date: Nov 2005
Posts: 7
it could just be your gasket i had one go on my 200 and it sounded like a tractor if you can try and feel for any blowing around the gaskets careful not to brun your self though
Offline   Reply With Quote
Old 02 Dec 2005, 11:49 AM   #3 (permalink)
Fresh Scooby
 
Join Date: Jun 2005
Location: Bracknell
Posts: 45
I'll have a look at that..I'm going to do a oil change aswell see if that prolongs things
Cheers Pete
Offline   Reply With Quote
Old 03 Dec 2005, 08:41 AM   #4 (permalink)
Cool Scooby
 
Join Date: Nov 2004
Posts: 388
Check to restrictor in the boost solonoid pipework and the boost pipework itself!!!

Sometimes if the engine gets overfilled with oil it will get into the pipework and causes similar problems!!! 8)

Give it all a clean out and see how it goes.

It's not impossible for the turbo to go, but it is pretty hard.
Offline   Reply With Quote
Old 05 Dec 2005, 03:33 PM   #5 (permalink)
Fresh Scooby
 
Join Date: Jun 2005
Location: Bracknell
Posts: 45
Think there was too much oil in engine did an oil change and filled it up with approx 4 litres....but as I was under the bonnet thought I have a look at this power streering leak from the reservoir i've had for a while.
Took the reservoir off to see how it all went together and see if their was anything obvious.
All looked ok put it back together filled up the reservoir started car, got the i need more fluid noise so topped it up...noise got worse and then I noticed bubbles in the fluid!!
so my question is have a got air in the system from taking reservoir off or am I sucking air in now from not seating the reservoir correctly.
The noise dare I say it sounds like the bearings are knackerd but surely just running the car up in the driveway with low fluid would'nt bugger them ...would it??
wish I left well alone now easy to say in hind sight I guess

Any thoughts

Not happy Pete
Offline   Reply With Quote
Old 09 Dec 2005, 12:17 PM   #6 (permalink)
Fresh Scooby
 
Join Date: Jun 2005
Location: Bracknell
Posts: 45
The turbo is ok its the power steering pump thats had it!
200 quid from grade A
Better that than the turbo

Later guys

Pete
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Info: VF Series turbo 2002pete Engine Bay 22 18 Sep 2009 07:57 AM
Scooby shootout pot1175 National Meetings and Track Days 12 26 Jul 2006 04:43 AM


All times are GMT. The time now is 02:59 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.