Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

Bug Eye WRX PPP - low boost
Reply
 
LinkBack Thread Tools Display Modes
Old 31 May 2013, 10:33 AM   #1 (permalink)
Regular Scooby
 
KaraK's Avatar
 
Join Date: May 2004
Location: Cumbria, UK
Posts: 189
Send a message via MSN to KaraK
Bug Eye WRX PPP - low boost

Noticed a few weeks back that the car didn't feel as fast as it had done previously, as I'd just acquired an OBD dongle I did some logging and found that I was only getting 0.6 bar of boost rather than about the 1.1 I'd expect from the PPP map. Double checked the MAP sensor's figures by plumbing in a separate boost test kit which confirmed the readings from the ODB, thinking I might have a boost leak I gave the car to my mechanic to pressure test and it all came back good.

Next thought was to try the boost solenoid so I picked one up off ebay and fitted it, after jump starting the car (stupid battery went flat while it's been parked up - grr!) I took it out for a run with the OBD on, initially I was only seeing 0.7 bar but after 20 mins or so of driving I did another run and saw 0.8, a further run and I was seeing 1 bar which is encouraging if a little shy of the aimed for figure. What I'm wondering is whether the flat battery means the ECU was in some kind of learning mode and slowly increasing boost as I drove or whether I've still got issues?

Other things to throw in the mix is that the last round of work the car had done was to correct a couple of exhaust leaks - most notably the up pipe was shagged and I replaced it with a decat item - I don't have any readings to confirm but I'm pretty sure that immediately after this work and for a good couple of weeks afterwards it was boosting correctly. I'm going to do some more running over the weekend and see if I'm now consistently getting this 1 bar figure but in the meantime has anyone got any suggestions?
__________________
Not even in the face of armageddon - never compromise
Offline   Reply With Quote
Old 31 May 2013, 05:05 PM   #2 (permalink)
Super Moderator
Paid & Proud
 
Tidgy's Avatar
 
Join Date: Apr 2006
Location: Nottingham
Posts: 18,743
Re: Bug Eye WRX PPP - low boost

I'd be more worrie about the boost going all over the place, get it looked at by a specialist.
__________________
PM, Squirrels best friend, cream egg king and resident .org spam tart/Perv
Offline   Reply With Quote
Old 05 Jun 2013, 09:17 AM   #3 (permalink)
Regular Scooby
 
KaraK's Avatar
 
Join Date: May 2004
Location: Cumbria, UK
Posts: 189
Send a message via MSN to KaraK
Re: Bug Eye WRX PPP - low boost

Car is booked in for a diagnostic session this afternoon so fingers crossed we'll get to the bottom of it (at 75 for the hour I damn well hope so anyway!)
__________________
Not even in the face of armageddon - never compromise
Offline   Reply With Quote
Old 01 Jul 2013, 01:13 PM   #4 (permalink)
Regular Scooby
 
KaraK's Avatar
 
Join Date: May 2004
Location: Cumbria, UK
Posts: 189
Send a message via MSN to KaraK
Re: Bug Eye WRX PPP - low boost

Probably time I updated this.. Car had a diagnostic session with a local specialist on Saturday and after plugging in and running it on the dyno he said that despite actually making quite decent power (261bhp at the fly) "it's knocking it's tits off" and that he thinks the likely cause is ringland failure

He also plumbed in his boost gauge and determined that it's not agreeing with the MAP sensor, suggesting that this might have failed as well.

At this point I really don't know what to do with the car now - if it is ringland failure then fixing it is anything from a piston swap to a full rebuild apparently, and with an initial quote for full rebuild coming in at 3k that doesn't sound feasible
__________________
Not even in the face of armageddon - never compromise
Offline   Reply With Quote
Old 01 Jul 2013, 01:38 PM   #5 (permalink)
Cool Scooby
 
Technical_Bob's Avatar
 
Join Date: Feb 2010
Location: In a cloud up in the sky, Like lucy
Posts: 291
Send a message via MSN to Technical_Bob
Re: Bug Eye WRX PPP - low boost

what year car is this?
Only the ring land is a issue on the 2.5,
what fuel you running, is the car serviced regular, was the fuelling ok?
__________________
Subaru servicing, repairs and diagnostic fault finding help available.
Offline   Reply With Quote
Old 02 Jul 2013, 03:45 PM   #6 (permalink)
Regular Scooby
 
KaraK's Avatar
 
Join Date: May 2004
Location: Cumbria, UK
Posts: 189
Send a message via MSN to KaraK
Re: Bug Eye WRX PPP - low boost

The car is a 2002 which as you say would may ringland failure rather unlikely, fuel was some fresh Vpower that I'd filled up with that morning. As a general rule I've only ever given the car 97 RON minimum - I think I once put about a fiver's worth of 95 in so I could limp it to a decent fuel station but it was positively babied all the way there and then filled up with the good stuff.

Car is serviced regularly - last service was about 6.5k ago and was oil, filter, plugs etc.

He didn't comment on the fuelling at all which would presumably suggest that it was ok? although foolishly I forgot to ask
__________________
Not even in the face of armageddon - never compromise
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
HP boost gutbucket Modifications - Tips and Tricks 3 18 Jun 2012 04:01 PM
E-Boost 40psi electronic boost controller sub225 Newbies - Say Hello Here 3 15 Apr 2012 03:03 PM
3 port boost solenoid, or manual boost controller philldoebagins Modifications - Tips and Tricks 6 03 Dec 2011 08:49 PM
boost problem - stutter/judder under boost occuring Dazzaboy7 Subaru Impreza Discussions 8 06 Oct 2011 12:04 PM
hitting boost cut, need help to lower boost mark191178 Subaru Impreza Discussions 12 01 Jul 2010 12:00 AM


All times are GMT. The time now is 05:56 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.