Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

fault codes!
Reply
 
LinkBack Thread Tools Display Modes
Old 04 Apr 2013, 06:51 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Mar 2011
Posts: 9
fault codes!

hi all! just finished changing the engine on my jdm classic wrx started it up and im getting fault codes 24 (idle system malfunction) and 45 ( pressure sensor) my first thoughts are that ive put vaccum hoses on wrong, could this cause it? thanks
Offline   Reply With Quote
Old 04 Apr 2013, 07:49 PM   #2 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,565
Re: fault codes!

Quote:
Originally Posted by vtec View Post
hi all! just finished changing the engine on my jdm classic wrx started it up and im getting fault codes 24 (idle system malfunction) and 45 ( pressure sensor) my first thoughts are that ive put vaccum hoses on wrong, could this cause it? thanks
if you had only started the car it wont have made boost so im not sure the 45 code is a hose, sounds daft but is it plugged in, or have you caught the wiring at all?
how long was the car not ran for, could the IACV have seized due to being dirty and not used maybe ?
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 04 Apr 2013, 07:55 PM   #3 (permalink)
Fresh Scooby
 
Join Date: Mar 2011
Posts: 9
Re: fault codes!

yeah i was thinking the iacv valve, the engine hasnt run for about 2 years i think! the engine has made boost because i had it revving before the fault code came up, the pipes are all on but im just not sure if they are in the right place!
Offline   Reply With Quote
Old 04 Apr 2013, 08:56 PM   #4 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,565
Re: fault codes!

WRX 1993 Fault 45
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 06 Apr 2013, 04:46 PM   #5 (permalink)
Fresh Scooby
 
Join Date: Mar 2011
Posts: 9
Re: fault codes!

ill change the iacv monday and clear the ecu hopefully that will do it! thanks for the help
Offline   Reply With Quote
Old 08 Apr 2013, 08:56 AM   #6 (permalink)
Fresh Scooby
 
Join Date: Mar 2011
Posts: 9
Re: fault codes!

its all good change the iacv thingy running sweet the other code has disappeared so thats hopefully a good thing?
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
abs fault codes?? how to get them?? smudge2031 Technical General 0 29 Jan 2011 09:42 PM
fault codes 24 and 23 scotto Engine Bay 2 03 Jul 2010 05:45 PM
Autronics fault codes Tidgy Technical General 0 05 Dec 2007 01:38 PM
ECU Data Fault Codes 2002pete Electrical (Including ICE) 2 25 Apr 2007 07:59 AM


All times are GMT. The time now is 01:23 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.