Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

Speedo problem
Reply
 
LinkBack Thread Tools Display Modes
Old 30 Dec 2012, 01:35 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Dec 2012
Posts: 1
Speedo problem

Afternoon all, I'm returning to this site after an absence of a few years. Hoping someone out there can help. I have a 98 Terzo and the speedo has stopped working (no mph or odometer). I suspect the problem lies with the vehicle speed sensor mounted on the gearbox? I also have a 99 Turbo with a failed gearbox. What I'm wondering is whether the speed sensors for the two cars are compatible? Both have the digital instrument panels, but unless I'm missing something, the speed sensor on the 99 car seems to be on the passenger side of the gearbox, rather than on the driver's side as it is on the Terzo. Any advice would be much appreciated.
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
speedo kph to mph scoobycrystal Interior 4 08 Jul 2010 08:21 AM
speedo mph dnt work hullscoob1986 Technical General 2 03 Jul 2010 12:57 PM
speedo problem njt-ponty Electrical (Including ICE) 7 04 Nov 2005 09:06 PM
speedo convertor njt-ponty Technical General 1 16 Oct 2005 05:45 PM
speedo help gaz c Subaru Impreza Discussions 0 19 Jun 2005 07:40 AM


All times are GMT. The time now is 05:34 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.