Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

boost problems
Reply
 
LinkBack Thread Tools Display Modes
Old 27 May 2012, 10:30 AM   #1 (permalink)
Fresh Scooby
 
teamwolf24's Avatar
 
Join Date: Jul 2011
Location: swindon
Posts: 13
boost problems

Hi all I need some help I have a 55 plate impreza wrx and it has boost problems.
when the engine is cool I am getting 1 bar of boost but when the engine warms up the boost only gets to 0.5 bar boost and the car feels flat.
I have now removed the hks dump valve and put the standard one on I have replaced the boost solenoid on the inner wing plus the air flow meter and it is still the same.
Has anyone had this problem or got any ideas?
Many thanks Baz
Offline   Reply With Quote
Old 27 May 2012, 02:02 PM   #2 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
Re: boost problems

done an ECU reset after reverting back to standard equipment?..if not,do one or get one done
__________________
Mapped by Enginetuner(Plymouth)..
Offline   Reply With Quote
Old 27 May 2012, 02:49 PM   #3 (permalink)
Fresh Scooby
 
teamwolf24's Avatar
 
Join Date: Jul 2011
Location: swindon
Posts: 13
Re: boost problems

Hi ecu reset last week and it's still the same and there are no error codes stored.
I have been told that the turbo can crack across the wast gate that can cause this problem? Or poss actuator fault?
Offline   Reply With Quote
Old 28 May 2012, 07:49 AM   #4 (permalink)
Super Moderator
Paid & Proud
 
Tidgy's Avatar
 
Join Date: Apr 2006
Location: Nottingham
Posts: 18,743
Re: boost problems

get it looked at by a specilaist and go from there, there are lots of things that can cause boost control issues from a sensor, to a part failure.

You an chase it round the engine bay replacing parts trying to find where the fault is and still never find it.
__________________
PM, Squirrels best friend, cream egg king and resident .org spam tart/Perv
Offline   Reply With Quote
Old 28 May 2012, 09:01 AM   #5 (permalink)
Fresh Scooby
 
teamwolf24's Avatar
 
Join Date: Jul 2011
Location: swindon
Posts: 13
Re: boost problems

It looks like it may have been the induction kit causing the problem as now removed and it seems to be running ok. Can an induction kit cause over boost? As ecu was shutting down or it may have just been that it was sucking in hot air. So going to make up a heat shield and cold air feed and poss remap. Going to give it a good run today to see how it runs.
Car was plugged into Subaru computer last week and had no errors and ecu was reset.
Will let you know how it runs Baz.
Offline   Reply With Quote
Old 28 May 2012, 12:13 PM   #6 (permalink)
Super Moderator
Paid & Proud
 
Tidgy's Avatar
 
Join Date: Apr 2006
Location: Nottingham
Posts: 18,743
Re: boost problems

Quote:
Originally Posted by teamwolf24 View Post
It looks like it may have been the induction kit causing the problem as now removed and it seems to be running ok. Can an induction kit cause over boost? As ecu was shutting down or it may have just been that it was sucking in hot air. So going to make up a heat shield and cold air feed and poss remap. Going to give it a good run today to see how it runs.
Car was plugged into Subaru computer last week and had no errors and ecu was reset.
Will let you know how it runs Baz.
if it flows enough air yes it can cause boost issues. Sounds liek you may have fouden the culprit though.

The computer isn't 100% reliable at picking up faults, and not all subaru mechanics are any good at fault finding without a computer telling them whats wrong.
__________________
PM, Squirrels best friend, cream egg king and resident .org spam tart/Perv
Offline   Reply With Quote
Old 28 May 2012, 08:56 PM   #7 (permalink)
Fresh Scooby
 
teamwolf24's Avatar
 
Join Date: Jul 2011
Location: swindon
Posts: 13
Re: boost problems

Done 100 miles today and all is good boosting as it should.
I'm glad you put not all Subaru mechanics can't fault find. I hope I don't fall into this category as have just started working at Subaru. LOL
Offline   Reply With Quote
Old 30 May 2012, 11:37 AM   #8 (permalink)
Super Moderator
Paid & Proud
 
Tidgy's Avatar
 
Join Date: Apr 2006
Location: Nottingham
Posts: 18,743
Re: boost problems

Quote:
Originally Posted by teamwolf24 View Post
Done 100 miles today and all is good boosting as it should.
I'm glad you put not all Subaru mechanics can't fault find. I hope I don't fall into this category as have just started working at Subaru. LOL
you have alot to learn then young padawan if you have just started,,,,

i've met some right crettin dealer mechanics, not just subaru ones i might add.
__________________
PM, Squirrels best friend, cream egg king and resident .org spam tart/Perv
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
over boost problems smudge2031 Engine Bay 19 23 Sep 2010 09:05 PM
boost problems almack69 Technical General 5 16 Feb 2010 07:43 PM
boost problems 1stimpreza Technical General 2 10 Dec 2009 07:30 AM
having problems with the boost?!? ashtray69 Technical General 3 21 Jul 2009 10:23 PM
boost problems gringo8585 Engine Bay 5 27 Feb 2009 06:45 PM


All times are GMT. The time now is 01:13 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.