Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

1996 WRX Not running right
Reply
 
LinkBack Thread Tools Display Modes
Old 24 Apr 2012, 01:09 AM   #1 (permalink)
Fresh Scooby
 
Join Date: Apr 2012
Posts: 10
1996 WRX Not running right

Hey everyone.. My 1996 WRX import doesnt seem to be running right..

When its cold... it will sit and idle.. but if i was to rev it it splutters. But if i put my foot flat to the floor it will slowly build up the revs.

And if i was to take it out for a run when its cold.. it will really misfire.

When its warmed up it will idle and rev ok. but out driving it feels underpowered.

Any idea? or starting points?
Offline   Reply With Quote
Old 26 Apr 2012, 10:24 AM   #2 (permalink)
Senior Scooby
 
scoobymike79's Avatar
 
Join Date: Sep 2009
Location: Lincolnshire
Posts: 1,730
Re: 1996 WRX Not running right

When was it last serviced, is the cel light on?
__________________
"Straight roads are for fast cars, turns are for fast drivers." -Colin McRae
Offline   Reply With Quote
Old 27 Apr 2012, 12:29 AM   #3 (permalink)
Fresh Scooby
 
Join Date: Apr 2012
Posts: 10
Re: 1996 WRX Not running right

Im not sure what the cell light is?

It had the oil and filters done just last week. But i never done the spark plugs as it seemed a really hard job and was guna look up some advice.

It smells like its running rich and its popping like there is excess fuel. So maybe if the plugs are weak and needing changed they might not be sparking enough to burn all the fuel??
Offline   Reply With Quote
Old 27 Apr 2012, 01:32 AM   #4 (permalink)
Senior Scooby
 
Join Date: Jan 2010
Posts: 1,370
Re: 1996 WRX Not running right

Cel - check engine light
Offline   Reply With Quote
Old 29 Apr 2012, 11:31 PM   #5 (permalink)
Fresh Scooby
 
Join Date: Apr 2012
Posts: 10
Re: 1996 WRX Not running right

Ah right.. no there are no warning lights on.
Offline   Reply With Quote
Old 29 Apr 2012, 11:58 PM   #6 (permalink)
Senior Scooby
 
Join Date: Jan 2010
Posts: 1,370
Re: 1996 WRX Not running right

May be the coolant temp sensor
Offline   Reply With Quote
Old 30 Apr 2012, 12:01 AM   #7 (permalink)
Cool Scooby
 
ccsworks's Avatar
 
Join Date: May 2011
Location: birmingham
Posts: 261
Re: 1996 WRX Not running right

what fuel are you using? standerd unleaded or v power. any upgrades?



FROM WORKS THE REAL DEAL.
Offline   Reply With Quote
Old 30 Apr 2012, 03:18 PM   #8 (permalink)
Senior Scooby
 
scoobymike79's Avatar
 
Join Date: Sep 2009
Location: Lincolnshire
Posts: 1,730
Re: 1996 WRX Not running right

I'd start by changing the plugs if they haven't been done for a long time, its not as difficult as it looks. When you say oil and filters does that include the air filter? I'd have thought if the coolant temp sensor was faulty it would throw up a cel light
__________________
"Straight roads are for fast cars, turns are for fast drivers." -Colin McRae
Offline   Reply With Quote
Old 30 Apr 2012, 06:48 PM   #9 (permalink)
Fresh Scooby
 
Join Date: Apr 2012
Posts: 10
Re: 1996 WRX Not running right

Im using the super unleaded. It has a Decat exhaust and front mount intercooler..

yea the air filter had been changed, also tried it running with a cone filter and it makes no difference.
Offline   Reply With Quote
Old 30 Apr 2012, 11:39 PM   #10 (permalink)
Cool Scooby
 
ccsworks's Avatar
 
Join Date: May 2011
Location: birmingham
Posts: 261
Re: 1996 WRX Not running right

as mike says its a good idea to start with the plugs if they haven't been changed.

the coolant sensor does through the CEL normally if its faulty.

has it been remapped according to the upgrades. all so try v. power fuel.

I triad mine on super unleaded once when shell was dry It holds back.



FROM WORKS THE REAL DEAL.



FROM WORKS THE REAL DEAL.
Offline   Reply With Quote
Old 02 May 2012, 11:29 PM   #11 (permalink)
Fresh Scooby
 
Join Date: Apr 2012
Posts: 10
Re: 1996 WRX Not running right

Would it usually need a remap for just a decat and front mount cooler?

Can someone tell me where i will find the coolant sensor?
Offline   Reply With Quote
Old 03 May 2012, 10:06 AM   #12 (permalink)
Senior Scooby
 
Join Date: Jan 2010
Posts: 1,370
Re: 1996 WRX Not running right

Absolutely needs a remap with those mods
Offline   Reply With Quote
Old 03 May 2012, 12:41 PM   #13 (permalink)
Super Moderator
Paid & Proud
 
Tidgy's Avatar
 
Join Date: Apr 2006
Location: Nottingham
Posts: 18,743
Re: 1996 WRX Not running right

Could be a maf issue, another sensor issue or could indeed need mapping or a combination.

Need to get it to a specialist to get it looked at, drive it as little as possible (not at all if you can) and keep the revs very very low, under 2500rpm.
__________________
PM, Squirrels best friend, cream egg king and resident .org spam tart/Perv
Offline   Reply With Quote
Old 06 May 2012, 06:24 PM   #14 (permalink)
Fresh Scooby
 
Join Date: Apr 2012
Posts: 10
Re: 1996 WRX Not running right

What works the fueling? it seems the car is overfueling quite alot. it stinkes of petrol and the exhaust pops and bangs like its igniting of something.

Any ideas?
Offline   Reply With Quote
Old 07 May 2012, 01:47 AM   #15 (permalink)
Cool Scooby
 
ccsworks's Avatar
 
Join Date: May 2011
Location: birmingham
Posts: 261
Re: 1996 WRX Not running right

You would need the right tools and data to check things like fuel pressure.

Was the car ever running right when you bought it?

If not it could be a number of things being an import car.

Being an import If some of the upgrades were removed of the engine the old map would still through same amount of fuel.

A bigger fuel pump with too much fuel pressure they normally have an adjustable race fuel pressure regulator could be set on high.

Your maf could be playing up or clogged.

It could be the air released from your dump valve will cause over fuelling depending on what type of dv you got.

It could be your outlet valves creeping out compression and over fuelling.

The popping noise could be the anti lag.

Most times its un burnt fuel igniting.

Too much air and the fuel canít burn smoothly . To little air and the fuel simply canít burn, because there isnít enough air to burn it all.

It might be uk fuel itself not running right on the old map because imports run n high octane.

Am sure most of the lads here would recommend a remap to get it running right as long as your engine is ok and has good compression.

If thereís any other upgrades you planning i would do them before the remap.



FROM WORKS THE REAL DEAL.
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
my 1996 wrx turbo scottyb1 Users Photo Gallery 20 15 Aug 2010 06:43 PM
1996 wrx restriction seddomyster Modifications - Tips and Tricks 15 29 Sep 2008 12:47 AM


All times are GMT. The time now is 07:26 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.