Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

power steering pump gone after timing belt replacement
Reply
 
LinkBack Thread Tools Display Modes
Old 06 Mar 2012, 06:30 AM   #1 (permalink)
Fresh Scooby
 
Join Date: Mar 2011
Posts: 18
power steering pump gone after timing belt replacement

I just had my timing belt replaced on my 2007 subaru impreza and as soon as I get it back I am told my power steering was noisy and the pump needs replacing. I had no problems or noise what so ever before this, and now the continuous whine. I am a little concerned the mechanic might have not done something correctly to damage the pump.

Is it known for this to occur, or could the mechanic have done something wrong? I don't want to pay $500 for a replacement second hand pump when it may have been damaged by the mechanic.
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
intermittent knocking noise after timing belt replacement mark81 Technical General 0 04 Feb 2012 05:33 AM
Timing Belt Replacement mark81 Subaru Impreza Discussions 3 21 Oct 2011 07:14 PM
Power Steering Belt... No it must be the A/C Belt ferko_67 Technical General 1 30 Apr 2011 07:01 AM
sqeaking power steering pump help ianjohn Engine Bay 3 12 Nov 2010 05:43 PM


All times are GMT. The time now is 06:00 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.