Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

Strange Breaking problem
Reply
 
LinkBack Thread Tools Display Modes
Old 21 Feb 2012, 03:00 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Feb 2012
Posts: 2
Strange Breaking problem

Hey all, I have this strange breaking problem with my car.
Its a 1999 Subaru Impreza 2.0 sport.
The problem is all 4 breaks are binding on when I push the break peddle twice as I'm slowing down or came to a stop.
Anyone experienced a problem like this before?
Offline   Reply With Quote
Old 21 Feb 2012, 05:30 PM   #2 (permalink)
Super Moderator
Paid & Proud
 
Tidgy's Avatar
 
Join Date: Apr 2006
Location: Nottingham
Posts: 18,743
Re: Strange Breaking problem

are the pistons seizing?
__________________
PM, Squirrels best friend, cream egg king and resident .org spam tart/Perv
Offline   Reply With Quote
Old 27 Feb 2012, 02:32 PM   #3 (permalink)
Fresh Scooby
 
Join Date: Feb 2012
Posts: 2
Re: Strange Breaking problem

Sorry for the late reply, the pistons ain't seizing as the breaks have been checked over by 2 mechanics. The breaks work fine while driving, it's only when I come to a stop then press the break peddle twice they bind on. To take off the binding breaks when I've stopped I have to push the clutch down and up whilst out of gear.
Offline   Reply With Quote
Old 27 Feb 2012, 03:57 PM   #4 (permalink)
Senior Scooby
 
Join Date: Jan 2010
Posts: 1,370
Re: Strange Breaking problem

I'd look towards your servo
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange oil reading!! w16lam Subaru Impreza Discussions 1 11 Apr 2011 02:30 PM
Strange problem with engine check light ?? alexb Engine Bay 6 10 May 2010 09:44 PM
Strange Idling was4 Engine Bay 0 08 Jun 2008 04:52 PM
strange boost problem! doc__dave Engine Bay 11 30 Aug 2007 07:09 PM


All times are GMT. The time now is 10:16 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.