Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

Idle speed
Reply
 
LinkBack Thread Tools Display Modes
Old 01 Jan 2012, 10:53 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Jan 2012
Posts: 5
Idle speed

Hi all.
I've just bought a wrx turbo v plate
When I start it the rpm is about 1500 then when it's warm it drops to 1000 rpm.
Is this normal for a car of this age?
Thanks.
Offline   Reply With Quote
Old 04 Jan 2012, 03:18 PM   #2 (permalink)
Cool Scooby
 
Join Date: Nov 2009
Posts: 211
Re: Idle speed

i would say so, mine does this but currently idling a touch high at 1100rpm. Have cleaned the idle control valve too. Straight after i cleaned it it dropped to 800 rpm but has since risen. if yours sits at 1000 that shoud be ok i would think.
Offline   Reply With Quote
Old 04 Jan 2012, 03:26 PM   #3 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
Re: Idle speed

anywhere between 800 and 1000 rpm is fine...
__________________
Mapped by Enginetuner(Plymouth)..
Offline   Reply With Quote
Old 08 Jan 2012, 09:00 PM   #4 (permalink)
Fresh Scooby
 
Join Date: Jan 2012
Posts: 5
Re: Idle speed

Thanks guys.
Offline   Reply With Quote
Old 10 Jan 2012, 05:11 PM   #5 (permalink)
Fresh Scooby
 
Join Date: Jan 2012
Posts: 5
Re: Idle speed

Ok so now it won't settle when idling. it jumps from 100 to 1000 like its purring and stalled on me. It has only stalled once but the engine seems juddery when idling. Any help is greatly appreciated. Thanks.
Offline   Reply With Quote
Old 10 Jan 2012, 06:35 PM   #6 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
Re: Idle speed

sounds like the 02 sensor is on it's way out fella...
__________________
Mapped by Enginetuner(Plymouth)..
Offline   Reply With Quote
Old 11 Jan 2012, 12:16 AM   #7 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,567
Re: Idle speed

Quote:
Originally Posted by Cozytoes3rd View Post
Ok so now it won't settle when idling. it jumps from 100 to 1000 like its purring and stalled on me. It has only stalled once but the engine seems juddery when idling. Any help is greatly appreciated. Thanks.
did u clean the IACV out ? if so did you replace the gasket for it, I know they look 100% but i had a issue on a car where it wouldnt idle properly, I had cleaned the IACV and the gasket looked fine but as it was old it had been compressed to a point where it wasnt sealing correctly after being opened and cleaned, if you havent cleaned it then im talking testicles lol
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 28 Jan 2012, 04:19 PM   #8 (permalink)
Fresh Scooby
 
Join Date: Jan 2012
Posts: 5
Re: Idle speed

Thanks mates. It was the maf and and O2 . She's runnin sweet again.
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
erractic idle after map showtime Technical General 4 31 Jan 2011 12:59 PM
Odd Idle when hot WAYNE WRX Engine Bay 3 12 Oct 2007 07:41 PM
idle all over??? andyd Engine Bay 4 10 Jan 2007 09:38 PM
slow idle speed causes stalling starsistar Engine Bay 6 23 Aug 2005 07:41 PM


All times are GMT. The time now is 07:54 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.