Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza Technical Area > Technical General

Subaru Impreza Forum

sudden JERK in hard acceleration :(
Reply
 
LinkBack Thread Tools Display Modes
Old 08 May 2011, 07:47 PM   #1 (permalink)
Fresh Scooby
 
Join Date: May 2011
Posts: 20
sudden JERK in hard acceleration :(

when accelerating hard in 3rd /4th gears around 3-4000 RPM it just cuts out and the cars rams me forward asif i had braked hard, and then continues and does it again. although its fine when i dont drive hard. please forgive me as me impreza turbo knowledge is nil. i just bought it today and im annoyed. i read about unpluging the maf and it did cut out so i assume its not that. i hope somebody can help me as my friend said it may be the piston rings? which sounds expensive. please guide me!! thanks alot matt
Offline   Reply With Quote
Old 08 May 2011, 09:43 PM   #2 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: sudden JERK in hard acceleration :(

sounds like your hitting limp mode for some reason if it doesnt rev over 4500 rpm?
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 08 May 2011, 09:46 PM   #3 (permalink)
Cool Scooby
 
ccsworks's Avatar
 
Join Date: May 2011
Location: birmingham
Posts: 261
Re: sudden JERK in hard acceleration :(

is your cel on the engine managment light
Offline   Reply With Quote
Old 09 May 2011, 06:23 AM   #4 (permalink)
Regular Scooby
 
Goulders's Avatar
 
Join Date: Oct 2010
Posts: 131
Re: sudden JERK in hard acceleration :(

When you say 'cuts out', do you mean the engine stops or it just loses power?? I assume it just holds you back and you can then drive 'normally' which would point towards a turbo problem. Have a search on .org and there are loads of helpful threads. Could be a faulty turbo actuator, but quite possibly a vacuum hose that is split and/or leaking and presents itself under boost. Check your hoses are all ok by taking one off at a time and thoroughly examining it and then check the actuator arm moves on the turbo.
__________________
Here, there, every fecking where!!!
Offline   Reply With Quote
Old 09 May 2011, 08:07 AM   #5 (permalink)
Fresh Scooby
 
Join Date: May 2011
Posts: 20
Re: sudden JERK in hard acceleration :(

thanks for your replies, it does rev beyond 4,500, no cel light, and its doesnt cut out just suddenly looses it for a split second then resumes acceleration, then same problem repetativly under hard acceleration. i read about overboosting and to turn down boos to lengthen the rod on actuator?? but my actuator is covered by a big heat shield on the turbo and looks a bit to complicated for me. im going to clean out the wastegate solenoid and replace fuel filter to see if this helps, any more help is very much apriciated. oh 1 more thing, its only day 2 of owning the car and car wont start this morning so im looking at a dodgy alternator or batteryaswell (aswell as a noticing oil on drive this morning) !!
Offline   Reply With Quote
Old 09 May 2011, 08:35 AM   #6 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
Re: sudden JERK in hard acceleration :(

sounds like boost cut or fuel cut,more likely to be boost though..
__________________
Mapped by Enginetuner(Plymouth)..
Offline   Reply With Quote
Old 09 May 2011, 10:10 AM   #7 (permalink)
Regular Scooby
 
Goulders's Avatar
 
Join Date: Oct 2010
Posts: 131
Re: sudden JERK in hard acceleration :(

Quote:
Originally Posted by mattyjonesgy View Post
thanks for your replies, it does rev beyond 4,500, no cel light, and its doesnt cut out just suddenly looses it for a split second then resumes acceleration, then same problem repetativly under hard acceleration. i read about overboosting and to turn down boos to lengthen the rod on actuator?? but my actuator is covered by a big heat shield on the turbo and looks a bit to complicated for me. im going to clean out the wastegate solenoid and replace fuel filter to see if this helps, any more help is very much apriciated. oh 1 more thing, its only day 2 of owning the car and car wont start this morning so im looking at a dodgy alternator or batteryaswell (aswell as a noticing oil on drive this morning) !!
The heat shield is a bit fiddly to get off, but is only around half as dozen screws to get off then you can access the rod. Unclip the rod and take the wastegate actuator off. You need a vacuum to test it correctly, but if you push it in and cover the pipe, it should hold a little bit and when you remove the cover from the pipe, the rod should pop out. The rod should move backwards and forwards and although may be a bit stiff, shouldnt be notchy.
Then check the little lever on the turbo. It should be free and little or no resistance. Without taking the turbo apart to check the vanes, it would be impossible to confirm they are spot on, but if the lever moves ok, they should be ok as you are still getting the boost.
Check and double check ALL the boost pipework. There are quite a few, but make sure there no obvious cracks or splits and all the connections are tight.
As for the fuel filter, I had the same problem when I bought mine. I posted a thread on here, but basically the filter was fooked and consequently the car wouldnt start as it should and took 10 seconds to start. After a change, it cracked up first time. If your battery is a little weak, it may drain very quickly on start up.
Is the car turning over as normal, but just not firing and then the battery drains or is there no power at all.
As for the oil, all you need to do is trace back where is had come from. Sometime, you need to wipe the whole engine down and check again after a couple of days to trace the source. Hopefully, that wont be too serious, but it depends if it is engine oil or gearbox oil.
Oh, and make sure you use V-Power or equivalent. Imprezas (in my experience) dont like cheap, low RON fuels. I tried cheaper fuels and got all sorts of running problems until I switched to V-Power. Now I get and extra 40 miles per tank so the extra cost is paid back in extra miles.
Dont forget to reset your ECU as it could have learnt to cut fuel at certain points. See some of my previous threads cos I have learnt through trial and error, but more importantly by listening to the great advice from those on this forum. They are really helpful and very clued up!!
__________________
Here, there, every fecking where!!!
Offline   Reply With Quote
Old 09 May 2011, 11:26 PM   #8 (permalink)
Cool Scooby
 
ccsworks's Avatar
 
Join Date: May 2011
Location: birmingham
Posts: 261
Re: sudden JERK in hard acceleration :(

check your dump velve if its the after market one they thruogh to much pressur out when the standerd on pushes the boost back in so theres no 1 or 2 secound delay in power at hight reves.
Offline   Reply With Quote
Old 12 May 2011, 08:44 AM   #9 (permalink)
Fresh Scooby
 
Join Date: May 2011
Posts: 20
Re: sudden JERK in hard acceleration :(

Solved it (i think) its not done it since, i clearer out the boost solenoid whilst in diagnostic with brake cleaner and its fine now. I have a new problem since though if any1 can help iys a tapping noise soinds just like




Is it something to worry about thanks
Offline   Reply With Quote
Old 12 May 2011, 09:16 AM   #10 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: sudden JERK in hard acceleration :(

sounds like an injector ticking but not 100%
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 12 May 2011, 11:58 AM   #11 (permalink)
Fresh Scooby
 
Join Date: May 2011
Posts: 20
Re: sudden JERK in hard acceleration :(

Been quote 2 hours labour
Just to investigate what it is either lifters or tappets possibly, is it safe to drive hard with this problem?
Offline   Reply With Quote
Old 12 May 2011, 01:46 PM   #12 (permalink)
Regular Scooby
 
Goulders's Avatar
 
Join Date: Oct 2010
Posts: 131
Re: sudden JERK in hard acceleration :(

Agree with Bob, sounds like the injectors. Mine sounds the same.
__________________
Here, there, every fecking where!!!
Offline   Reply With Quote
Old 12 May 2011, 02:37 PM   #13 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: sudden JERK in hard acceleration :(

if it hasnt had a recent oil change then give it one, it may help if they think its the tappets and is cheaper then 2 hours to look at it.
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 13 May 2011, 08:33 AM   #14 (permalink)
Fresh Scooby
 
Join Date: May 2011
Posts: 20
Re: sudden JERK in hard acceleration :(

Had an oil change(old oil stank of petrol) and garage say they now think its a pinton and needs new engine or a rebuild keeps getting worse and reason why its only doing about 10MPG is because of that! Dont know what to do or where to start now any1 no where i can get an engine from? Thanks
Offline   Reply With Quote
Old 13 May 2011, 10:21 AM   #15 (permalink)
Regular Scooby
 
Goulders's Avatar
 
Join Date: Oct 2010
Posts: 131
Re: sudden JERK in hard acceleration :(

Quote:
Originally Posted by mattyjonesgy View Post
Had an oil change(old oil stank of petrol) and garage say they now think its a pinton and needs new engine or a rebuild keeps getting worse and reason why its only doing about 10MPG is because of that! Dont know what to do or where to start now any1 no where i can get an engine from? Thanks
Get a second opinion!!! Have they done proper tests or just guessed at what the problem is. I am no mechanic, but that seems a convenient diagnosis for them if they haven't tested it properly and therefore will make them more money.
__________________
Here, there, every fecking where!!!
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
sudden unintended acceleration seascay Technical General 4 15 Mar 2011 10:52 AM
Unwanted reving during hard acceleration heffs976 Technical General 9 18 Nov 2009 08:41 AM
SUBARU STI VERSION 2 - MISSING UNDER HARD ACCELERATION scoobymad2005 Subaru Impreza Discussions 3 27 Sep 2008 03:14 PM
Sudden loss of skills spanky Subaru Impreza Discussions 7 06 Jan 2005 03:46 PM


All times are GMT. The time now is 08:44 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.