Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza General > Subaru Impreza Discussions

Subaru Impreza Forum

new car new member some probs
Reply
 
LinkBack Thread Tools Display Modes
Old 02 Dec 2010, 10:54 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Dec 2010
Posts: 6
new car new member some probs

hi guys after this weather and living on a farm i was out to buy a jeep of some sort but there was nowt in my price range so i ended up getting a impreza 2.0 auto cheap i have a few niggles with it there is some sort of electrcal fault the inside light, clock,hazzards and front spots/fogs dont work i have had a wee look at the fuse under the bonnet but they all look fine can someone point me in the right direction i also have a what looks like brake warning light not the hand brake and the airbag light apart from that it seems to drive stop good

Offline   Reply With Quote
Old 02 Dec 2010, 11:17 PM   #2 (permalink)
Scooby Fanatic
 
alunian's Avatar
 
Join Date: Aug 2010
Posts: 752
Re: new car new member some probs

have you checked the fuses behind the coin tray next to the steering wheel, you will need to remove the tray to get to them.
Offline   Reply With Quote
Old 03 Dec 2010, 07:27 AM   #3 (permalink)
Fresh Scooby
 
Join Date: Dec 2010
Posts: 6
Re: new car new member some probs

Quote:
Originally Posted by alunian View Post
have you checked the fuses behind the coin tray next to the steering wheel, you will need to remove the tray to get to them.
no but now i know know they are there cheers
Offline   Reply With Quote
Old 04 Dec 2010, 08:47 PM   #4 (permalink)
Fresh Scooby
 
Join Date: Dec 2010
Posts: 6
Re: new car new member some probs

ok hazzards work just a duff switch abs light off as snow was all jammed in sensor but still no light or clock the fuse is fine and i bridged the earth stil no joy where is the original earth for these and is there also a fuse in the main box under the bonnet if you switch the light to the off position the clock comes on very dim and radio goes off radio also needs to be switched on every time thr ignition if turned on and off this lets me to think there is a problem with the supply as the radio has two and the permanant live is shared with the clock and light any body no where the live comes from
Offline   Reply With Quote
Old 06 Dec 2010, 10:18 PM   #5 (permalink)
Scooby Fanatic
 
alunian's Avatar
 
Join Date: Aug 2010
Posts: 752
Re: new car new member some probs

I cant even read my clock anymore the bulb has gone.
I know this may sound daft but the only thing i can think of is checking the bulbs. Otherwise you'll have to wait for someone with more knowledge to help.
Offline   Reply With Quote
Old 07 Dec 2010, 01:45 PM   #6 (permalink)
Fresh Scooby
 
Join Date: Dec 2010
Posts: 6
Re: new car new member some probs

Quote:
Originally Posted by alunian View Post
I cant even read my clock anymore the bulb has gone.
I know this may sound daft but the only thing i can think of is checking the bulbs. Otherwise you'll have to wait for someone with more knowledge to help.
bulbs fine as it comes on very very dim im only getting 2.7v at the back of the clock
Offline   Reply With Quote
Old 07 Dec 2010, 09:09 PM   #7 (permalink)
Scooby Fanatic
 
alunian's Avatar
 
Join Date: Aug 2010
Posts: 752
Re: new car new member some probs

this is what i've come across in the subaru manual for the fuses in the engine bay.

Offline   Reply With Quote
Old 07 Dec 2010, 09:15 PM   #8 (permalink)
Fresh Scooby
 
Join Date: Dec 2010
Posts: 6
Re: new car new member some probs

Quote:
Originally Posted by alunian View Post
this is what i've come across in the subaru manual for the fuses in the engine bay.

thanks for the reply bud but my fuse box if different to than one i think i have a weak connection somewhere as if flickers as you drive over bumps really bugging me now lol
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Vatanen boosted by FIA member clubs News_Bot Formula News 0 10 Sep 2009 04:12 PM
Riggs' crew member hit with suspension. News_Bot Nascar News 0 13 Nov 2006 03:28 PM
Riggs' crew member hit with suspension. News_Bot Nascar News 0 08 Nov 2006 08:01 PM
Lamba link wring probs! pot1175 Electrical (Including ICE) 0 15 Sep 2006 04:54 PM
PC Probs Nelson General Chat - Anything about Anything 7 06 Dec 2004 10:57 PM


All times are GMT. The time now is 01:51 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.