Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza General > Subaru Impreza Discussions

Subaru Impreza Forum

WRX problem help needed
Reply
 
LinkBack Thread Tools Display Modes
Old 04 Sep 2010, 02:19 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Sep 2010
Posts: 20
WRX problem help needed

Hello I own a impreza sti 98 import, however I have a friend who owns a uk spec impreza wrx 98 and has had problems for a while now.

Basically we have compression on all 4 cylinders, we have a spark, and we also have fuel. Injectors have been cleaned incase it was those, crank sensor, cam sensor replaced with mine off my car and still nothing. A number of other sensors from the left side of bay have been changed incase it was one of those, still nothing.

If car is bump started, it runs on left side only, and only if held on say 2-4k revs, now it wont even fire, it does try sometimes, but nothing.

it was tuned a while ago and ran fine, had heads done twice and was fine then one day stopped working, almost randomly. we've tried all fuses as far as I remember. and fuel pump does pump fuel through as we took line off the rail.

We have ran out of ideas... timing has been done few times to double check, it isnt possible for the crank to be 180 degrees out is it?
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Urgent Help needed with engine change problem! Richard9891 Subaru Impreza Discussions 2 31 Jul 2010 02:06 PM
STi problem (diff./clutch/gearbox) Mooseman Technical General 9 25 Sep 2009 08:50 PM
Wheel problem, advice needed scuba888 Exterior 3 16 Feb 2008 09:59 PM
problem, advice needed sjay72 Subaru Impreza Discussions 3 06 Feb 2007 04:13 AM
Performance problem help needed mikesp Engine Bay 3 19 May 2006 08:09 PM


All times are GMT. The time now is 09:36 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.