Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza General > Subaru Impreza Discussions

Subaru Impreza Forum

fan motor on 06' sti
Reply
 
LinkBack Thread Tools Display Modes
Old 01 Jul 2010, 08:45 AM   #1 (permalink)
Fresh Scooby
 
Join Date: Jun 2010
Posts: 3
fan motor on 06' sti

Hi all,

New in town and like to hear anyone has the same problem. I have an 06' STI in Hong Kong with Euro spec. After owning a while, noticed water temp goes usually high at lights. I had to replace relays at 20000 kilos and now new a/c fan motor at 30000 kilos. It turns out both of the above were made in thailand and other locals spoken with had same problem. It was quite nerve wrecking considering HK climate reach 33 and abv during summer. One I spoke with overheated during wedding reception attendance and burnt engine as result.
Just wondering if 06' STI elsewhere have same problem and how you guys dealt with it. I did manage to replace the fan control relays with ones made in Japan but the fan motor itself must stick with Thailand made. I was told inevitably fan motor would break again without hint and must pay extra attention constantly.
Tks for your advice in advance.
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 06:32 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.