Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza General > Subaru Impreza Discussions

Subaru Impreza Forum

any help please...
Reply
 
LinkBack Thread Tools Display Modes
Old 10 Sep 2009, 06:27 AM   #1 (permalink)
Fresh Scooby
 
Join Date: Aug 2009
Posts: 7
any help please...

-my rex has a unsteady idle and some times even stalls cos the idle drops so low. any ideas?

-Also when i plant it sometimes it goes real strong other times it feels flat as if its starving for fuel or something. could it need a uprated fuel pump? it has full exhaust and boost controller, not sure what its running yet (no gauge) but its bn wound up obviously.

- also when im on it, as soon as it hits around 120-130km it cuts out for a sec? could this be the ECU? im thinking of getting it dyno tuned if i cant sort it out myself, any help would be much appreciated as these cars are new to me, thanks.
Offline   Reply With Quote
Old 10 Sep 2009, 09:35 AM   #2 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
Re: any help please...

the cutting out could be either boost or fuel cut...


unsteady idle possibly down to MAF of Idle control valve,this will also have an effect of the performance ie:- holding back as you say..
__________________
Mapped by Enginetuner(Plymouth)..
Offline   Reply With Quote
Old 11 Sep 2009, 05:10 AM   #3 (permalink)
Fresh Scooby
 
Join Date: Aug 2009
Posts: 7
Re: any help please...

thanks alot mate, i think u mite be onto something with the MAF, dont know why i didnt think of that. a mate told me he knew of one that developed the unsteady idle after fitting a pod filter? doesnt sound right to me but sure enough it has one. ill clean the MAF and try that. very new to these cars, i know my V8s, this cars all very new to me but i must say its growing on me. if i could sort out these little problems ill be very happy with it.

-the cut out doesnt seem like fuel cos the motor really seems to almost stop dead for a sec as if its a limiter or something so spark maybe cutting out? could that be the coil pack maybe? thanks mate
Offline   Reply With Quote
Old 11 Sep 2009, 05:16 AM   #4 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
Re: any help please...

if the MAF is at fault and is cleaned/replaced,the problem should be resolved,if the spark was blowing out,you'd get it higher up in the rev range,also check all the pipework and give the boost solaniod a clean too..
__________________
Mapped by Enginetuner(Plymouth)..
Offline   Reply With Quote
Old 11 Sep 2009, 06:01 AM   #5 (permalink)
Fresh Scooby
 
Join Date: Aug 2009
Posts: 7
Re: any help please...

-i just took the pod filter off and it idled fine. it was pretty dirty so i cleaned it and it put it back on and it was alot better but not 100% maybe certain pod filters create turbulance thru the MAF which upsets it? what filter do u run?

-i know in commodore V6s, they have a similar coilpack setup and iv seen a problem several times where the car can be runnig fine until till u get around highway speeds and it will cut out thats wot got me thinkin that
-yeh well if i go up a gear, it cn push past the mark where it cuts but if i hold 3rd it cuts around 5500rpm
thanks alot mate, gettin there i think
Offline   Reply With Quote
Old 11 Sep 2009, 08:25 AM   #6 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
Re: any help please...

i run K&N,have done in all may cars,never had any issues

i know what you mean about the pushing the car past the mark,found that when i suffered from over boost and also when my MAF went,can be quite hard to explain..
__________________
Mapped by Enginetuner(Plymouth)..
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 02:14 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.