Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza General > Subaru Impreza Discussions

Subaru Impreza Forum

I notice LAG after the DV installed
Reply
 
LinkBack Thread Tools Display Modes
Old 23 Sep 2004, 10:46 PM   #16 (permalink)
Dedicated Scooby
 
Nelson's Avatar
 
Join Date: Apr 2004
Location: South West
Posts: 2,659
Thats helps loads and I for one would be very interested only it appears from the thread that they aren't available for the Classic Impreza
Offline   Reply With Quote
Old 26 Sep 2004, 12:57 AM   #17 (permalink)
Fresh Scooby
 
Join Date: Sep 2004
Posts: 11
Hi,

I have sent TSR an email regarding this. I will get back to you when i recieve their reply!!!!
Offline   Reply With Quote
Old 28 Sep 2004, 01:02 PM   #18 (permalink)
Regular Scooby
 
Join Date: Jun 2004
Location: South West
Posts: 118
My cars never had a recirc since I've owned but I do have one from another car. I'll stick it on and see if I notice any difference
Offline   Reply With Quote
Old 28 Sep 2004, 03:14 PM   #19 (permalink)
Dedicated Scooby
 
Nelson's Avatar
 
Join Date: Apr 2004
Location: South West
Posts: 2,659
Same as Olly - when I had my prev WRX it had a VTA from the beginning - Anyway I was having a few problems with a Forge VTA so I fitted a recirc and the car felt better through the gears and more smoother acceleration......I do miss the whooooosh at times though
Offline   Reply With Quote
Old 28 Sep 2004, 03:37 PM   #20 (permalink)
Regular Scooby
 
Join Date: Jun 2004
Location: South West
Posts: 118
Nelson is it possible that because you were having probs with your VTA changing it to anything else might have made an improvement?
I have been told that the only VTA's that don't mess the car about are the Blitz (which I have) and the HKS.
Maybe one day I can stick my Blitz on your car and see if its any good?
Offline   Reply With Quote
Old 28 Sep 2004, 04:03 PM   #21 (permalink)
Dedicated Scooby
 
Nelson's Avatar
 
Join Date: Apr 2004
Location: South West
Posts: 2,659
Nah mate - I had a HKS and a Forge and they both seemed to create a less smoother car in acceleration etc. The VTA seemed to cause more lag than take it away ?? The real problem that annoyed me was lifting off the throttle and getting a jerky ride when the VTA Dumped. I have however been told that this is normal with VTA's cos of the slight over fuelling! I put the oem recirc on which was good but then went out and bought a Forge Recirc which was a lot better.

This was experienced once again when I fitted the HKS to my current Scoob. The car definately feels better with the recirc on.....I just want to get an uprated recirc !! I am more than happy to try your Blitz mate on mine but my dumper bolts direct to the i/c so I will need the fitting kit

Personally the probs experienced aren't huge by any stretch and having gone to a Full Decat the car doesn't feel as smooth as it did (with the quieter zorst) anyway so a VTA now probably wouldn't make a huge difference to the smooth ride. A lot of it is down to personal preference
Offline   Reply With Quote
Old 29 Sep 2004, 09:26 PM   #22 (permalink)
RRH
Young Scooby
 
Join Date: Apr 2004
Location: Usually at Oulton.....
Posts: 75
I use a Forge re-circ DV.

The theory behind them is that a VTA will dump boost quicker rather than re-circulating it and causing the turbo to stall. They often have the amusing side effect of bigger pops, bangs and flames as the ECU dumps a load of fuel in, not realising the air isn't there any more.

A VTA is of no performance use unless you're running big boost, and as has been suggested, can often be counter-productive.

Most people just fit them for the noise. Whatever floats your boat..... :roll:
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
EBC Ultimax BlackDash USR Slotted Rotors... installed! Subie Gal Technical General 1 20 Apr 2008 04:17 PM
Defi's Installed - Ta Wuz! clutdav Users Photo Gallery 13 19 Jun 2006 07:26 AM
ICE installed... :) Phill-type-R Electrical (Including ICE) 6 02 May 2005 12:50 PM
installed body side molding applepad Exterior 3 23 Nov 2004 07:55 PM


All times are GMT. The time now is 06:41 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.