Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza General > Subaru Impreza Discussions

Subaru Impreza Forum

couple of questions/problems
Reply
 
LinkBack Thread Tools Display Modes
Old 19 Jan 2009, 05:19 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Jan 2009
Posts: 2
couple of questions/problems

hullo, another newbie with problems, acouple of days ago i bought a 94 wrx ra, ive noticed an oil leak from drivers side of engine, previous owner said rocker cover gaskets were fixed,is there anythig else common to leak or just a bad repair job? oil and exhaust = very bad smell!!! also car seems to steam up very easily, any sign of rain and i have to drive with blower and heated screen on full time! and finaly when cold car takes a bit of effort to start, anything in peticular to check that would cause this? any help greatly appreciated
Offline   Reply With Quote
Old 19 Jan 2009, 05:27 PM   #2 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: couple of questions/problems

Say it was a bad repair job on the rocker cover gasket drivers side, normally the heat off the turbo perishes the gasket then oil drips down onto hot exhaust and you get a burning oil smell what your getting......... could try the pollen filter for the hard to clear the windscreen think imprezas has these to .........as for the hard to starting could try leads and plugs and battery all the small things first

Last edited by stiimpreza1984; 19 Jan 2009 at 05:30 PM.
Offline   Reply With Quote
Old 19 Jan 2009, 05:35 PM   #3 (permalink)
Veteran Scooby
 
uk dave's Avatar
 
Join Date: Feb 2005
Location: Impreza Preservation Society HQ
Posts: 4,399
Send a message via MSN to uk dave
Re: couple of questions/problems

Mine steams up easily to be fair,but keep an eye on your coolant level as it could be a leaky heater matrix,on other cars ive owned when they`ve gone found the windows steamed up alot due to coolant leaking in the car may be worth checking if carpets wet anywhere around dash area nr heater.


Starting problems more than likely a sensor - cam/crank/water temp-try disconnecting/reconnecting battery to see if ya get a check engine light Ya can manually read faultcode then or maybe it just wants a service.Oil leak i`d say yer not a very good fix by previous owner.


Aboves just my opinion.
__________________
Best sealant used to date- Fourstar ultimate paint protection *Now discontinued* Rebranded as sonus SFX4 paint sealant-Try some ya wont be dissapointed.
Offline   Reply With Quote
Old 19 Jan 2009, 05:42 PM   #4 (permalink)
Fresh Scooby
 
Join Date: Jan 2009
Posts: 2
Re: couple of questions/problems

cheers lads, looks like i'll be getting my hands dirty sooner than i thought! suppose ownership cant all be fun!!
Offline   Reply With Quote
Old 20 Jan 2009, 06:11 PM   #5 (permalink)
Veteran Scooby
 
uk dave's Avatar
 
Join Date: Feb 2005
Location: Impreza Preservation Society HQ
Posts: 4,399
Send a message via MSN to uk dave
Re: couple of questions/problems

Dont look at them as problems its just a car with character, melted piston/knackered crank/head gasket issues/knackered gearbox/ they`re problems


I know water leaks can be a pain to find the source,but the oil leaks no big deal to get sorted.


Its when the pain outweighs the fun of owning one you`ve got problems!!
__________________
Best sealant used to date- Fourstar ultimate paint protection *Now discontinued* Rebranded as sonus SFX4 paint sealant-Try some ya wont be dissapointed.
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
couple of queries jimmyp Technical General 7 15 Oct 2008 05:34 PM
A couple of questions...... mcc_boz Technical General 3 01 Nov 2005 05:45 PM


All times are GMT. The time now is 11:57 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.