Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza General > Subaru Impreza Discussions

Subaru Impreza Forum

Bit of help needed
Reply
 
LinkBack Thread Tools Display Modes
Old 15 Nov 2008, 12:15 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Dec 2007
Posts: 28
Bit of help needed

Well got my impreza up for sale and i dont realy want to. but ive dug myself in and not thought before ive modded and added to my budget a remap.
and the fueling isnt very good mpg is bad i get aobut 15 mpg and lower drving slowly.
but due to a recent job loss i cant afford to shell out out a grand in one go for and apexi.
so what im thinking is taking it off th road over christmas and do a strip down all new gaskets minus the hg clean everything up heat lag all my piping and fit a turbo beanie new belts plugs and so on get everything new .
but what can i do about the fueling ive been looking and will an apexi afc neo work to sort my overfueling until i have the grand for the apexi ecu
Offline   Reply With Quote
Old 16 Nov 2008, 05:26 PM   #2 (permalink)
Veteran Scooby
 
uk dave's Avatar
 
Join Date: Feb 2005
Location: Impreza Preservation Society HQ
Posts: 4,399
Send a message via MSN to uk dave
Re: Bit of help needed

Just local running i only get about 18mpg,on a run probably 35mpg just the way it is, only got zorst an filter really on mine-if ya gonna mod stuff expect mpg to suffer.
__________________
Best sealant used to date- Fourstar ultimate paint protection *Now discontinued* Rebranded as sonus SFX4 paint sealant-Try some ya wont be dissapointed.
Offline   Reply With Quote
Old 16 Nov 2008, 09:30 PM   #3 (permalink)
Fresh Scooby
 
Join Date: Dec 2007
Posts: 28
Re: Bit of help needed

yeah i can even get past 15 lol my fueling is all over the place i think if i put my foot to the floor over 2500 rpm and let of it pops flames its gota be overfueling, i heard tho that 97 -98 do over fuel more than most to keep temps down to reduce det.
Im also gettin a black smoke when i floor it and i come on boost but not always
Offline   Reply With Quote
Old 16 Nov 2008, 11:01 PM   #4 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: Bit of help needed

Quote:
Originally Posted by -Ant- View Post
yeah i can even get past 15 lol my fueling is all over the place i think if i put my foot to the floor over 2500 rpm and let of it pops flames its gota be overfueling, i heard tho that 97 -98 do over fuel more than most to keep temps down to reduce det.
Im also gettin a black smoke when i floor it and i come on boost but not always
With the heavy fuel consumption is your air filter dirty or clogged if not could be a fuel injection system fault

As for the black smoke could be burning oil check the oil level when engine cold flat ground and check it then when engine cold in the same place a few days later it should not burn oil at all if the oil level drops you know your burning oil

Have a sti v6 RA and it dont burn oil at all my friends 04sti does not either
But as said above a modded engine the mpg will suffer more
hope it helps

Last edited by stiimpreza1984; 16 Nov 2008 at 11:06 PM.
Offline   Reply With Quote
Old 16 Nov 2008, 11:34 PM   #5 (permalink)
Fresh Scooby
 
Join Date: Dec 2007
Posts: 28
Re: Bit of help needed

Air filter ok newish apexi power, Fuel injection sytem from what i can gather everything seems to be alright but the injectors when i last had them out because i replaced all the inlet gaskets had like an orangey gunnk around the bottom of them so i cleaded them with some thinners, The fuel filter ive not changed so that could be one to do, The plugs are 12 months old now so im gonna inspect them sometime in the next week or so if i keep the car, As for the oil its not burning any oil i thought this a few months ago but its not when i took the intercooler off there was a bit of oil in the bottom of the intercooler so i thought the turbo might of been passing oil but it was just the normal bit of oil you find in the intercooler piping.

Could the fact that ive not got an uprated fuel pressure regulator fitted cause it to overfuel a bit or cause it to fuel wrong ?
Offline   Reply With Quote
Old 16 Nov 2008, 11:51 PM   #6 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: Bit of help needed

Quote:
Originally Posted by -Ant- View Post
i took the intercooler off there was a bit of oil in the bottom of the intercooler so i thought the turbo might of been passing oil but it was just the normal bit of oil you find in the intercooler piping.

Could the fact that ive not got an uprated fuel pressure regulator fitted cause it to overfuel a bit or cause it to fuel wrong ?
Ya you do get a bit of like black residue at end of intercooler that normal once as you said they not streaming oil out of it as that would indicate worn turbo bearings ya could try changing the fuel filter might help that cheap..........

As for the fuel pressure regulator would imagine this only capable for fuelling standard cars and as your car not standard could be that..............
Offline   Reply With Quote
Old 16 Nov 2008, 11:59 PM   #7 (permalink)
Fresh Scooby
 
Join Date: Dec 2007
Posts: 28
Re: Bit of help needed

Ok cheers, The turbos fine. Im gonna go for changing the fuel filter, Putting a set of new iridium plugs in it, HT leads.

Im gonna source a place to get my injectors cleaned because im gonna strip everything down and replace the inlet gaskets and clean it all out in the next couple of weeks if i get my job tomorrow.
Offline   Reply With Quote
Old 17 Nov 2008, 12:00 AM   #8 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: Bit of help needed

great let us know how it goes
Offline   Reply With Quote
Old 19 Nov 2008, 08:05 PM   #9 (permalink)
Fresh Scooby
 
Join Date: Dec 2007
Posts: 28
Re: Bit of help needed

ok well had an emissions test yesterday at me mate dads garage and the reading was 7 and its surposed to be 0.5 so i dont no if that helps or if thats the normal readings of wrx with a decat but its was 7 not 0.7
Offline   Reply With Quote
Old 20 Nov 2008, 07:21 PM   #10 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: Bit of help needed

Dont know that tbh bout the emissions but seeing what your saying does seem to be to high could be overfuelling running to rich that will up the emissions to could be your problem all along with the heavy fuel consumption
Offline   Reply With Quote
Old 20 Nov 2008, 07:24 PM   #11 (permalink)
Fresh Scooby
 
Join Date: Dec 2007
Posts: 28
Re: Bit of help needed

any one know how much lambdas for on or how to check is its nackerd or not
Offline   Reply With Quote
Old 21 Nov 2008, 12:00 AM   #12 (permalink)
Veteran Scooby
 
uk dave's Avatar
 
Join Date: Feb 2005
Location: Impreza Preservation Society HQ
Posts: 4,399
Send a message via MSN to uk dave
Re: Bit of help needed

Had mine diagnosed when i took it in for a service though werent runnin bad or using excessive fuel,as for how much as an example IMPREZA PARTS 2.0I TURBO GC8/GF8 EJ20G EJ205 94 TO 2000 UK SPEC Lambda Sensor- Oxygen Sensor 3 Wire EJ20 IMPREZA 2.0i Turbo GC8/GF8 EJ20G Engines : 69.95 : Subaru Impreza Turbo Parts, Tuning, Spares & Accessories : 2.0i Turbo GC8/GF8 94 TO 00 UK - E mine were more than that.
__________________
Best sealant used to date- Fourstar ultimate paint protection *Now discontinued* Rebranded as sonus SFX4 paint sealant-Try some ya wont be dissapointed.
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Donnelly denies driver needed as steward. News_Bot Formula News 0 21 Oct 2008 10:00 AM
WSS: Pitt: I needed a bit of luck! News_Bot Superbike News 0 05 Oct 2008 07:10 PM
Pitt: I needed a bit of luck! News_Bot Superbike News 0 05 Oct 2008 06:32 PM
Hirvonen: I needed more speed on Friday. News_Bot Rally News 0 19 May 2008 12:00 PM
BMW: We needed to take risks News_Bot Formula News 0 20 Feb 2008 05:32 PM


All times are GMT. The time now is 08:06 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.