Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza General > Subaru Impreza Discussions

Subaru Impreza Forum

Engine Mods. Advice please!!
Reply
 
LinkBack Thread Tools Display Modes
Old 22 Aug 2007, 03:36 PM   #1 (permalink)
Fresh Scooby
 
minimad69's Avatar
 
Join Date: Apr 2007
Location: Somerset
Posts: 13
Question Engine Mods. Advice please!!

Hello everyone.

Ive been a member here for a while but havnt posted much but im after a bit of advice so hopefully you chaps can answer a few questions for me.

I have a 2003 wrx with 70k on the clock. full service history etc and well maintained. Rescent cam belt change and no problems since ive owned it.

At the moment it has a PPP on it but after a rolling road sesion a few months ago its only putting out 240bhp due to the factory cat not being upgraded i was under the impression the sports cat was part of the PPP putting the wrx power upto 270 ish bhp. first question is can anyone confirm this??

Secondly i have just bought a decat downpipe that replaces the last 2 cats in the system and a cold air induction system. what sort of BHP figures should i expect with these mods ontop of my current mods. Also will the standard fuel pump and injectors be able to cope with the new figures?

Finally how far can this engine be taken perfoemance wise before it starts becoming un reliable?

cheers
Kevin

Last edited by minimad69; 22 Aug 2007 at 04:58 PM.
Offline   Reply With Quote
Old 22 Aug 2007, 06:00 PM   #2 (permalink)
Forum Sponsor
Paid & Proud
 
Join Date: Feb 2005
Location: north east
Posts: 655
sports cat was only part of the STi package..............

you'll probs gain around 15-20 from the de-cat, etc. and everything should cope fine, you'll never get a lot more from that spec due to the turbo
__________________
ASPerformance
UK distributors PIAA, EXE-TC, PERFORMANCE FRICTION
online shop!!
Offline   Reply With Quote
Old 23 Aug 2007, 04:10 PM   #3 (permalink)
Fresh Scooby
 
minimad69's Avatar
 
Join Date: Apr 2007
Location: Somerset
Posts: 13
Well the bits have arived today so hopefully i will be fitting the all the weekend and see if they make much difference

Not to sure about fitting the cold air intake system as it sits in the inner wing, has anyone fitted one of these before and got any hints or tips when fitting them?
Offline   Reply With Quote
Old 23 Aug 2007, 04:34 PM   #4 (permalink)
Super Moderator
Paid & Proud
 
2002pete's Avatar
 
Join Date: Sep 2004
Location: UK
Posts: 14,377
Quote:
Originally Posted by minimad69 View Post
has anyone fitted one of these before and got any hints or tips when fitting them?
Peter UK300 has a K&N Typhoon cold air intake system.

Link: http://www.subaru-impreza.org/bbs/sh...ad.php?t=25625
__________________
Pete.

Offline   Reply With Quote
Old 23 Aug 2007, 04:47 PM   #5 (permalink)
Fresh Scooby
 
minimad69's Avatar
 
Join Date: Apr 2007
Location: Somerset
Posts: 13
cheers for that 2002pete, ive found a few guides on the net for installing and doesnt look too dificult so i will give it a go the weekend

saying that im a tad concerned about the problems with the MAF although mines a later model so should be ok i hope
Offline   Reply With Quote
Old 23 Aug 2007, 07:40 PM   #6 (permalink)
Super Moderator
Paid & Proud
 
Tidgy's Avatar
 
Join Date: Apr 2006
Location: Nottingham
Posts: 18,743
alot of fuss is made about maf failures but tbh you have to be very unlucky to do any real damage, if it starts running rough, boosting all over the place then back off and get it looked at, if you have issues keep it off the boost untill looked at to be on the safe side
__________________
PM, Squirrels best friend, cream egg king and resident .org spam tart/Perv
Offline   Reply With Quote
Old 24 Aug 2007, 05:21 PM   #7 (permalink)
Fresh Scooby
 
minimad69's Avatar
 
Join Date: Apr 2007
Location: Somerset
Posts: 13
well the induction system is now fitted, sounds absolutely wicked and does make the throttle response seem a tad better. Fitted in under an hour which wasnt too bad and no signs of any trouble o far, cars still running perfect

Also had a silicon inlet pipe to fit onto the turbo but couldnt see how to remove the old one without taking off the inlet manifolds so thats now sat on the shelf collecting dust.

Next will be the de-cats but got to wait untill the mini turbo im working on is off the ramps to get under the car properly and make life a tad easier
Offline   Reply With Quote
Old 24 Aug 2007, 05:44 PM   #8 (permalink)
Super Moderator
Paid & Proud
 
2002pete's Avatar
 
Join Date: Sep 2004
Location: UK
Posts: 14,377
Quote:
Originally Posted by minimad69 View Post
cars still running perfect
Great news!
__________________
Pete.

Offline   Reply With Quote
Old 28 Aug 2007, 04:14 PM   #9 (permalink)
Fresh Scooby
 
minimad69's Avatar
 
Join Date: Apr 2007
Location: Somerset
Posts: 13
Had another nice surprise today , phoned my insurance company keithmichaels.co.uk to declaire the lastest mods and there was no change to my premium
Offline   Reply With Quote
Old 28 Aug 2007, 06:09 PM   #10 (permalink)
Super Moderator
Paid & Proud
 
2002pete's Avatar
 
Join Date: Sep 2004
Location: UK
Posts: 14,377
Quote:
Originally Posted by minimad69 View Post
No change to my premium
__________________
Pete.

Offline   Reply With Quote
Old 29 Aug 2007, 11:22 AM   #11 (permalink)
Super Moderator
Paid & Proud
 
Tidgy's Avatar
 
Join Date: Apr 2006
Location: Nottingham
Posts: 18,743
hehe, gary has always said no extra charge everytime i ring him to add bits and bobs lol
__________________
PM, Squirrels best friend, cream egg king and resident .org spam tart/Perv
Offline   Reply With Quote
Old 29 Aug 2007, 12:28 PM   #12 (permalink)
Fresh Scooby
 
minimad69's Avatar
 
Join Date: Apr 2007
Location: Somerset
Posts: 13
Quote:
Originally Posted by Tidgy View Post
hehe, gary has always said no extra charge everytime i ring him to add bits and bobs lol
have you received a new certificate each time you have added any mods Tidgy, i forgot to ask about it on the phone and emailed him yesterday asking about it but had no response as yet
Offline   Reply With Quote
Old 29 Aug 2007, 03:16 PM   #13 (permalink)
jd
Obsessed Scooby
Paid & Proud
 
jd's Avatar
 
Join Date: Mar 2005
Location: here
Posts: 6,414
Send a message via MSN to jd
Quote:
Originally Posted by Tidgy View Post
hehe, gary has always said no extra charge everytime i ring him to add bits and bobs lol
same for me, still no extra. in fact went down this year LOL
__________________
blah blah blah
Offline   Reply With Quote
Old 29 Aug 2007, 03:57 PM   #14 (permalink)
Super Moderator
Paid & Proud
 
Tidgy's Avatar
 
Join Date: Apr 2006
Location: Nottingham
Posts: 18,743
Quote:
Originally Posted by minimad69 View Post
have you received a new certificate each time you have added any mods Tidgy, i forgot to ask about it on the phone and emailed him yesterday asking about it but had no response as yet
no mate, ask him to fax me a list of the mods to have to hand if i get stopped, but thats all
__________________
PM, Squirrels best friend, cream egg king and resident .org spam tart/Perv
Offline   Reply With Quote
Old 09 Sep 2007, 07:19 PM   #15 (permalink)
Fresh Scooby
 
minimad69's Avatar
 
Join Date: Apr 2007
Location: Somerset
Posts: 13
After weeks of having my decat pipe sat in the boot of the scooby i finally managed to get it over to the workshop today and get it fitted, OMG what an arse of a job that was took about 4 hrs in total but finally got it sorted, luckily the 4 poster ramp made life a lot easier

Everything seems to be runing fine now its fitted, idles fine and no engine management light or problems so far.

One thing ive noticed now though is you can clearly hear the turbo spooling up from about 2500 rpm which wasnt very noticable before and from 3k onwards all you hear is the cold air induction.

is this normal to hear the turbo sppoling up when fitting a decat?
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
advice please, engine light on ONCE AGAIN... ozbod1 Electrical (Including ICE) 6 28 May 2008 08:03 PM
16 important OIL questions and answers oilman Technical General 0 23 Jan 2008 03:31 PM
2007 2.5i US version engine mods? RaceFaceXC Subaru Impreza Discussions 3 02 Oct 2007 11:21 AM
OUTSTANDING NEW ‘BOXER’ ENGINE FOR ’06 LEGACY RANGE skylight General Chat - Anything about Anything 3 03 Aug 2005 10:15 AM
Engine oil & spark plugs advice scoobylee Engine Bay 9 22 Mar 2005 09:50 PM


All times are GMT. The time now is 09:50 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.