Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza General > Subaru Impreza Discussions

Subaru Impreza Forum

What would you guy's do if you had this much problem's with your car!!!
Reply
 
LinkBack Thread Tools Display Modes
Old 19 Jun 2006, 12:55 PM   #1 (permalink)
Regular Scooby
 
girlyracer's Avatar
 
Join Date: Feb 2006
Posts: 116
What would you guy's do if you had this much problem's with your car!!!

Hi guy's

just thought i would get some feed back to see what you would do if you had this much problem:

enjoy the list:
Faults with car


26th Feb. Placed order for car.
4th March picked car up.
6th March car went back as not running right had car 5 weeks and replaced short block pre-cat and cat plus sensors to get running right.
10th April got car back.
11th April car went back as engine management light came on.
14th April car went back again for engine management light came on again and had to have coil pack ordered for it.
24th April went back and had a 1000 mile service and the coil packs replaced.
8th May the engine management light came on + not running right need new neutral gear sensor switch.
12th May went and had switch fitted.
15th May to go to the garage again and have a turbo pipe replaced.
16th May had to have the car picked up on a flatbed recovery truck as oil pipe had not been fitted correctly, so lost all engine oil.
18th May lost all power again, while at dealers we try to sort out another car but had know joy s would not give the right money for my car they only wanted to give me 11,000 pounds when I paid 13,495 for it 12 weeks ago.
23rd May went back to find out what the problem with the car is, they rang me and said they need a new turbo on it.
31st May rang me to say the received the turbo but was not the right one said they would not be able to get the right one till Monday 5th June.
6th June they rang me to say the have got the new turbo but wont be able to fit it till the following day.
7th June they rang me to say the have fitted the new turbo but car was still not running right.
9th June spoke to them again today to find out that they reckon the car is not running right on the left side off the engine saying it might be the gaps in the tappets might need setting as the clearance might be wrong and if that is not the problem they are going to have to take the engine apart again, plus I asked for the manager to ring me but he has not as usual .
13th June got a phone call saying that they found the problem; they have said that two of the pistons or piston rings are broken and that they are waiting for the go ahead to sort it.
16th June the service manager rang me to say he has got all the parts to put the car back together and should be ready on Tuesday 20th June well I will wait and see.

lottie and david
Offline   Reply With Quote
Old 19 Jun 2006, 01:07 PM   #2 (permalink)
jd
Obsessed Scooby
Paid & Proud
 
jd's Avatar
 
Join Date: Mar 2005
Location: here
Posts: 6,414
Send a message via MSN to jd
was it a new car you ordered?
__________________
blah blah blah
Offline   Reply With Quote
Old 19 Jun 2006, 01:42 PM   #3 (permalink)
bob
Senior Scooby
Paid & Proud
 
bob's Avatar
 
Join Date: Jul 2004
Location: Bristol UK
Posts: 1,547
16th May had to have the car picked up on a flatbed recovery truck as oil pipe had not been fitted correctly, so lost all engine oil.

This would have done then engine no good, no wonder you have piston ring problems...
Offline   Reply With Quote
Old 19 Jun 2006, 01:46 PM   #4 (permalink)
Dr. Infrastructure
Paid & Proud
 
Gaza's Avatar
 
Join Date: Jun 2006
Location: Washington, D.C.
Posts: 5,178
Send a message via AIM to Gaza
Sounds like a lemon. I would have returned it.
__________________
Gary
2007 STi
-Cobb AP; Turbo XS RFL; SPT Cat-back;18" Gram Lights
Offline   Reply With Quote
Old 19 Jun 2006, 03:08 PM   #5 (permalink)
Obsessed Scooby
Paid & Proud
 
PeterUK300's Avatar
 
Join Date: Apr 2004
Location: East Herts
Posts: 12,081
Is this a new WRX ?? as 13,495 is so so cheap.....
I take it is as you mention 1000 mile service....
IF NEW...
I would defo speak to Trading standards as this must warrant a replacement..
Also give Watchdog a try......
__________________
All the best
Pete

http://www.scoobyweb.co.uk
Offline   Reply With Quote
Old 19 Jun 2006, 03:39 PM   #6 (permalink)
Regular Scooby
 
girlyracer's Avatar
 
Join Date: Feb 2006
Posts: 116
no the car is a 51 plate uk300

the reason it had 1000 mile service is because it had a new bottom end fitted in it

lotie and david

Last edited by girlyracer; 19 Jun 2006 at 03:45 PM.
Offline   Reply With Quote
Old 19 Jun 2006, 04:39 PM   #7 (permalink)
Veteran Scooby
 
uk dave's Avatar
 
Join Date: Feb 2005
Location: Impreza Preservation Society HQ
Posts: 4,399
Send a message via MSN to uk dave
Quote:
Originally Posted by girlyracer
Hi guy's

just thought i would get some feed back to see what you would do if you had this much problem:

enjoy the list:
Faults with car


26th Feb. Placed order for car.
4th March picked car up.
6th March car went back as not running right had car 5 weeks and replaced short block pre-cat and cat plus sensors to get running right.
10th April got car back.
11th April car went back as engine management light came on.
14th April car went back again for engine management light came on again and had to have coil pack ordered for it.
24th April went back and had a 1000 mile service and the coil packs replaced.
8th May the engine management light came on + not running right need new neutral gear sensor switch.
12th May went and had switch fitted.
15th May to go to the garage again and have a turbo pipe replaced.
16th May had to have the car picked up on a flatbed recovery truck as oil pipe had not been fitted correctly, so lost all engine oil.
18th May lost all power again, while at dealers we try to sort out another car but had know joy s would not give the right money for my car they only wanted to give me 11,000 pounds when I paid 13,495 for it 12 weeks ago.
23rd May went back to find out what the problem with the car is, they rang me and said they need a new turbo on it.
31st May rang me to say the received the turbo but was not the right one said they would not be able to get the right one till Monday 5th June.
6th June they rang me to say the have got the new turbo but wont be able to fit it till the following day.
7th June they rang me to say the have fitted the new turbo but car was still not running right.
9th June spoke to them again today to find out that they reckon the car is not running right on the left side off the engine saying it might be the gaps in the tappets might need setting as the clearance might be wrong and if that is not the problem they are going to have to take the engine apart again, plus I asked for the manager to ring me but he has not as usual .
13th June got a phone call saying that they found the problem; they have said that two of the pistons or piston rings are broken and that they are waiting for the go ahead to sort it.
16th June the service manager rang me to say he has got all the parts to put the car back together and should be ready on Tuesday 20th June well I will wait and see.

lottie and david
dont think i`d want to keep the car to be honest-how many miles are on it??? (car not engine.)could do with seeing a solicitor-had problems with a 106gti i had new and customer relations manager of peugeot uk said we can offer you a price for the car but wont give the full refund basically the same as youve been told said to him what if thats not good enough said id have to get a solicitor involved-it were paintwork problems so got it done meself in the end coz would sooner have a gd car mechanically and sort the paint meself than a unreliable car which is a nightmare-you need to know what your rights are though in this situation but other than that you could see if it runs half decent and sell it.
__________________
Best sealant used to date- Fourstar ultimate paint protection *Now discontinued* Rebranded as sonus SFX4 paint sealant-Try some ya wont be dissapointed.
Offline   Reply With Quote
Old 19 Jun 2006, 05:18 PM   #8 (permalink)
Obsessed Scooby
Paid & Proud
 
PeterUK300's Avatar
 
Join Date: Apr 2004
Location: East Herts
Posts: 12,081
Quote:
Originally Posted by girlyracer
no the car is a 51 plate uk300

the reason it had 1000 mile service is because it had a new bottom end fitted in it

lotie and david
Thought that was what you had, the 1000 mile service threw me.....

Well to be honest as it is previously owned and they are doing everything they can to rectify I am not sure you could ask for much more....

As stated above still worth seeking legal advice though.

If the engine has been rebuilt correctly then that should cure all problems. Ensure you get a further 12 months warranty on the engine if not the whole car in way for compensation for all the agro..
__________________
All the best
Pete

http://www.scoobyweb.co.uk
Offline   Reply With Quote
Old 20 Jun 2006, 12:54 AM   #9 (permalink)
bob
Senior Scooby
Paid & Proud
 
bob's Avatar
 
Join Date: Jul 2004
Location: Bristol UK
Posts: 1,547
New engine and lost the oil...Not surprised you had ring problem and turbo problems. Swarf must be all round the system..Would not be suprised if the bottom end starts playing up next. Don't think I would keep this car. Most prob have to take a loss but it may pay in the end.
Offline   Reply With Quote
Old 20 Jun 2006, 08:09 AM   #10 (permalink)
Regular Scooby
 
girlyracer's Avatar
 
Join Date: Feb 2006
Posts: 116
the problem is that they are a newish dealership and they have only got one fully quailfied service man there

plus the managerment is not very good as they don't return your calls and they don't even wanna come to some kind off agreement with this either

david
Offline   Reply With Quote
Old 20 Jun 2006, 11:12 AM   #11 (permalink)
Veteran Scooby
 
uk dave's Avatar
 
Join Date: Feb 2005
Location: Impreza Preservation Society HQ
Posts: 4,399
Send a message via MSN to uk dave
wouldnt neccesarily trust them to be working on a subaru engine to be fair then meself,dont really know what to tell ya-would be tempted to see where ya stand and see if you could have a specialists/subaru dealer do the work then bill them if you dont trust them, can see it getting a bit messy though.
__________________
Best sealant used to date- Fourstar ultimate paint protection *Now discontinued* Rebranded as sonus SFX4 paint sealant-Try some ya wont be dissapointed.
Offline   Reply With Quote
Old 20 Jun 2006, 06:27 PM   #12 (permalink)
Super Moderator
Paid & Proud
 
Tidgy's Avatar
 
Join Date: Apr 2006
Location: Nottingham
Posts: 18,743
bit of a bad issue this one, first of go see a lawyer, you may have to pay but they can tell you what your rights are and arn't.

personally i wouldn't keep the car, unless they pay a reputable company to rebuild the engine (due to them seeming to be unable to) and some considerable compensation for your trouble.
__________________
PM, Squirrels best friend, cream egg king and resident .org spam tart/Perv
Offline   Reply With Quote
Old 21 Jun 2006, 08:35 AM   #13 (permalink)
Regular Scooby
 
girlyracer's Avatar
 
Join Date: Feb 2006
Posts: 116
lol still not got the car back they have told me that i might get it back at the weekend but which weekend i don't know
Offline   Reply With Quote
Old 21 Jun 2006, 08:41 AM   #14 (permalink)
Administrator
 
skylight's Avatar
 
Join Date: Apr 2004
Location: Here and S.Wales
Posts: 13,155
your doing a good job keeping your records up to date - if i were you id make a fuller account with proof (reciepts) etc etc just in case:

This trip may solve your problems but as Bob says...

Good luck, please do keep us informed.
Offline   Reply With Quote
Old 22 Jun 2006, 09:01 AM   #15 (permalink)
Regular Scooby
 
girlyracer's Avatar
 
Join Date: Feb 2006
Posts: 116
spoke to those idiots at subaru yesturday, not god news at all they said that the engine was in the car and that every thing is back in and on the car but it is still not running right they are saying that the engine is missing on number 3 and 4 lol
they said that could be because the valve clearance might not be right.

god i think that they should have got some monkeys from a near by zoo to fix as i reckon they could do a better job than those retards

david
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Button: I have no problems with motivation. News_Bot Formula News 0 02 Jul 2008 12:28 PM
Radiator Problems - White Fluid Provik Engine Bay 3 30 Jun 2007 10:54 PM
new car,clutch problems. tricky07773 Engine Bay 5 19 Mar 2007 07:12 PM
General Problems after new server skylight General Chat - Anything about Anything 2 17 Aug 2004 07:16 AM


All times are GMT. The time now is 09:47 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.