Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza General > Subaru Impreza Discussions

Subaru Impreza Forum

high idle problem
Reply
 
LinkBack Thread Tools Display Modes
Old 08 Jan 2012, 05:27 PM   #1 (permalink)
Fresh Scooby
 
Join Date: Nov 2010
Location: Isle of Wight
Posts: 6
high idle problem

Hi,

i have MAF sensor problems on my MY97 impreza STI
they keep blowing
my car idles at 1500rpm
ive changed o2, temp, MAF 6 times, cleaned throttle body, TPS twice and ICV 3 times
what would you suggest?
i want to get rid of the car but cant until its working properly
thanks alot
Jamie

vf34 turbo, only mod
Offline   Reply With Quote
Old 08 Jan 2012, 06:09 PM   #2 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: high idle problem

any mods to the airbox or piping? just wondering if a vibration is causing the issue.
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 08 Jan 2012, 06:17 PM   #3 (permalink)
Fresh Scooby
 
Join Date: Nov 2010
Location: Isle of Wight
Posts: 6
Re: high idle problem

Quote:
Originally Posted by bugeye_bob View Post
any mods to the airbox or piping? just wondering if a vibration is causing the issue.
the turbo intake pipe was cut by previous owner for some unknown reason, its just a little shorter where meets the air intake pipe, i have turned some aluminum then joined both together and tightened with jubilees
cheers
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
High idle lillpete Technical General 18 19 Feb 2012 10:14 AM
IDC High idle rubix Engine Bay 4 10 Dec 2011 09:37 PM
Idle problem type r_v-limited Technical General 19 06 May 2010 01:42 PM
Idle Problem '97 2.0gl dude2k85 Engine Bay 1 13 Dec 2009 11:30 PM
High Idle Problem on Bugeye myles Technical General 3 06 Jan 2008 09:50 AM


All times are GMT. The time now is 08:53 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.