Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza General > Subaru Impreza Discussions

Subaru Impreza Forum

Couple of questions
Reply
 
LinkBack Thread Tools Display Modes
Old 23 Nov 2011, 11:13 PM   #1 (permalink)
Young Scooby
 
Join Date: Jun 2009
Posts: 89
Couple of questions

Hi guys just recently got the scooby back out of the garage after being parked up for a while. Got a couple of issues.

I have a 1995 wrx import.
Has anyone experienced their fuel pump relay intermittently cutting out as driving seems to be worse in the morning. Have re wired the feed wires to the relay coil with no affect and changed cam and crank sensor. Checked the crank sensor wiring, checked the ecu earths. Was wondering if anyone else had the problem before i start a lot of wiring work to get to the bottom of this. Have had so many ideas on the possibilities im being lazy trying to find a quick answer.

Second has anyone decat their car with remap

Last one if your still reading has anyone tried a polar performance chipped ecu. i have aquired one. The car seems to be boosting low. With standard ecu 0.5bar and polar performance ecu 0.7 bar.. Wondering on the accuracy of my boost gauage to be honest as i hear the dump valve make a little noise when the gauge is reading vacuum. Just before it reads boost.

Cheers for looking
Offline   Reply With Quote
Old 24 Nov 2011, 12:32 AM   #2 (permalink)
Senior Scooby
 
Join Date: Jan 2010
Posts: 1,370
Re: Couple of questions

Is the dump valve sticking after lying up for a while ?
Offline   Reply With Quote
Old 24 Nov 2011, 07:35 PM   #3 (permalink)
Young Scooby
 
Join Date: Jun 2009
Posts: 89
Re: Couple of questions

Quote:
Originally Posted by shambles View Post
Is the dump valve sticking after lying up for a while ?
Hi no taken the dump valve off just incase
Offline   Reply With Quote
Old 25 Nov 2011, 09:32 AM   #4 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
Re: Couple of questions

.5 bar is the factory boost on the early classic iirc fella...you wont get alot more unless you fit an aftermarket ECU and supporting mods along with a remap..
__________________
Mapped by Enginetuner(Plymouth)..
Offline   Reply With Quote
Old 25 Nov 2011, 10:19 PM   #5 (permalink)
Young Scooby
 
Join Date: Jun 2009
Posts: 89
Re: Couple of questions

Cheers fella. Trying to work out all the different versions and power outputs of all the impreza. Been told the z4 ecu best stock one and boosts to 0.9bar is that right.
Cheers
Offline   Reply With Quote
Old 26 Nov 2011, 11:57 AM   #6 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
Re: Couple of questions

it's ment to be the better of the O/E ECU's,boost sounds about right..
__________________
Mapped by Enginetuner(Plymouth)..
Offline   Reply With Quote
Old 27 Nov 2011, 02:39 PM   #7 (permalink)
Fresh Scooby
 
brayden's Avatar
 
Join Date: Aug 2011
Location: nottingham
Posts: 22
Re: Couple of questions

hi m8 does my car need a service its only done a just under a 1000 miles since the last service that was in march iv not long bought the car iv bought the servive kit just not sure if the oil actually needs doin yet thanks
Offline   Reply With Quote
Old 27 Nov 2011, 02:57 PM   #8 (permalink)
Super Moderator
Paid & Proud
 
Tidgy's Avatar
 
Join Date: Apr 2006
Location: Nottingham
Posts: 18,743
Re: Couple of questions

no need to change oil at 1k, 5k is about the norm or 12 months depending on what comes first
__________________
PM, Squirrels best friend, cream egg king and resident .org spam tart/Perv
Offline   Reply With Quote
Old 04 Dec 2011, 05:54 PM   #9 (permalink)
Young Scooby
 
Join Date: Jun 2009
Posts: 89
Re: Couple of questions

Well after much searching through wiring found a fault with the crankshaft sensor wiring. Run myself a new twisted pair. The fuel pump relay has been fine ever since. Found a fault with the boost gauge. Put a new one on and all sorted boosting at 0.9bar now.
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Couple of questions... stevie3000 Subaru Impreza Discussions 4 27 Mar 2010 10:13 PM
couple of questions/problems JonnyW Subaru Impreza Discussions 4 20 Jan 2009 06:11 PM
Couple of questions howhardcanitbe Technical General 3 12 Dec 2008 01:02 PM
A couple of Newbie questions Grovesy Subaru Impreza Discussions 1 26 Sep 2006 10:31 AM
A couple of questions...... mcc_boz Technical General 3 01 Nov 2005 05:45 PM


All times are GMT. The time now is 09:02 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.