Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza General > Subaru Impreza Discussions

Subaru Impreza Forum

Hate to say im actually starting to dislike Imprezas
Reply
 
LinkBack Thread Tools Display Modes
Old 14 Sep 2011, 07:48 PM   #1 (permalink)
Cool Scooby
 
Join Date: Nov 2009
Posts: 211
Hate to say im actually starting to dislike Imprezas

Hi i have now owned 2 imprezas and the first failed, fuel gauge stopped working, then fuel ran out, then car never recovered from this. I have just bought a second one and car drove car 170 miles back home with broken fuel gauge, i decided to change the ecu and all seemed ok, then changed to alloy rad and then the fuel ran out. Now battery has died within 24 hours of its previous start? I have a toad thatcham system and i have a feeling that the immobiliser has gone on as now the car wont fire at all. There is about 15 litres of fuel in the car as put it in today so i know there is enough fuel in the car to start it. I ran some injector cleaner through the car incase the pump had pulled any rubbish up from the bottom of the tank, but like i say the car doesnt ignite at all. Changed fuel filter incase that was clogged but no start. I know what i need to do is turn the car over take the hose off the filter and catch the fuel which i will do tomorrow, but what i wanted to ask was could the immobiliser have stayed on if the battery was going flat? Is there anything else anyone can recommend, im close to being put off imprezas for life sadly, a car i loved through childhood and through my teens and now having been lucky or unlucky some might say with the two ive had im considering scrapping the new one too unless can get her started quickly. As much help will be appreciated. Regards Gareth
Offline   Reply With Quote
Old 14 Sep 2011, 09:07 PM   #2 (permalink)
Obsessed Scooby
 
The Pilot's Avatar
 
Join Date: Jul 2006
Location: Bay of Tor...
Posts: 6,567
Re: Hate to say im actually starting to dislike Imprezas

seems to me your buying sheds and making them worse

flat battery,immobiliser,etc,i bet you've overlooked the alternator,get it checked,probably on it's way out hence the charge draining so quickly,also,if your not confident or compident in doing any work on a scoob,take it to someone who knows what to do and how they behave,a friend has made the same mistake with his car,he's chucked plenty of cash at it but it's still not right,mainly because he he has no idea and he still can't get it into his head that you can#t mod the nuts off a P1 and expect it to work without remapping for any additional mods...
__________________
Mapped by Enginetuner(Plymouth)..
Offline   Reply With Quote
Old 15 Sep 2011, 10:54 AM   #3 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,563
Re: Hate to say im actually starting to dislike Imprezas

sounds like you need a field, a gallon of petrol and a box of matches.
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 15 Sep 2011, 11:41 AM   #4 (permalink)
Cool Scooby
 
Join Date: Nov 2009
Posts: 211
Re: Hate to say im actually starting to dislike Imprezas

Mistake ive made with this one was the sender unit stopped working as was driving it home. Id only ever buy an early classic so have to expect issues with the older cars. Im a subaru enthusiast and will always buy the older shape as i feel it represents subaru best personally. Annoying thing is it was working fine, some basic mods which dont require any sort of remap and the car dont work at all. As they say if it aint broke lol.
Offline   Reply With Quote
Old 15 Sep 2011, 04:21 PM   #5 (permalink)
Cool Scooby
 
Join Date: Nov 2009
Posts: 211
Re: Hate to say im actually starting to dislike Imprezas

Just a quick question gents, how do you test the voltage running through the alternator? Ive tested the battery and there is approx 12 volts running through it so popped this on charge as i understand to get everything to run properly the batt needs about 12.4 volts, but i stand corrected. Do you attach the volt meter to the male plug on the top left hand side of the alternator (95 wrx) if i unplug this and push the +ve and -ve wires from the volt meter into the alternator i get no lights at all? Also does the ignition need to be switched a quarter turn? The fuel pump is working as removed the top pipe after the fuel filter and the fuel is pumping through. Regards Gareth
Offline   Reply With Quote
Old 15 Sep 2011, 04:48 PM   #6 (permalink)
Obsessed Scooby
 
stiimpreza1984's Avatar
 
Join Date: Jul 2008
Location: Cork, Ireland
Posts: 7,475
Re: Hate to say im actually starting to dislike Imprezas

As Ed said you try the alternator had to change an alternator in another jap import car before because it was faulty got the alternator rebuilt and it turned out the voltage regulator in it was the problem, no problem ever since the old alternator would only barely charge the battery and after 8 hours the batt was dead this could be your prob
__________________
SEE NO EVO HEAR NO EVO!
Offline   Reply With Quote
Old 15 Sep 2011, 04:52 PM   #7 (permalink)
Senior Scooby
 
Join Date: Jan 2010
Posts: 1,370
Re: Hate to say im actually starting to dislike Imprezas

you should be getting 14 - 1.5 volts on a runing alternator
Offline   Reply With Quote
Old 15 Sep 2011, 04:52 PM   #8 (permalink)
Senior Scooby
 
Join Date: Jan 2010
Posts: 1,370
Re: Hate to say im actually starting to dislike Imprezas

14 - 14.5 even
Offline   Reply With Quote
Old 15 Sep 2011, 07:07 PM   #9 (permalink)
Cool Scooby
 
Join Date: Nov 2009
Posts: 211
Re: Hate to say im actually starting to dislike Imprezas

this is the problem gents the car wont start? Ive not got a fully charged battery on there and nothing. Engine tries to turn over but doesnt ignite. Is it possible when the battery was dying on me that the immobiliser has gone on? Although when i turn the key a quarter turn and all the lights on the dash come on, fuel comes out the filter, im not sure if the immobilisor wld cut the fuel supply? Its a toad ai606 alarm and imm if this helps. Any ideas if it might be worth re-setting the alarm/immobilisor and if so whats the best way to do it? Really appreciate your help guys. Gareth
Offline   Reply With Quote
Old 20 Sep 2011, 08:51 PM   #10 (permalink)
Fresh Scooby
 
Join Date: Sep 2011
Posts: 1
Lightbulb Re: Hate to say im actually starting to dislike Imprezas

You may be chasing linked problems not just one.

If you have a poor earth on starter motor or block or battery, this might pull the voltage down to a point where your alarm interferes with ignition.

This might be because the alarm is faulty too.

If the battery has been hammered from trying to start, then a cell could be fried, and so holding a charge will be poor.

If your starter has been worked hard, it might be damaged and be offering resistance or under performing, further loading the battery.

Your alternator may be needing a refresh too, but not necessarily connected to the other faults.

My suggestion is eliminate these above. Alarms are notorious for messing electrics up. Remove this problem first, then work your way through the others.

MAF and ECU not to be overlooked either.
Offline   Reply With Quote
Old 22 Sep 2011, 10:47 AM   #11 (permalink)
Cool Scooby
 
Join Date: Nov 2009
Posts: 211
Re: Hate to say im actually starting to dislike Imprezas

thanks for the help Polainm. Good news, ive changed spak plugs and car now working fine, have to say looks like the plugs had been in the car for at least 10 years they were black! All good now, but thanks for the advice guys.
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Difference between UK and Japanese Imprezas Gears Subaru Impreza Discussions 7 22 Sep 2011 07:29 PM
my imprezas a lemon scoobyman Newbies - Say Hello Here 0 14 Nov 2009 05:19 PM
If there were no Imprezas . . . rikimaru General Chat - Anything about Anything 31 12 Nov 2009 08:41 PM
Non Turbo Imprezas NAscooby85 Subaru Impreza Discussions 5 29 Sep 2007 08:03 PM
Top two confirm dislike of chicane. News_Bot Formula News 0 13 May 2007 09:32 AM


All times are GMT. The time now is 08:18 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.