Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru Impreza General > Subaru Impreza Discussions

Subaru Impreza Forum

Subaru Impreza acceleration problems
Reply
 
LinkBack Thread Tools Display Modes
Old 08 Mar 2011, 07:09 AM   #1 (permalink)
Fresh Scooby
 
Join Date: Mar 2011
Posts: 1
Subaru Impreza acceleration problems

hi my car is a Subaru Impreza 05 2.5ltr auto it starts fine but when you go to pull away it feels like there's nothing there and will only pull away very slowly even if you have your foot to the floor. if you hold your foot down it does pick up and accelerate after a few seconds. the problem becomes a bit better when the engine has warmed up but is still there. Theres also a grinding noise in the front right hand wheel its pretty distinct when you turn, searching around on the Internet i found that it could be that the bearings need to be replaced anybody have any other ideas any help would be much appreciated
Offline   Reply With Quote
Reply

Bookmarks

Tags
acceleration problems


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Impreza Applied Model/Engine Codes 2002pete Technical General 40 02 Jul 2015 06:22 PM
Info: Subaru Engines and Conversion Principles djquest Modifications - Tips and Tricks 10 19 Dec 2011 12:16 PM
Immobiliser problems in a Subaru Impreza 1993 sarah Electrical (Including ICE) 2 30 May 2009 09:03 AM


All times are GMT. The time now is 12:35 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.