Go Back   Subaru Impreza Forum - WRX STI Rally Performance Tuning > Subaru-Impreza.org > Newbies - Say Hello Here

Subaru Impreza Forum

Has my 54 WRX had Prodrive upgrades???
Reply
 
LinkBack Thread Tools Display Modes
Old 31 Aug 2010, 07:59 PM   #1 (permalink)
Young Scooby
 
grinch6301's Avatar
 
Join Date: Aug 2010
Location: Aberdeen
Posts: 70
Has my 54 WRX had Prodrive upgrades???

Hey, just bought a 54 WRX wagon and i'm a little unsure about the mods that have been done it. It has the 18in OZ gold prodrive alloys. The ride feels a lot harder and it sits really low. Also the springs are red so i think this has been upgraded as well. The exhaust system has been upgraded from the down pipe back. It doesnt have the blue intercooler pipe or a prodrive intercooler though.
Any help would be greatly appreciated
Cheers
Kev
Offline   Reply With Quote
Old 31 Aug 2010, 08:07 PM   #2 (permalink)
Veteran Scooby
 
bugeye_bob's Avatar
 
Join Date: Mar 2009
Location: UK-Earth - Search google maps for "The Stig"
Posts: 4,566
Re: Has my 54 WRX had Prodrive upgrades???

If Prodrive upgraded it then they will have a record of it.
__________________
-- .. ... ... .. -. --. / -... ..- - / -. --- - / ..-. --- .-. --. --- - - . -.
Offline   Reply With Quote
Old 01 Sep 2010, 06:59 AM   #3 (permalink)
Super Moderator
Paid & Proud
 
2002pete's Avatar
 
Join Date: Sep 2004
Location: UK
Posts: 14,377
Re: Has my 54 WRX had Prodrive upgrades???

18in OZ gold prodrive alloys and the red springs are not part of the WRX Prodrive Performance Pack. Only the STi got the sports cat "down-pipe"
__________________
Pete.

Offline   Reply With Quote
Old 02 Sep 2010, 09:47 PM   #4 (permalink)
Young Scooby
 
grinch6301's Avatar
 
Join Date: Aug 2010
Location: Aberdeen
Posts: 70
Re: Has my 54 WRX had Prodrive upgrades???

Thanks for the reply, as you could probably see I'm new to the impreza scene. I'm having some issues my car rubbing on the back arches. I've been told that it could be because the tyre sizes are wrong for the alloys i have. They are P1 Oz alloys with 225/40/18 tyres. Does anyone know if they are the correct tyres? The rubbing was only on one side, i swapped the wheels round and the rubbing swapped sides as well so i'm guessing its tyre problem??? Really cant be done with the car rubbing any time i have i have a paasenger so i'm desperate to figure this out!
Cheers
Kev
Offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Posted as requested by Prodrive skylight National Meetings and Track Days 12 29 May 2007 05:04 PM
Anyone ever removed Prodrive suspension upgrades. abaddon Technical General 0 20 Nov 2005 11:07 PM


All times are GMT. The time now is 02:04 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
LinkBacks Enabled by vBSEO 3.6.0 PL2 © 2011, Crawlability, Inc.